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Basic Safety Instructions 

Always read through and comply with the following safety instructions! 

All plants and locations of the Rohde & Schwarz group of companies make every effort to keep the safety 

standards of our products up to date and to offer our customers the highest possible degree of safety. Our 

products and the auxiliary equipment they require are designed, built and tested in accordance with the 

safety standards that apply in each case. Compliance with these standards is continuously monitored by 

our quality assurance system. The product described here has been designed, built and tested in 

accordance with the EC Certificate of Conformity and has left the manufacturer’s plant in a condition fully 

complying with safety standards. To maintain this condition and to ensure safe operation, you must 

observe all instructions and warnings provided in this manual. If you have any questions regarding these 

safety instructions, the Rohde & Schwarz group of companies will be happy to answer them. 

Furthermore, it is your responsibility to use the product in an appropriate manner. This product is designed 

for use solely in industrial and laboratory environments or, if expressly permitted, also in the field and must 

not be used in any way that may cause personal injury or property damage. You are responsible if the 

product is used for any purpose other than its designated purpose or in disregard of the manufacturer's 

instructions. The manufacturer shall assume no responsibility for such use of the product.  

The product is used for its designated purpose if it is used in accordance with its product documentation 

and within its performance limits (see data sheet, documentation, the following safety instructions). Using 

the product requires technical skills and, in some cases, a basic knowledge of English. It is therefore 

essential that only skilled and specialized staff or thoroughly trained personnel with the required skills be 

allowed to use the product. If personal safety gear is required for using Rohde & Schwarz products, this 

will be indicated at the appropriate place in the product documentation. Keep the basic safety instructions 

and the product documentation in a safe place and pass them on to the subsequent users. 

Observing the safety instructions will help prevent personal injury or damage of any kind caused by 

dangerous situations. Therefore, carefully read through and adhere to the following safety instructions 

before and when using the product. It is also absolutely essential to observe the additional safety 

instructions on personal safety, for example, that appear in relevant parts of the product documentation. In 

these safety instructions, the word "product" refers to all merchandise sold and distributed by the Rohde & 

Schwarz group of companies, including instruments, systems and all accessories. For product-specific 

information, see the data sheet and the product documentation. 

Safety labels on products 

The following safety labels are used on products to warn against risks and dangers. 

Symbol Meaning Symbol Meaning 

 

Notice, general danger location 

Observe product documentation 

    
ON/OFF  Power  

 

Caution when handling heavy equipment 

 

Standby indication 

 

Danger of electric shock  Direct current (DC) 
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Symbol Meaning Symbol Meaning 

 

 Caution ! Hot surface  Alternating current (AC) 

 

Protective conductor terminal  

To identify any terminal which is intended for 

connection to an external conductor for 

protection against electric shock  in case of a 

fault, or the terminal of a protective earth 

 Direct/alternating current (DC/AC) 

 

Earth (Ground) 

 
 

Class II Equipment 

to identify equipment  meeting the safety 

requirements specified for Class II equipment   

(device protected by double or reinforced 

insulation) 

 

Frame or chassis Ground terminal 

 

EU labeling for batteries and accumulators 

For additional information, see section "Waste 

disposal/Environmental protection", item 1. 

 

Be careful when handling electrostatic sensitive 

devices 

 

EU labeling for separate collection of electrical 

and electronic devices 

For additional information, see section "Waste 

disposal/Environmental protection", item 2. 

 

Warning! Laser radiation 

For additional information, see section 

"Operation", item 7. 

  

 

Signal words and their meaning 

The following signal words are used in the product documentation in order to warn the reader about risks 

and dangers. 

 

Indicates a hazardous situation which, if not avoided, will result in death or 

serious injury. 

 

Indicates a hazardous situation which, if not avoided, could result in death or 

serious injury. 

 

Indicates a hazardous situation which, if not avoided, could result in minor or 

moderate injury. 

 

Indicates information considered important, but not hazard-related, e.g. 

messages relating to property damage. 

In the product documentation, the word ATTENTION is used synonymously. 

These signal words are in accordance with the standard definition for civil applications in the European 

Economic Area. Definitions that deviate from the standard definition may also exist in other economic 

areas or military applications. It is therefore essential to make sure that the signal words described here 

are always used only in connection with the related product documentation and the related product. The 

use of signal words in connection with unrelated products or documentation can result in misinterpretation 

and in personal injury or material damage. 
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Se parte del uso correcto del producto para los fines definidos si el producto es utilizado conforme a las 

indicaciones de la correspondiente documentación del producto y dentro del margen de rendimiento 

definido (ver hoja de datos, documentación, informaciones de seguridad que siguen). El uso del producto 

hace necesarios conocimientos técnicos y ciertos conocimientos del idioma inglés. Por eso se debe tener 

en cuenta que el producto solo pueda ser operado por personal especializado o personas instruidas en 

profundidad con las capacidades correspondientes. Si fuera necesaria indumentaria de seguridad para el 

uso de productos de Rohde & Schwarz, encontraría la información debida en la documentación del 

producto en el capítulo correspondiente. Guarde bien las informaciones de seguridad elementales, así 

como la documentación del producto, y entréguelas a usuarios posteriores. 

Tener en cuenta las informaciones de seguridad sirve para evitar en lo posible lesiones o daños por 

peligros de toda clase. Por eso es imprescindible leer detalladamente y comprender por completo las 

siguientes informaciones de seguridad antes de usar el producto, y respetarlas durante el uso del 

producto. Deberán tenerse en cuenta todas las demás informaciones de seguridad, como p. ej. las 

referentes a la protección de personas, que encontrarán en el capítulo correspondiente de la 

documentación del producto y que también son de obligado cumplimiento. En las presentes 

informaciones de seguridad se recogen todos los objetos que distribuye el grupo de empresas 

Rohde & Schwarz bajo la denominación de "producto", entre ellos también aparatos, instalaciones así 

como toda clase de accesorios. Los datos específicos del producto figuran en la hoja de datos y en la 

documentación del producto. 

Señalización de seguridad de los productos 

Las siguientes señales de seguridad se utilizan en los productos para advertir sobre riesgos y peligros. 

Símbolo Significado Símbolo Significado 

 

Aviso: punto de peligro general 

Observar la documentación del producto 

    
Tensión de alimentación de PUESTA EN 

MARCHA / PARADA 

 

Atención en el manejo de dispositivos de peso 

elevado  

Indicación de estado de espera (standby) 

 

Peligro de choque eléctrico  Corriente continua (DC) 

 

Advertencia: superficie caliente  Corriente alterna (AC) 

 

Conexión a conductor de protección  Corriente continua / Corriente alterna (DC/AC) 

 

Conexión a tierra 

 
El aparato está protegido en su totalidad por un 

aislamiento doble (reforzado) 

 

Conexión a masa 

 

Distintivo de la UE para baterías y 

acumuladores 

Más información en la sección 

"Eliminación/protección del medio ambiente", 

punto 1. 
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Símbolo Significado Símbolo Significado 

 

Aviso: Cuidado en el manejo de dispositivos 

sensibles a la electrostática (ESD) 

 

Distintivo de la UE para la eliminación por 

separado de dispositivos eléctricos y 

electrónicos 

Más información en la sección 

"Eliminación/protección del medio ambiente", 

punto 2. 

 

Advertencia: rayo láser 

Más información en la sección 

"Funcionamiento", punto 7. 

  

 

Palabras de señal y su significado 

En la documentación del producto se utilizan las siguientes palabras de señal con el fin de advertir contra 

riesgos y peligros. 

 

Indica una situación de peligro que, si no se evita, causa lesiones 

graves o incluso la muerte. 

 

Indica una situación de peligro que, si no se evita, puede causar 

lesiones graves o incluso la muerte. 

 

Indica una situación de peligro que, si no se evita, puede causar 

lesiones leves o moderadas. 

 

Indica información que se considera importante, pero no en relación 

con situaciones de peligro; p. ej., avisos sobre posibles daños 

materiales.  

En la documentación del producto se emplea de forma sinónima el 

término CUIDADO. 

 

Las palabras de señal corresponden a la definición habitual para aplicaciones civiles en el área 

económica europea. Pueden existir definiciones diferentes a esta definición en otras áreas económicas o 

en aplicaciones militares. Por eso se deberá tener en cuenta que las palabras de señal aquí descritas 

sean utilizadas siempre solamente en combinación con la correspondiente documentación del producto y 

solamente en combinación con el producto correspondiente. La utilización de las palabras de señal en 

combinación con productos o documentaciones que no les correspondan puede llevar a interpretaciones 

equivocadas y tener por consecuencia daños en personas u objetos. 

Estados operativos y posiciones de funcionamiento 

El producto solamente debe ser utilizado según lo indicado por el fabricante respecto a los estados 

operativos y posiciones de funcionamiento sin que se obstruya la ventilación. Si no se siguen las 

indicaciones del fabricante, pueden producirse choques eléctricos, incendios y/o lesiones graves con 

posible consecuencia de muerte. En todos los trabajos deberán ser tenidas en cuenta las normas 

nacionales y locales de seguridad del trabajo y de prevención de accidentes.  
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1. Si no se convino de otra manera, es para los productos Rohde & Schwarz válido lo que sigue:  

como posición de funcionamiento se define por principio la posición con el suelo de la caja para 

abajo, modo de protección IP 2X, uso solamente en estancias interiores, utilización hasta 2000 m 

sobre el nivel del mar, transporte hasta 4500 m sobre el nivel del mar. Se aplicará una tolerancia de 

±10 % sobre el voltaje nominal y de ±5 % sobre la frecuencia nominal. Categoría de sobrecarga 

eléctrica 2, índice de suciedad 2.  

2. No sitúe el producto encima de superficies, vehículos, estantes o mesas, que por sus características 

de peso o de estabilidad no sean aptos para él. Siga siempre las instrucciones de instalación del 

fabricante cuando instale y asegure el producto en objetos o estructuras (p. ej. paredes y estantes). Si 

se realiza la instalación de modo distinto al indicado en la documentación del producto, se pueden 

causar lesiones o, en determinadas circunstancias, incluso la muerte. 

3. No ponga el producto sobre aparatos que generen calor (p. ej. radiadores o calefactores). La 

temperatura ambiente no debe superar la temperatura máxima especificada en la documentación del 

producto o en la hoja de datos. En caso de sobrecalentamiento del producto, pueden producirse 

choques eléctricos, incendios y/o lesiones graves con posible consecuencia de muerte. 

Seguridad eléctrica 

Si no se siguen (o se siguen de modo insuficiente) las indicaciones del fabricante en cuanto a seguridad 

eléctrica, pueden producirse choques eléctricos, incendios y/o lesiones graves con posible consecuencia 

de muerte.  

1. Antes de la puesta en marcha del producto se deberá comprobar siempre que la tensión 

preseleccionada en el producto coincida con la de la red de alimentación eléctrica. Si es necesario 

modificar el ajuste de tensión, también se deberán cambiar en caso dado los fusibles 

correspondientes del producto.  

2. Los productos de la clase de protección I con alimentación móvil y enchufe individual solamente 

podrán enchufarse a tomas de corriente con contacto de seguridad y con conductor de protección 

conectado. 

3. Queda prohibida la interrupción intencionada del conductor de protección, tanto en la toma de 

corriente como en el mismo producto. La interrupción puede tener como consecuencia el riesgo de 

que el producto sea fuente de choques eléctricos. Si se utilizan cables alargadores o regletas de 

enchufe, deberá garantizarse la realización de un examen regular de los mismos en cuanto a su 

estado técnico de seguridad. 

4. Si el producto no está equipado con un interruptor para desconectarlo de la red, o bien si el 

interruptor existente no resulta apropiado para la desconexión de la red, el enchufe del cable de 

conexión se deberá considerar como un dispositivo de desconexión.  

El dispositivo de desconexión se debe poder alcanzar fácilmente y debe estar siempre bien accesible. 

Si, p. ej., el enchufe de conexión a la red es el dispositivo de desconexión, la longitud del cable de 

conexión no debe superar 3 m).  

Los interruptores selectores o electrónicos no son aptos para el corte de la red eléctrica. Si se 

integran productos sin interruptor en bastidores o instalaciones, se deberá colocar el interruptor en el 

nivel de la instalación. 

5. No utilice nunca el producto si está dañado el cable de conexión a red. Compruebe regularmente el 

correcto estado de los cables de conexión a red. Asegúrese, mediante las medidas de protección y 

de instalación adecuadas, de que el cable de conexión a red no pueda ser dañado o de que nadie 

pueda ser dañado por él, p. ej. al tropezar o por un choque eléctrico.  
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6. Solamente está permitido el funcionamiento en redes de alimentación TN/TT aseguradas con fusibles 

de 16 A como máximo (utilización de fusibles de mayor amperaje solo previa consulta con el grupo de 

empresas Rohde & Schwarz). 

7. Nunca conecte el enchufe en tomas de corriente sucias o llenas de polvo. Introduzca el enchufe por 

completo y fuertemente en la toma de corriente. La no observación de estas medidas puede provocar 

chispas, fuego y/o lesiones. 

8. No sobrecargue las tomas de corriente, los cables alargadores o las regletas de enchufe ya que esto 

podría causar fuego o choques eléctricos. 

9. En las mediciones en circuitos de corriente con una tensión Ueff > 30 V se deberán tomar las medidas 

apropiadas para impedir cualquier peligro (p. ej. medios de medición adecuados, seguros, limitación 

de tensión, corte protector, aislamiento etc.). 

10. Para la conexión con dispositivos informáticos como un PC o un ordenador industrial, debe 

comprobarse que éstos cumplan los estándares IEC60950-1/EN60950-1 o IEC61010-1/EN 61010-1 

válidos en cada caso. 

11. A menos que esté permitido expresamente, no retire nunca la tapa ni componentes de la carcasa 

mientras el producto esté en servicio. Esto pone a descubierto los cables y componentes eléctricos y 

puede causar lesiones, fuego o daños en el producto. 

12. Si un producto se instala en un lugar fijo, se deberá primero conectar el conductor de protección fijo 

con el conductor de protección del producto antes de hacer cualquier otra conexión. La instalación y 

la conexión deberán ser efectuadas por un electricista especializado. 

13. En el caso de dispositivos fijos que no estén provistos de fusibles, interruptor automático ni otros 

mecanismos de seguridad similares, el circuito de alimentación debe estar protegido de modo que 

todas las personas que puedan acceder al producto, así como el producto mismo, estén a salvo de 

posibles daños. 

14. Todo producto debe estar protegido contra sobretensión (debida p. ej. a una caída del rayo) mediante 

los correspondientes sistemas de protección. Si no, el personal que lo utilice quedará expuesto al 

peligro de choque eléctrico. 

15. No debe introducirse en los orificios de la caja del aparato ningún objeto que no esté destinado a ello. 

Esto puede producir cortocircuitos en el producto y/o puede causar choques eléctricos, fuego o 

lesiones. 

16. Salvo indicación contraria, los productos no están impermeabilizados (ver también el capítulo 

"Estados operativos y posiciones de funcionamiento", punto 1). Por eso es necesario tomar las 

medidas necesarias para evitar la entrada de líquidos. En caso contrario, existe peligro de choque 

eléctrico para el usuario o de daños en el producto, que también pueden redundar en peligro para las 

personas. 

17. No utilice el producto en condiciones en las que pueda producirse o ya se hayan producido 

condensaciones sobre el producto o en el interior de éste, como p. ej. al desplazarlo de un lugar frío a 

otro caliente. La entrada de agua aumenta el riesgo de choque eléctrico. 

18. Antes de la limpieza, desconecte por completo el producto de la alimentación de tensión (p. ej. red de 

alimentación o batería). Realice la limpieza de los aparatos con un paño suave, que no se deshilache. 

No utilice bajo ningún concepto productos de limpieza químicos como alcohol, acetona o diluyentes 

para lacas nitrocelulósicas. 
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Customer Support 
 

Technical support – where and when you need it 
For quick, expert help with any Rohde & Schwarz equipment, contact one of our Customer Support 
Centers. A team of highly qualified engineers provides telephone support and will work with you to find a 
solution to your query on any aspect of the operation, programming or applications of Rohde & Schwarz 
equipment. 
 

Up-to-date information and upgrades 
To keep your instrument up-to-date and to be informed about new application notes related to your 
instrument, please send an e-mail to the Customer Support Center stating your instrument and your wish. 
We will take care that you will get the right information. 
 

Europe, Africa, Middle East Phone +49 89 4129 12345 
customersupport@rohde-schwarz.com

North America Phone 1-888-TEST-RSA (1-888-837-8772) 
customer.support@rsa.rohde-schwarz.com

Latin America Phone +1-410-910-7988 
customersupport.la@rohde-schwarz.com

Asia/Pacific Phone +65 65 13 04 88 
customersupport.asia@rohde-schwarz.com

China Phone +86-800-810-8228 /  
 +86-400-650-5896 
customersupport.china@rohde-schwarz.com
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1 Preface
The R&S SGU is an upconverter in the frequency range of 10 MHz to 40 GHz.

Optimized for use in automated test equipment (ATE), the instrument offers very fast
settling times in an exceptionally small form factor and low power consumption. The
R&S SGU has LO connectors for coupling multiple generators to a common LO source
and can be equipped with a mechanical step attenuator.

1.1 Key Features

The key features of the R&S SGU include the following:

● Compact size and low power consumption
● Remote connection via PCI Express, minimizing time for setup

Alternatively, LAN or USB connections available
● Coherent LO input and output connectors, also usable as MIMO input/output and

phase coherent I/Q demodulation
● Linux operating system
● Graphical user interface R&S SGMA-GUI to set up and control one or more

R&S SGU instruments simultaneously from one remote computer, available for
Windows and Linux systems

1.2 Documentation Overview

This section provides an overview of the R&S SGU user documentation. You find it on
the product page at:

http://www.rohde-schwarz.com/product/SGU100A.html > "Downloads"

Getting started manual

Introduces the R&S SGU and describes how to set up and start working with the prod-
uct. Includes basic operations, typical measurement examples, and general informa-
tion, e.g. safety instructions, etc. A printed version is delivered with the instrument.

Online help

Embedded in the R&S SGMA-GUI software, it offers quick, context-sensitive access to
the complete information.

User manual

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control commands
with programming examples, and information on maintenance, instrument interfaces
and error messages. Includes the contents of the quick start guide manual.
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The online version of the operating manual provides the complete contents for imme-
diate display on the Internet.

Service manual

Describes the performance test for checking the rated specifications, module replace-
ment and repair, firmware update, troubleshooting and fault elimination, and contains
mechanical drawings and spare part lists.

Instrument security procedures manual

Deals with security issues when working with the R&S SGU in secure areas.

Basic safety instructions

Contains safety instructions, operating conditions and further important information.
The printed document is delivered with the instrument.

Data sheet and brochure

The data sheet contains the technical specifications of the R&S SGU. It also lists the
options and their order numbers as well as optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

Release notes and open source acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The open source acknowledgment document provides verbatim license texts of the
used open source software.

See http://www.rohde-schwarz.com/product/SGU100A.html > "Downloads" > "Firm-
ware"

Application notes, application cards, white papers, etc.

These documents deal with special applications or background information on particu-
lar topics, see http://www.rohde-schwarz.com/appnotes.

1.3 Typographical Conventions

The following text markers are used throughout this documentation:

Convention Description

"Graphical user interface ele-
ments"

All names of graphical user interface elements on the screen, such as
dialog boxes, menus, options, buttons, and softkeys are enclosed by
quotation marks.

KEYS Key names are written in capital letters.
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Convention Description

File names, commands,
program code

File names, commands, coding samples and screen output are distin-
guished by their font.

Input Input to be entered by the user is displayed in italics.

Links Links that you can click are displayed in blue font.

"References" References to other parts of the documentation are enclosed by quota-
tion marks.

Typographical Conventions
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2 Preparing for Use
● Putting into Operation............................................................................................. 14
● Linux Operating System..........................................................................................20
● Connecting an External PC and Devices................................................................20

2.1 Putting into Operation

This section describes the basic steps to be taken when setting up the R&S SGU for
the first time.

Risk of injury and instrument damage
The instrument must be used in an appropriate manner to prevent electric shock, fire,
personal injury, or damage.
● Do not open the instrument casing.
● Read and observe the "Basic Safety Instructions" delivered as a printed brochure

with the instrument.
In addition, read and observe the safety instructions in the following sections.
Notice that the data sheet may specify additional operating conditions.

Risk of instrument damage
Note that the general safety instructions also contain information on operating condi-
tions that prevent damage to the instrument. The instrument's data sheet can contain
additional operating conditions.

Risk of electrostatic discharge (ESD)
Electrostatic discharge (ESD) can damage the electronic components of the instrument
and the device under test (DUT). ESD is most likely to occur when you connect or dis-
connect a DUT or test fixture to the instrument's test ports. To prevent ESD, use a wrist
strap and cord and connect yourself to the ground, or use a conductive floor mat and
heel strap combination.
For details, refer to the basic safety instructions included at the front of the manual.
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Risk of instrument damage during operation
An unsuitable operating site or test setup can damage the instrument and connected
devices. Ensure the following operating conditions before you switch on the instrument:
● All fan openings are unobstructed and the airflow perforations are unimpeded. The

minimum distance from the wall is 10 cm.
● The instrument is dry and shows no sign of condensation.
● The instrument is positioned as described in the following sections.
● The ambient temperature does not exceed the range specified in the data sheet.
● Signal levels at the input connectors are all within the specified ranges.
● Signal outputs are correctly connected and are not overloaded.

2.1.1 EMI Suppression

Electromagnetic interference (EMI) may affect the measurement results.

To suppress generated Electromagnetic Interference (EMI),
● Use suitable shielded cables of high quality. For example use double-shielded RF

and LAN cables.
Note: USB cables are of varying and often poor quality. Therefore, check the qual-
ity of each individual USB cable as described in the service manual.

● Always terminate open cable ends.
● Note the EMC classification in the data sheet

2.1.2 Unpacking and Checking the Instrument

Check the equipment for completeness using the delivery note and the accessory lists
for the various items. Check the instrument for any damage. If there is damage, imme-
diately contact the carrier who delivered the instrument. Make sure not to discard the
box and packing material.

Packing material
Retain the original packing material. If the instrument needs to be transported or ship-
ped at a later date, you can use the material to protect the control elements and con-
nectors.
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Risk of damage during transportation and shipment
Insufficient protection against mechanical and electrostatic effects during transportation
and shipment can damage the instrument.
● Always make sure that sufficient mechanical and electrostatic protection is provi-

ded.
● When shipping an instrument, the original packaging should be used. If you do not

have the original packaging, use sufficient padding to prevent the instrument from
moving around inside the box. Pack the instrument in antistatic wrap to protect it
from electrostatic charging.

● Secure the instrument to prevent any movement and other mechanical effects dur-
ing transportation.

The carrying handles at the front and side of the casing are designed to lift or carry
the instrument. Do not apply an excessive external force to the handles.
Observe the information on transporting heavy instruments in the basic safety instruc-
tions included at the front of the printed manual.

2.1.3 Accessory List

The instrument comes with the following accessories:

● Power cable
● Getting Started printed manual

2.1.4 Placing or Mounting the Instrument

The R&S SGU is designed for use under laboratory conditions, either on a bench top
or in a rack using a rack adapter kit (order number see data sheet).

Bench Top Operation

If the R&S SGU is operated on a bench top, the surface should be flat. The instrument
can be used in horizontal position, standing on its feet.
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Risk of injury and instrument damage if stacking instruments
A stack of instruments may tilt over and cause injury. Furthermore, the instruments at
the bottom of the stack may be damaged due to the load imposed by the instruments
on top.
Observe the following instructions when stacking instruments:
● Never stack more than three instruments with the same dimensions (width and

length). If you need to stack more than three instruments, install them in a rack.
● The overall load imposed on the lowest instrument must not exceed 500 N.
● All instruments should have the same dimensions (width and length).

If you need to stack smaller instruments on the top, the overall load imposed on the
lowest instrument must not exceed 250 N.

● If the instruments have foldable feet, fold them in completely.

Rack mounting

The R&S SGU can be installed in a rack using a rack adapter kit (Order No. see data
sheet). The installation instructions are part of the adapter kit.

Risk of instrument damage in a rack
An insufficient airflow can cause the instrument to overheat, which may disturb the
operation and even cause damage.
Make sure that all fan openings are unobstructed, that the airflow perforations are
unimpeded, and that the minimum distance from the wall is 10 cm.

2.1.5 Switching the Instrument On and Off

The R&S SGU is automatically adapted to the AC voltage supplied. There is no need
to set the voltage manually or change fuses. The AC SUPPLY AND POWER SWITCH
is at the rear of the unit.
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To connect the AC supply

► Connect the R&S SGU to the AC power source using the AC power cable deliv-
ered with the instrument.

Note: The instrument is in compliance with safety class EN61010-1.
Connect the instrument only to a socket with earthing contact.

To start up the instrument

1. Connect the instrument to the AC supply.

2. To turn on the power, press the main power switch to position I (On).

To switch between standby and ready state

► Press the POWER ON /STAND BY key briefly to switch the instrument from the
standby to ready state or vice versa.

In ready state, the button is green. The instrument is ready for operation. All mod-
ules are power-supplied and the R&S SGU initiates its startup procedure.
In standby state, the button is orange. The standby power mode keeps the power
switch circuits and the remote control system active.

Start-up and booting

The instrument boots the operating system and starts the instrument firmware. During
the booting process, the green POWER ON /STAND BY key blinks. If the previous
session was terminated regularly, the instrument uses the last setup with the relevant
instrument settings.

Once the startup procedure has been terminated, the instrument is ready for operation.

In the R&S SGMA-GUI, select "Instrument > Preset" function to return the instrument
to its defined reset/preset state, if the current setup is no longer relevant.

To customize the start settings, use the "SGMA-GUI > File > Save As/Open" function.

To shut down the Instrument

To shut down the R&S SGU, proceed as described below.

Putting into Operation
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Risk of losing data
If you switch off the running instrument using the rear panel switch or by disconnecting
the power cord, the instrument loses its current settings.
Always press the POWER ON/STANDBY key first to shut down the application prop-
erly.

1. Press the POWER ON /STAND BY key to save the current setup, shut down the
operating system and set the instrument to standby state.

The POWER ON /STAND BY LED must be orange.

Tip: If the instrument is operated manually via the R&S SGMA-GUI, select "SGMA-
GUI > Instrument Name > Setup > Standby".

2. To turn the power off, press the main power switch to position 0 (Off).

None of the front-panel LEDs should be on.

2.1.6 Function Check

The instrument automatically monitors the main functions when it is switched on and
monitors them continuously during operation.

A detected fault is indicated by an "Error" message displayed in the info line of the
R&S SGMA-GUI together with a brief error description. For an in-depth identification of
the error, press the "SGMA-GUI > Info" button. In response, a description of the
error(s) is displayed. For more information, refer to the "Error Messages" section in the
User Manual.

2.1.7 Default Settings

When the instrument is switched on, it is not the preset state that is active, but rather
the instrument state that was set before the instrument was switched off. It is recom-
mended that you use the "SGMA-GUI > Instrument > Preset" function to return the
instrument to its defined preset state every time a new configuration is required or the
current setup is no longer relevant.

The R&S SGU offers a two-stage preset concept:
● Preset the instrument to a predefined state

The "SGMA-GUI > Instrument Name > Preset" function calls up a defined instru-
ment setup. All parameters and switching states are preset (also those of inactive
operating modes). The default instrument settings provide a reproducible initial
basis for all other settings. However, functions that concern the integration of the
instrument into a measurement setup are not changed.

● Preset the instrument to its factory settings
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The instrument can also be forced to load its default factory settings. To access the
corresponding dialog box, select the "SGMA-GUI > Instrument Name > Setup >
Factory Preset" function.
For more information and an overview of the settings affected by the factory preset
function, see Chapter 8.9, "Factory Preset", on page 98.

User-defined instrument states can be stored and called up using the functions
"SGMA-GUI > File > Save As/Open".

2.2 Linux Operating System

The instrument uses an embedded Linux operating system, optimally adapted to the
instrument.

Accessing the Operating System
No access to the operating system is required for normal operation.
All necessary system settings can be made in the "Setup" dialog.

2.3 Connecting an External PC and Devices

As a rule, the R&S SGU is operated exclusively via remote control on a connected PC.
Another way to control the instrument is the manual operation via the R&S SGMA-GUI
software on the connected PC.

Both the remote control and the manual operation of the instrument require an external
controller. For the prerequisites and the instructions on how to configure an external
controller for remote control, refer to the User Manual. A brief introduction to the
remote control capabilities is provided in Chapter 10, "Network and Remote Control
Operation", on page 110.

This section gives an introduction on how to configure the external PC for manual
operation (see Chapter 2.3.1, "Installing the R&S SGMA-GUI Software on an External
PC", on page 21).

In addition to connecting an external controller, it may be useful to connect other exter-
nal devices, e.g. a memory stick. The following interfaces are provided on the rear
panel of the instrument, see also Chapter 3.2, "Rear Panel Tour", on page 28:

● PCI Express (refer to Chapter 2.3.3, "Connecting a Controller via PCI Express",
on page 24

● USB interface (refer to Chapter 2.3.4, "Connecting a Controller or a USB Device
via USB", on page 24)

● LAN interface (refer to Chapter 2.3.2, "Connecting a Remote PC via LAN",
on page 22)
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2.3.1 Installing the R&S SGMA-GUI Software on an External PC

The R&S SGMA-GUI software is a graphical user interface program for one or more
instruments. It runs on a remote PC.

The R&S SGMA-GUI software is provided as separate installation package for the dif-
ferent operating systems. The latest version of the software togehter with the relese
notes is available for download at:

http://www.rohde-schwarz.com/product/SGU100A.html > "Downloads" > "Software"

This page always offers the latest information on your R&S SGMA-GUI.

This description focuses on the handling of the Windows-32 version. The file naming
conventions and the installation instructions for the other operating systems are analo-
gous.

The R&S SGMA-GUI installation package for Windows-32 operating system consists
of the file SGMA-GUI_<V.VV.VVV.VVV>.exe. The version numbers in the file names
vary with each update. To install the R&S SGMA-GUI, the following hardware and soft-
ware requirements have to be met.

Table 2-1: Hardware and Software Requirements

Requirement Remark

One of the following operating sys-
tems:
● Windows XP SP2
● Windows Vista
● Windows 7
● Windows 8/ 8.1
● Windows 10
● Linux

R&S SGMA-GUI has to be installed on one of the supported operat-
ing systems.

Note:

Any other Windows version or other operating systems are not sup-
ported.

Windows Installer Version 4.5 or higher is needed for the installation
of the software on a Windows XP computer.

During installation, the operation system is checked.

The installation will be terminated if this requirement is not fulfilled.

R&S VISA VISA drivers can be obtained on the Rhode & Schwarz website:

http://www.rohde-schwarz.com/rsvisa

CPU At least Pentium or compatible, as from 1 GHz (recommended).

VGA color display resolution At least 800*600 pixels

Installing a new software version

Administrator rights are necessary for installation and starting.

1. Download the R&S SGMA-GUI software

2. In Windows Explorer double-click SGMA-GUI_V.VV.VVV.VVV.exe and follow the
instructions.
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Uninstalling an old software version

An uninstallation of a previous version of the SW can be performed prior to the installa-
tion of the new one but is not mandatory.

► To uninstall this version, go to "Start > Settings > Control Panel > Add/Remove
Programs" and select the entry SGMA-GUI_V.VV.VVV.VVV.

The script file identifies and removes all currently installed R&S SGMA-GUI soft-
ware items.

2.3.2 Connecting a Remote PC via LAN

The R&S SGU is equipped with a network interface and can be connected to an Ether-
net LAN (local area network). The interface can be used, for example:

● To connect an external computer for manual control of the instrument by means of
the R&S SGMA-GUI software.

● To operate the device by a remote control program.
See Chapter 10, "Network and Remote Control Operation", on page 110.

This section describes how to configure the LAN interface. It includes the following top-
ics:

● Chapter 2.3.2.1, "Connecting the Instrument to the Network", on page 22
● Chapter 2.3.2.2, "Assigning the IP Address", on page 23
● Chapter 2.3.2.3, "Automatically Adding Instruments to the SGMA-GUI ",

on page 23

2.3.2.1 Connecting the Instrument to the Network

There are two methods to establish a LAN connection to the instrument:

● A non-dedicated network (Ethernet) connection from the instrument to an existing
network.

● A dedicated network connection (Point-to-point connection) between the instru-
ment and a single computer.

In both cases, an IP address has to be assigned to the instrument and the computer,
see Chapter 2.3.2.2, "Assigning the IP Address", on page 23.

Setting Up a Network (LAN) Connection

Risk of network failure
Before connecting the instrument to the network or configuring the network, consult
your network administrator. Errors may affect the entire network.

► Connect the instrument to the network or to a single PC.
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If the instrument is connected to the LAN, the operating system automatically
detects the network connection and activates the required drivers.
By default, the instrument is configured to use dynamic TCP/IP configuration and
obtain all address information automatically.

2.3.2.2 Assigning the IP Address

Depending on the network capacities, the TCP/IP address information for the instru-
ment can be obtained in different ways.
● If the network supports dynamic TCP/IP configuration using the Dynamic Host

Configuration Protocol (DHCP), all address information can be assigned automati-
cally.

● If the network does not support DHCP, the instrument tries to obtain the IP address
via Zeroconf (APIPA) protocol. If this attempt does not succeed or if the instrument
is set to use alternate TCP/IP configuration, the addresses must be set manually.

The R&S SGU uses the Zeroconf IP addresses 169.254.xxx.yyy., where xxx takes val-
ues between 1...254 and yyy the values in the value range 1...255; the subnet mask is
always 255.255.0.0. The IP address of the host must be within the same address area
for Zeroconf.

By default, the instrument is configured to use dynamic TCP/IP configuration and
obtain all address information automatically. This means that it is safe to establish a
physical connection to the LAN without any previous instrument configuration.

2.3.2.3 Automatically Adding Instruments to the SGMA-GUI

For information on how to install the R&S SGMA-GUI software, refer to Chapter 2.3.1,
"Installing the R&S SGMA-GUI Software on an External PC", on page 21.

1. For each new instrument perform the following steps:

a) Connect the instrument to the network.
b) Press the POWER ON /STAND BY key to switch on the instrument.
c) Wait until the POWER ON /STAND BY LED is green and not blinking.
d) Press the ID key on the front panel of the instrument.

2. Start the SGMA-GUI on a computer connected to the same network.

3. Open the "Instruments" dialog and click "Scan".

Note: This step is performed automatically on the first start and can also be omit-
ted for instruments with a direct LAN connection to the computer.

All instruments are added automatically to the main panel of the SIGMA-GUI.
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2.3.3 Connecting a Controller via PCI Express

A PCI Express connector is provided on the rear panel of the instrument, see Chap-
ter 3.2, "Rear Panel Tour", on page 28.

Risk of device failure
The R&S SGU is equipped with a single lane PCIe interface that supports hot plugging.
Do not connect an external PC to the PCIe connector of the instrument during opera-
tion if this external PC does not support hot-plugging!

Using the PCIe interface for remote control of the instrument requires extended knowl-
edge. Refer to Chapter 10.3, "Advanced Remote Control Using PCIe", on page 120
for detailed information.

2.3.4 Connecting a Controller or a USB Device via USB

The USB interface on the rear panel of the R&S SGU allows you to connect either a
USB device or use the R&S SGU as a device and connect it to a controller.

Connecting a controller (host PC or compatible signal generator)

If you connect a controller (host PC or compatible signal generator) to the R&S SGU,
the R&S SGU acts as a USB device.

To connect the controller to the USB interface of the R&S SGU, always connect the
USB Type Micro-B connector to the R&S SGU. Refer to the documentation of the
controller to find out which USB connector type you can connect to the controller.

The Figure 2-1 illustrates schematically the required connector type to emphasize on
the different connector shape.

Figure 2-1: USB Type Micro-B connectors

An external PC with installed R&S SGMA-GUI is required for manual operation of the
R&S SGU.

On the remote PC, perform the steps as described in Chapter 2.3.2.3, "Automatically
Adding Instruments to the SGMA-GUI ", on page 23.

Connecting a USB device

If you connect a USB device (Memory stick, CD-ROM, an instrument) to the R&S SGU,
the R&S SGU acts as a host.
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To connect a USB device to the interface of the R&S SGU, always connect the
USB Type Micro-A connector to the R&S SGU. Refer to the documentation of the
USB device to find out which USB connector type you can connect to the USB device.

The Figure 2-2 illustrates schematically the required connector type to emphasize on
the different connector shape.

Figure 2-2: USB Type Micro-A connectors

If you connect an R&S SGS to an R&S SGU via a USB cable, perform the steps as
described in Chapter 5.2, "Setups for Connecting an R&S SGS and an R&S SGU",
on page 39.

Using a USB Adapter
You can use a USB adapter to customize the connectors of a USB cable to the
requirements of the instrument.
For example, you can use a Type-A / Micro-A adapter to customize a standard USB
cable with Type A and Type Micro-B connectors for the connection of an R&S SGS
(acting as a host) to an R&S SGU (acting as a USB device).
In some cases, you can also use a Type-A / Micro-B adapter to establish a connection
to the instrument. To check whether the adapter you have is suitable or not you can
connect a USB stick with an LED through the adapter to the instrument. If the LED of
the USB stick lights up after a connection to the instrument then you can use this
adapter for further applications with the instrument.

Connecting an External PC and Devices
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3 Instrument Tour
The following topics will help you get familiar with the instrument and perform the first
steps:
● Front Panel Tour
● Rear Panel Tour

This section explains the control elements and the connectors of the R&S SGU with
the aid of the front and rear views. Specifications of interfaces can be found in the data
sheet.

3.1 Front Panel Tour

This section provides an overview of control elements on the front panel of the
R&S SGU. The connectors of the R&S SGU are placed on the rear panel and are
described in Chapter 3.2, "Rear Panel Tour", on page 28. As the R&S SGU is mainly
intended to be remote-controlled, the front panel of the R&S SGU contains no display
but mostly LEDs to inform the user about the status of the instrument. The user inter-
face can be displayed on a remote PC station used to manually remote control the
instrument.

Figure 3-1: Front panel view

POWER ON /STAND BY

The POWER ON /STAND BY key switches the instrument from the standby to ready
state or vice versa.

In ready state, the button is green. The instrument is ready for operation.

In standby state, the button is orange. In this state, it is safe to switch off the AC power
and disconnect the instrument from the power supply.

A blinking green color indicates that a booting operation is in process.

RF ON
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The RF ON key switches the RF signal on or off. If activated, the button is green.

LO IN

The LO IN LED indicates the compatibility of the level of the LO input signal with the
correct operation of the R&S SGU.
● Green indicates that the level of the LO input signal is in the range of correct oper-

ation.
● Red indicates that the level of the LO input signal is too high or too low.
● No light indicates that the instrument is in a bypass mode.

ERROR / WARNING

The ERROR / WARNING LED indicates the status of the R&S SGU.
● Red indicates that an error has occurred, e.g. temperature exceeded or power fail-

ure.
● Blinking orange indicates a running process (e.g calibration, self test).
● No light indicates that no errors or warnings have occurred.
For details on errors or warnings, refer to the graphical user interface on a remote PC
("SGMA-GUI > Info").

For more information, refer to the "Error Messages" section in the User Manual.

LAN

Pressing the key for more than 3 s resets the LAN interface settings, i.e the "IP Adress
Mode" is reset to DHCP.

ID

Pressing the ID key while the instrument is active, opens the "SGMA-GUI > Setup >
Instruments > Configure Instruments > Edit Instrument" dialog of the corresponding
instrument on the remote controller.

Pressing the ID key of an inactive instrument and starting "SGMA-GUI > Setup >
Instruments > Scan", leads to an automatic activation of the instrument in the SGMA-
GUI.

Front Panel Tour
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3.2 Rear Panel Tour

This section provides an overview of the connectors on the rear panel of the instru-
ment. For technical data of the connectors, refer to the data sheet.

Figure 3-2: Rear panel view

Protection of mechanical components
To avoid damage of the SMA connectors it is essential to limit the tightening torque to
60 Ncm. Use an adequate 8 mm torque wrench and not an ordinary open-end wrench.

PCI EXPRESS CONNECTOR

The PCIe (Peripheral Component Interconnect Express) single lane interface allows
remote control with optimized speed.

For details, see Chapter 2.3.3, "Connecting a Controller via PCI Express", on page 24.

USB CONNECTOR

The USB (universal serial bus) interface, Type Micro, allows you to connect various
external devices, e.g.:
● If the interface is configured as a device interface, a remote computer can be con-

nected for firmware update, manual operation via the R&S SGMA-GUI software or
for remote control of the instrument.

● If the interface is configured as a host interface, a memory stick for file transmis-
sion can be connected.

For details, see Chapter 2.3.4, "Connecting a Controller or a USB Device via USB",
on page 24.
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LAN CONNECTOR

The LAN (Ethernet) interface allows you to connect the R&S SGU to other devices,
e.g. a remote computer, for firmware update, manual operation via the R&S SGMA-
GUI software or for remote control of the instrument. The connection to the remote
computer can be direct or via a network.

For details, see Chapter 2.3.2, "Connecting a Remote PC via LAN", on page 22.

RF OUT

Provides an RF 50 Ohm signal output.

NOTICE! Maximum Input Levels. Do not overload the RF output. The maximum per-
missible back-feed is specified in the data sheet.

LO IN, LO OUT

SMA type connectors that can be used for local oscillator signals and alternatively also
in MIMO setups.

Local oscillator input and output:
● LO IN: Input for external LO signals
● LO OUT: Output of internal LO signals

TRIG

Multi purpose connector. The TRIG connector is used mainly as an input connector for
an external pulse modulator source.

I, Q IN / OUT

Rear Panel Tour
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The I IN and Q IN SMA female type connectors are the inputs of the I/Q modulator,
provided for feeding of external signal.

The I OUT and Q OUT SMA female type connectors are for direct output of the analog
I/Q signal.

NOTICE! Maximum Input Levels. Do not overload the I and Q inputs. The maximum
permissible voltage is 1V. For details, refer to the data sheet.
Note: The I/Q modulator requires the hardware optionR&S SGU-B120V/-B140V.

AC SUPPLY AND POWER SWITCH

The AC supply and power switch allow you to connect the R&S SGU to the power sup-
ply and switch on the instrument.

For details, see "To connect the AC supply" on page 18.

Rear Panel Tour
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4 First Steps with the Instrument
If an R&S SGU is connected to a signal generator, the instrument acts as an extension
to the signal generator extending its frequency range.

This section provides an example on how to configure the instrument to convert a con-
tinuous wave (CW) signal.

4.1 R&S SGU as an Extension to the R&S SGS

In case the R&S SGU is connected to a compatible R&S signal generator, a controller
only needs to talk to the signal generator which in turn takes care of the proper settings
for the R&S SGU.

In the following example, the instrument is manually operated via the R&S SGMA-GUI
software. The R&S SGU in this example is a base unit equipped with the frequency
option R&S SGU-B120.

Configuring the R&S SGU to upconvert a CW signal generated by the R&S SGS

As a prerequisite for this example the R&S SGMA-GUI software has to be installed on
a remote PC.

Figure 4-1: Example of a test setup for upconverting a CW signal generated by the R&S SGS

For higher setting/ measuring speeds, use a PCIe switch and PCIe connections.

1. Connect the test equipment as shown on Figure 4-1:

a) Connect the R&S SGS, R&S SGU and the controller to a LAN switch.
b) Connect the RF OUT of the R&S SGS to the LO IN of the R&S SGU.
c) Connect the TRIG connectors of the R&S SGS and the R&S SGU.

 

 

R&S SGU as an Extension to the R&S SGS

ManualsPlus.com

https://www.manualsplus.com/


First Steps with the InstrumentR&S®SGU100A

32User Manual 1176.7726.02 ─ 07

d) Connect the RF OUT of the R&S SGU to the RF IN of the signal analyzer.

2. Switch on the R&S SGS and the R&S SGU.

The POWER ON/STANDBY keys have to be green and not blinking.

3. Press the ID keys on the front panels of the R&S SGS and the R&S SGU (only
required if the components are connected via a company network).

4. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application and the configure instruments dialog open. Both
instruments are added automatically to the instruments list and to the main panel of
the R&S SGMA-GUI software.
The main panel provides a quick access to the main settings of the configured and
activated instruments. The display shows one row per instrument with the instru-
ment specific settings. The rows comprise the instrument, the connection state, the
used frequency and power level and the state of the RF output and the modulator.

5. In the R&S SGMA-GUI main panel, the green indicator in front of the instrument's
name confirms that there is a connection between the instrument and the remote
PC and that the instrument is recognized by the software.

6. In the R&S SGMA-GUI main panel, select the rows corresponding to the corre-
sponding instruments to be configured and select "Instrument Name > Preset" to
restore their predefined settings.

7. Select "SGMA-GUI main panel > R&S SGS > Extension".

The "Extension" dialog opens.

R&S SGU as an Extension to the R&S SGS
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Tip: Instrument does not appear in the extension dialog. If the R&S SGU is not
automatically shown in this dialog, press "Scan > Start" to find the instrument.

8. Select the R&S SGU from the list and set "Available Instruments > Select > On" to
enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection between the R&S SGS ant the R&S SGU.
The R&S SGMA-GUI indicates the extended frequency range of the R&S SGS and
the activated extension mode.

9. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

R&S SGU as an Extension to the R&S SGS
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The diagram displays the connection state of the tested connections.

10. Select "SGMA-GUI > R&S SGS > Freq = 40 GHz", "Lev = -30 dBm".

11. Select "SGMA-GUI >SGS> RF > State > On" to enable the output of the CW sig-
nal.

The extension adopts these values and states automatically and generates a CW
signal with RF = 40 GHz and Level = -20 dBm.

The signal is output at the RF OUT connector on the rear panel of the R&S SGU.

R&S SGU as an Extension to the R&S SGS
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Identifying a specific instrument
If several instruments are active in the R&S SGMA-GUI use one of the device identifi-
cation functions to identify a specific device:
● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Channels >

Device Identify". The green LAN LED on the front panel of the instrument blinks.
● Press the ID key on the instrument's front panel. The "Edit Instrument" dialog of the

respective instrument opens.

4.2 R&S SGU as a Standalone Upconverter

This section provides an example on how to configure the instrument to convert a con-
tinuous wave (CW) signal. The signal in this example is provided by an incompatible
signal generator (local oscillator).

In the following example, the instrument is manually operated via the R&S SGMA-GUI
software. The R&S SGU in this example is a base unit equipped with the frequency
option R&S SGU-B120.

Configuring the R&S SGU to convert a CW signal

As a prerequisite for this example, the R&S SGMA-GUI software has to be installed on
a remote PC and the local oscillator has to be prepared for use.

Figure 4-2: Example of a setup of the R&S SGU as an upconverter

1. Connect the test equipment as shown in Figure 4-2. Additional connections may be
needed to fulfill the requirements of the connected local oscillator. To find out what
connections are needed refer to its user manual.

2. Switch on the R&S SGU.
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The POWER ON/STANDBY key has to be green and not blinking.

3. Press the ID key on the front panel the R&S SGU (only required if the components
are connected via a company network).

4. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application and the configure instruments dialog open. The
R&S SGU is added automatically to the instruments list and to the main panel of
the R&S SGMA-GUI software.
The main panel provides a quick access to the main settings of the configured and
activated instruments. The display shows one row per instrument with the instru-
ment specific settings. The rows comprise the instrument, the connection state, the
used frequency and power level and the state of the RF output and the modulator.

5. In the R&S SGMA-GUI main panel, the green indicator in front of the instrument's
name confirms that there is a connection between the instrument and the remote
PC and that the instrument is recognized by the software.

6. In the R&S SGMA-GUI main panel, select the row corresponding to the instrument
to be configured and select "Instrument Name > Preset" to restore the predefined
instrument's settings.

7. Select "SGMA-GUI > R&S SGU > Freq = 15 GHz", "Lev = -10 dBm", "RF > On".

R&S SGU as a Standalone Upconverter
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8. Select "SGMA-GUI > Instrument Name >Ext. Local Oscillator". Read the required
frequency and level values for the LO.

9. Change the settings of the LO to the required values.

10. Select "SGMA-GUI > Instrument Name > Ext. Local Oscillator > Confirm External
LO Settings" to apply the changes.

The 15 GHz signal is output at the LO OUT connector at the rear panel of the
R&S SGU.

Identifying a specific instrument
If several instruments are active in the R&S SGMA-GUI, use one of the device identifi-
cation functions to identify a specific device:
● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Channels >

Device Identify". The green LAN LED on the front panel of the instrument blinks.
● Press the ID key on the instrument's front panel. The "Edit Instrument" dialog of the

respective instrument opens.
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5 System Overview
The R&S SGU is an instrument intended either for the modulation of IQ signals or as
an upconverter in the frequency range of 10 MHz to 40 GHz.

Optimized for use in automated test equipment (ATE), the instrument offers very fast
settling times in an exceptionally small formfactor and low power consumption. The
R&S SGU can be equipped optionally with a mechanical step attenuator.

5.1 Setups for Instrument Control

The R&S SGU is an instrument designed for the automated test equipment (ATE)
needs. To maintain the small size, the instrument is not equipped with a display and
hence additional equipment is required to control the instrument.

This section provides an overview of the possible configuration setups for controlling
the R&S SGU.

5.1.1 Manual Operation from the R&S SGMA-GUI

The following example represents a basic configuration of the R&S SGU, operated
manually by the configuration software R&S SGMA-GUI. The configuration software is
installed on a remote PC and controls several instruments. The instruments are con-
nected to the remote PC over different remote control interfaces. Any combination of
the used interfaces is possible.

Figure 5-1: Configuration example: manual control from R&S SGMA-GUI

For information about the manual control, refer to:
● Chapter 6, "Understanding the R&S SGMA-GUI Software", on page 46
● Chapter 7, "Upconverter Settings", on page 70
● Chapter 8, "General Instrument Settings and Instrument Setup", on page 86

5.1.2 Remote Control from a Controller

The remote control provides access to the instrument's settings from a remote com-
puter (external controller) by means of remote commands. To automate often repeat-
ing settings and settings sequences, these are grouped in the remote control pro-
grams, i.e. application programs.
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An instrument may be connected to the controller via any of the supported interfaces
LAN, USB or PCIe.

Figure 5-2: Configuration example: remote control from a controller

For information about remote control, refer to:
● Chapter 10, "Network and Remote Control Operation", on page 110
● Chapter A, "Remote Control Basics", on page 194

5.1.3 Control of an R&S SGU from a Compatible R&S Signal Generator

If an R&S SGU is connected to a compatible R&S Signal Generator (e.g. R&S SGS ), it
extends its frequency range. In this setup, a controller does not need to access the
R&S SGU directly. Instead, the compatible R&S Signal Generator acts as a controller
to the R&S SGU. The generator performs all required settings automatically depending
on the required output signal parameters.

The Figure 5-3 shows a configuration example of the R&S SGU, directly controlled by
an R&S SGS. For a detailed description of the connecting possibilities, refer to Chap-
ter 5.2, "Setups for Connecting an R&S SGS and an R&S SGU", on page 39.

Figure 5-3: Configuration example: the R&S SGU as an extension to the R&S SGS

5.2 Setups for Connecting an R&S SGS and an R&S SGU

If an R&S SGU is connected to an R&S SGS, the R&S SGU acts as an extension to
the R&S SGS extending its frequency range. In this setup, a controller does not need
to access the R&S SGU directly. Instead, the R&S SGS acts as a controller to the R&S
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SGU. The generator performs all required settings automatically depending on the
required output signal parameters.

This chapter gives an overview of how to connect the instruments.

See:
● Chapter 5.2.1, "Direct Connection", on page 40
● Chapter 5.2.2, "Connection in a Company Network", on page 41
● Chapter 5.2.3, "Connection with a PCIe Switch", on page 44
● Chapter 4.1, "R&S SGU as an Extension to the R&S SGS", on page 31

5.2.1 Direct Connection

The R&S SGS and the R&S SGU can be connected through a direct connection as
shown in Figure 5-4.

Direct connection of an R&S SGS and an R&S SGU

Figure 5-4: Direct connection of an R&S SGS and an R&S SGU

1. Connect the R&S SGS and the R&S SGU directly using one of the following
options:

a) USB cable. Use a Type Micro-A connector for R&S SGS and a Type Micro-B
connector for R&S SGU. See also Chapter 2.3.4, "Connecting a Controller or a
USB Device via USB", on page 24.

b) LAN cable. No additional cable considerations are required.
c) PCIe cable. Refer to Chapter 10.3.4, "Connecting the Controller and the Instru-

ment", on page 124 for cable requirements and setup information.

2. Switch on the R&S SGS and the R&S SGU.

The R&S SGS automatically identifies the connected R&S SGU as its extension
and starts the extension mode.
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For a direct PCIe connection, an automatic identification of the R&S SGU as an exten-
sion is only available for an R&S SGS with a "Controller > Revision" 5 or higher. For a
description on how to manually set the PCIe identification, see Chapter 9.7, "How to
Manually Set a PCIe Direct Connection Between an R&S SGS and an R&S SGU",
on page 109.
You can check the "Controller > Revision" of your instrument in the "SGMA-GUI >
Instrument Name > Hardware Config" dialog.

If instrument is not automatically added as an extension
If the R&S SGU is not automatically added as an extension you can do that manually
in the "SGMA-GUI > R&S SGS Name > Extension" dialog.
If the R&S SGU is not listed in the list of "Available Instruments", you can press "Scan
> Start" to find the instrument.

5.2.2 Connection in a Company Network

Connection of an R&S SGS and an R&S SGU in a Company Network

As a prerequisite for this example the R&S SGMA-GUI software has to be installed on
a remote PC.
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Figure 5-5: Connection of an R&S SGS and an R&S SGU in a company network

1. Connect the test equipment as shown in Figure 5-5:

a) Connect the R&S SGS, the R&S SGU and the controller to the company net-
work.

b) Connect the RF OUT of the R&S SGS to the LO IN of the R&S SGU.

2. Switch on the R&S SGS and the R&S SGU.

The POWER ON/STANDBY keys have to be green and not blinking.

3. Press the ID keys on the front panels of the R&S SGS and the R&S SGU.

4. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application and the configure instruments dialog open. Both
instruments are added automatically to the instruments list and to the main panel of
the R&S SGMA-GUI software.

Note: If you connect the instruments to the company network for the first time this
process may take several minutes.
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5. In the R&S SGMA-GUI main panel, the green indicator in front of the instrument's
name confirms that there is a connection between the instrument and the remote
PC and that the instrument is recognized by the software.

6. Select "SGMA-GUI main panel > R&S SGS > Extension".

The "Extension" dialog opens.

Tip: Instrument doesn't appear in the extension dialog. If the R&S SGU is not auto-
matically shown in this dialog press "Scan > Start" to find the instrument.

7. Select the R&S SGU from the list and set "Available Instruments > Select > On" to
enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection between the R&S SGS ant the R&S SGU.
The R&S SGMA-GUI indicates the extended frequency range of the R&S SGS and
the activated extension mode.

8. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.
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The diagram displays the connection state of the tested signal connections. If the
test connections are correct (shown by an uninterrupted blue line), you can start
using the R&S SGS and the R&S SGU in extension mode.

Tip: If your connection is marked as faulty- a red line is crossing the blue connec-
tion line - check whether the cables are connected properly. Check also if the con-
nection cables are functioning properly.

Figure 5-6: A faulty connection between an R&S SGU and an R&S SGS

5.2.3 Connection with a PCIe Switch

The R&S SGS and the R&S SGU can be connected through a PCIe switch as shown
in Figure 5-7. This setup is recommended for achieving the highest setting/ measuring
speeds.
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PCIe switch connection of an R&S SGS and an R&S SGU

Figure 5-7: Connection of an R&S SGS and an R&S SGU through a PCIe switch

1. Connect the PCIe switch to a switched off computer with a single lane PCIe cable.

2. Connect the R&S SGS and the R&S SGU to the PCIe switch.

3. Switch on the R&S SGS and the R&S SGU.

The POWER ON/STANDBY keys of both instruments have to be green and not
blinking.

4. Switch on the computer.

5. On the computer start one of the following:

a) The R&S SGMA-GUI
b) An application program for remote control of the instruments

6. Manually (or remotely ) activate the R&S SGU as an extension to the R&S SGS.

The logical connection between an R&S SGS and an R&S SGU is established by the
driver layer of a program (e.g. the R&S SGMA-GUI) or the library PCIeController.dll
(Linux: libpciecontroller.so) of a remote control program on the PC. Such a program
has to be running on the PC so that an R&S SGS is able to communicate with an R&S
SGU.

Setups for Connecting an R&S SGS and an R&S SGU

ManualsPlus.com

https://www.manualsplus.com/


Understanding the R&S SGMA-GUI SoftwareR&S®SGU100A

46User Manual 1176.7726.02 ─ 07

6 Understanding the R&S SGMA-GUI Soft-
ware
This section gives a detailed description of the R&S SGMA-GUI user interface and
information on how to work with it. The main panel with the overview of the configured
instruments is the operating and control interface for the whole program. From here, all
program functions are accessible. This panel is displayed after the start of R&S SGMA-
GUI. The program always loads the previously used settings so you can continue your
work in the next session.

6.1 Operating Menu and Toolbar

On the top of the main panel, there are the menu bar, the toolbar and the info bar with
the corresponding "Info" button. Some of the functions are accessible via the toolbar
with its icons below the menu selection line.

The dialogs are built using elements, e.g., selection lists, checkboxes, and entry fields.
A blue frame indicates that the selected item is active. In a highlighted element, entries
can be made.

Table 6-1: Content of the operating menu

File Setup Help

 New Instruments About

 Open Software Contents

Save Reset SGMA-GUI Index

 Save as   
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File Setup Help

Exit   

Shut down instruments and exit   

6.1.1 File Menu

The R&S SGMA-GUI employs the standard Save/Recall file management function and
allows you to store and reload settings in/to a file with a user-defined name and loca-
tion (see also Chapter 6.4.1, "Storing and Loading Settings", on page 58).

In the following, the "File" menu of the R&S SGMA-GUI is described in detail. It incor-
porates standard functions.

New
Resets R&S SGMA-GUI and all connected instruments to their preset settings.

Open
Opens the standard file open browser for loading a saved R&S SGMA-GUI file
(*.savrcl). The file contains the user-specific settings of a session, such as instru-
ments configured in the software, etc. The complete settings of a session can be saved
and loaded.

Only files of this type are selectable.

Note: Instrument-specific settings, e.g. frequency and level settings, are stored locally
on the particular instrument itself. These instruments settings are saved automatically
in a predefined directory and loaded by default when starting the instrument again.
The files with instrument settings are not accessible.

Save
Standard quick save of the settings of the current session if a filename previously has
been applied. If not, the "Save As" dialog is opened.

Save as
Opens the standard file save browser for saving the settings of the current session.
R&S SGMA-GUI files have the file extension .savrcl so the name typed in is equip-
ped with this extension. The complete settings of a session are saved.

Exit
Quits the R&S SGMA-GUI. The current settings of the instrument's session are saved
and loaded by default when starting the software again.

Note: The instruments configured in the R&S SGMA-GUI are not shut down.

Shut down instruments and exit
Quits the R&S SGMA-GUI and switches the connected instruments to the standby
state (see alsoChapter 9.3, "How to Switch Between the Operating States",
on page 104 ).
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6.1.2 Setup Menu

The setup menu provides access to dialogs for setting the general settings of the soft-
ware, like dialogs for managing the connected instruments or dialogs providing infor-
mation about the installed options.

6.1.2.1 Configure Instruments

This dialog is the central point for managing the instrument that will be configured and
operated via the R&S SGMA-GUI. New instruments can be created and appended to
the list of available instruments, connection settings can be edited, instruments can be
removed from the list or they can be deactivated, but kept in the list for further use.

Refer to Chapter 6.4.2, "Handling Instruments in the R&S SGMA-GUI", on page 58
for information on how to configure and manage instruments in R&S SGMA-GUI.

Available Instruments
This section comprises a list of configured instruments. Each instrument is represented
by a "Symbolic Name" which is also displayed in the main panel and an "Instrument
Type". It is also displayed whether the instrument is activated in the R&S SGMA-GUI
and hence displayed in the main panel or not.

Remote command: 
:INSTruments:COUNt? on page 67
:INSTruments:NAME on page 67
:INSTruments:TYPE on page 69
:INSTruments:ACTive[:STATe] on page 66

Scan
Triggers a scan function and searches for instruments connected to the remote com-
puter via all the available interfaces. During the scan process, a progress bar is dis-
played.
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Tip: The first initialization of a newly connected instrument in a network and the instru-
ment's request to the DHCP server for an IP address may take some time. During this
time, the instrument does not respond to the query sent by the scan function. If the
instrument does not appear in the list of "Available Instruments", trigger the scan func-
tion again after some minutes.

Remote command: 
:INSTruments:SCAN on page 68

New Instrument
Calls the Add/Edit Instruments dialog.

Delete Instrument
Removes the selected instrument from the list of Available Instruments.

Edit Instrument
Calls the Add/Edit Instruments dialog.

Clear Instrument
Removes all instruments from the list of Available Instruments.

Export
Opens the standard file save browser for saving the list of the available instruments in
a mapping file. The mapping files have the file extension .map so the filename typed in
is automatically equipped with this extension.

A mapping file provides a cross-reference between the instruments' symbolic names
and their respective remote control parameters. The information in the mapping file is
grouped in rows, where one row corresponds to one configured instrument. The rows
have the following structure:
<InstrumentType> <SymbolicName> <IP_Address/Hostname>
<RemoteChannel> <SerialNumber>

Figure 6-1: Mapping file example

Tip: In a remote control application program, address the instruments by their symbolic
names and retrieve the remain required settings from the mapping file. This workflow is
especially useful for frequent exchange of instruments.

Remote command: 
:INSTruments:MAPPing:FILE on page 67
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Scan LAN instruments with host name prefix
Sets the prefix the searched host names begin with. Use this function to limit the
amount of the searched instruments and to speed up the scan process.

For example, set this field to "RsSGS, RsSGU, RsSGT", if you want to search for all
available instruments.

Tip: If you start a scan for an instrument with a set IP address and it doesn't appear in
the list of available instruments it may be due to the prefixes written in this field. You
can perform another scan while leaving this field empty.

Remote command: 
:INSTruments:SCAN:HNPRefix on page 69

6.1.2.2 Add/Edit Instruments

The dialog provides access to the main instrument's settings, such as "Symbolic
Name", "Instrument Type" and connection settings.

Refer to Chapter 6.4.2, "Handling Instruments in the R&S SGMA-GUI", on page 58
for information on how to configure and manage instruments in R&S SGMA-GUI.

Instrument Nr.
Automatically assigned number that indicates the instrument's index in the list of "Avail-
able Instruments".

Symbolic Name
Selects the alias name of the instrument.
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Remote command: 
:INSTruments:NAME on page 67

Instrument Type
Selects the instrument's family.

Remote command: 
:INSTruments:TYPE on page 69

Active
Activates/deactivates the display of the instrument's settings in the main panel.

Note: Only instruments in an active state can be controlled from the R&S SGMA-GUI!

Remote command: 
:INSTruments:ACTive[:STATe] on page 66

Exclusive Access
Checks whether the instrument is locked by another user and if not locks the instru-
ment. When an instrument is locked, it is reserved and can be operated manually or
remote exclusively from the remote PC on which the R&S SGMA-GUI is running or
from which the SCPI command is sent.

For interfaces using VISA, i.e. for LAN and USB, enabling the "Exclusive Access" trig-
gers the standard viLock request. For remote control over PCIe or Socket, the lock
request is performed on a higher application level.

Note: It is recommended to lock the instrument prior to further configuration.
Locked instruments will not be found by the scan function.
The instrument has to be unlocked to allow operation from another remote PC.

Note: The two functions "Exclusive Access" and monitoring are mutually exclusive.
Disable "Exclusive Access" if the instrument is monitored by an external PC.

Remote command: 
:INSTruments:EACCess[:STATe] on page 67
:LOCK? on page 140
:UNLock on page 140

Device Identity
Triggers the device identification function. The LAN LED on the front panel of the
selected instrument blinks.

See also Chapter 6.4.4, "Bidirectional Instrument Identification ", on page 61.

Hardware Channel
Selects the hardware interface used by the remote channel.

Remote command: 
:INSTruments:REMote:CHANnel on page 68

Instrument Name / IP Address
Enters the IP address or the host name of the connected instrument.

See also Chapter 6.4.3, "Finding Out the Default Hostname of the Instrument",
on page 61.
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Remote command: 
:INSTruments:REMote:NAME on page 68

Serial Number
Enters the serial number as instrument's identification while using the USB or PCIe
interfaces for remote control.

Remote command: 
:INSTruments:SERial on page 69

OK
Confirms the settings and closes the dialog.

Apply
Confirms the settings.

Cancel
Discards settings and closes the dialog.

6.1.2.3 Versions/Options Dialog

Querying information about the installed options and software version

► Select "Setup > Software".

An info dialog opens, showing program information.

Software
Displays information on:

"Package" Installed software packages.

"Version" Release of the software package.

Show Open Source Acknowledgments
Accesses the list of the used open source software packages and the corresponding
verbatim license texts.

Versions
Shows the installed software platform and its version.
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6.1.2.4 Reset SGMA-GUI

Resets R&S SGMA-GUI to its factory preset settings.

The connected instruments are not affected by this preset.
To preset one specific instrument to its factory preset settings, select "SGMA-GUI >
Instrument Name > Setup > Factory Preset". Refer to Chapter 8.9, "Factory Preset",
on page 98 for an overview of the settings affected by this function.

6.1.3 Help

The R&S SGMA-GUI is equipped with a context-sensitive help function. A help page
can be called any time during software operation.

The context-sensitive page which is opened with the F1 button is part of a comprehen-
sive help system.

It is possible to move from this context-sensitive page to any page of the help system.
An overview of the contents of the online help can be reached via the menu "SGMA-
GUI > Help > Contents".

A search for keywords within the help function is available via menu item "SGMA-GUI
> Help > Index".

6.2 Info Dialog and Messages in the Info Bar

A few operating states and the current messages are displayed in the info line. For
information on messages in greater detail and their management, an "Info" dialog can
be opened.

6.2.1 Info Dialog

The "Info" dialog provides a list of currently active permanent messages and a detailed
description of each message. The messages are color-coded according to their level.

Accessing the info dialog

► In the "R&S SGMA-GUI main panel", select the "Info" button.

The "Info" dialog opens.
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The upper part of the "Info" dialog lists the currently active permanent messages. See
the following table for explanation of the displayed information.

Parameter Description

"LEV" Message level. Messages referring to a logical component of R&S SGMA-GUI, e.g.,
Unicode, are marked in red color, info messages are marked in black color.
The following levels might occur:
● Err: Error message
● Info: Information message
● Sys: System message
● Crit: Critical message

For detailed information on the message types, see Chapter 6.2.2, "Understanding the
Messages in the Info Bar", on page 55.

"SCPI" Indicates the SCPI error code.

Text A list of all currently permanent messages in the order of their occurrence, i.e., the most
recent message is displayed first.

The buttons in the lower part of the "Info" dialog provide quick access to some func-
tions for managing these messages. For a detailed description on how to clear error
messages or display a history of all messages, refer to Chapter 6.4.5, "Managing Mes-
sages in the Info Dialog", on page 63.

Function Description

"Delete" Clears the highlighted message. This button is available only if the history of the
messages is displayed.

"Delete All" Clears all messages.

This button is available only if the history of the messages is displayed.

"Del. volatile" Clears all brief messages. This button is available only if the history of the mes-
sages is displayed.

"Show History/Static" Calls the list of all messages that have occurred since instrument switch-on. The
most recent messages are displayed at the top of the list. When the button is
pressed again, the list of current messages is displayed.

Info Dialog and Messages in the Info Bar
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Refer to Chapter 6.4.5, "Managing Messages in the Info Dialog", on page 63 for
information on how to manage messages.

6.2.2 Understanding the Messages in the Info Bar

Messages indicate information, warnings, and errors. They are displayed in the info
line in different colors depending on their importance and display duration. The follow-
ing messages are displayed:
● Error

There are two options:
– Critical errors are errors that prevent the instrument from working, e.g. an HW

failure. Critical errors are displayed in red color.
– System errors are errors that concern the operating system, e.g., wrong file

path. System errors are displayed in black color.
● Information

The information, e.g., file not found, is displayed in black color.
● Warning

A warning indicates a less significant error and is displayed in black color.
● Brief message

Brief messages report automatic settings in the program, e.g. switching on illegal
entries that are not accepted by the program, e.g., range violations. They are dis-
played in the info line on a yellow background. They are displayed on top of status
information or permanent messages.
Brief messages usually do not demand user actions and disappear automatically
after a short period of time. They are stored in the history, however.

● Permanent messages
Permanent messages are displayed if an error occurs that impairs further program
operation. The error signaled by a permanent message must be eliminated before
correct software operation can be ensured.
The message is displayed until the error is eliminated. It covers the status display
in the info line. After error elimination, the message automatically disappears and is
also recorded in the history.

6.3 Main Panel

The main panel of the R&S SGMA-GUI provides quick access to the main settings of
the configured instruments. The display shows one row per instrument and comprises
the instrument name and state, the used frequency and power level, the states of the
RF output and modulator and the used reference source.
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Click one of the buttons with an instrument name on it to access the menu tree with
further settings for the corresponding instrument. For a detailed description of the pro-
vided settings, see:
● Chapter 8, "General Instrument Settings and Instrument Setup", on page 86 for

general settings
● Chapter 7, "Upconverter Settings", on page 70 for R&S SGU settings.

Instrument/Connection State
The three colors of the state indicator in front of the instrument's name distinguish
between the following states:
● Gray: the instrument is configured and activated in the R&S SGMA-GUI but there is

no connection to the instrument.
● Green: the instrument is active, the connection is working and the instrument can

be manually and remotely operated.
● Red: the instrument is in one of the following states:

– Standby state
To operate the instrument manually, it has to be switched to ready state (see
"To return the instrument from standby to ready state" on page 105).

– Instrument locked
The red state indication together with the message "Instrument Locked" in the
"Info" line indicates that the instrument is locked for Exclusive Access from
another SGMA-GUI or controller.

– The instrument is performing a time consuming operation, e.g. a selftest.

Maximum Frequency
The numbers in the rectangular box  on the left of the instrument's name indicate the
maximum frequency of the instrument.

Pulse Modulation
A  sign on the left of the instrument's name indicates that the pulse modulation is
switched on.
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Instrument Name
Displays the alias name of the instrument, as selected by the parameter "SGMA-GUI >
Setup > Instruments > Add/Edit Instruments > Symbolic Name".

Click the button to access a menu tree for configuring the available instrument's set-
tings, e.g. "Level" settings.

Frequency
Sets the RF frequency at the RF output connector of the selected instrument.

Remote command: 
[:SOURce]:FREQuency[:CW|FIXed] on page 160

RF On/Off
Activates and deactivates the RF output signal.

The current state of the RF output (activated and deactivated) is indicated in the main
panel with the different block color (blue or gray) and the status "On/Off".

Remote command: 
:OUTPut[:STATe] on page 158

Mod State
Switches the I/Q modulation on and off.

Remote command: 
[:SOURce]:IQ:STATe on page 161

PEP
Displays the Peak Envelope Power (PEP) of the RF signal of the selected instrument.
The value is calculated as follows:

"PEP" = Level + Crest Factor

Remote command: 
[:SOURce]:POWer:PEP? on page 167

Level/Level Offset
Sets the RF level at the RF output connector of the selected instrument.

If you set a level offset, it will be indicated in the R&S SGMA-GUI main panel by a
change in the name of this parameter from "Level" to "Level Offset".

Note: The SCPI command [:SOURce]:POWer[:LEVel][:IMMediate][:
AMPLitude] sets the level of the "Level" display, that means the level containing off-
set while [:SOURce]:POWer:POWer sets the level at the RF output connector.

Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] on page 166
[:SOURce]:POWer:POWer on page 168

Main Panel
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6.4 Working with R&S SGMA-GUI

This section explains how to work with the R&S SGMA-GUI software and perform con-
figuration tasks for manual operation of the instruments.

6.4.1 Storing and Loading Settings

To proceed work with a particular configuration of the instruments in the R&S SGMA-
GUI, it is useful to save the used settings and load them again later.

How to store and load settings

1. Select "SGMA-GUI main panel > File > Save As".

2. Navigate to the desired directory and enter the filename.
The extension *.savrcl is applied automatically.

The current settings of the software are saved to the selected file.

3. To load settings from a file, select "SGMA-GUI main panel > File > Open"

4. Navigate to the directory the file is stored in and select the setting file.

The saved settings are loaded to the R&S SGMA-GUI and the main panel of the
software displays the saved instrument's configuration.

6.4.2 Handling Instruments in the R&S SGMA-GUI

This section provides information on how to configure and manage instruments in the
R&S SGMA-GUI.

For reference information about all provided settings in the user interface, refer to the
corresponding sections:
● Chapter 6.1.2.1, "Configure Instruments", on page 48 and Chapter 6.1.2.2, "Add/

Edit Instruments", on page 50
● Chapter 6.1.2.3, "Versions/Options Dialog", on page 52

Chapter 6.1.2.4, "Reset SGMA-GUI", on page 53

6.4.2.1 How to Automatically Add New Instruments to the SGMA-GUI

1. For each new instrument perform the following steps:

a) Connect the instrument to the network.
b) Switch on the instrument.
c) Press the ID key on the front panel of the instrument.

2. Start the SGMA-GUI on a computer connected to the same network.

All instruments are added automatically to the main panel of the SGMA-GUI.
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6.4.2.2 How to Manually Add New Instruments to the SGMA-GUI

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens.

2. Select the "New" button.

The Add Instrument dialog opens to register a new instrument.

3. In the "Symbolic Name" field, enter an alias name of your choice, e.g.
SGU-100021.

4. In the "Instrument Type" field, select the device family to connect to.

5. Select "Remote Control > Hardware Channel" and select the hardware interface.

6. For LAN or Socket interfaces, select "Remote Control > Instrument Name / IP
Address" and enter the IP Address or the hostname of the connected instrument,
e.g. rssgu100a100021.

Tip: See also Chapter 6.4.3, "Finding Out the Default Hostname of the Instrument",
on page 61 .

7. For USB or PCIe interfaces, select "Remote Control > Serial Number" and enter
the serial number of the connected instrument , e.g. 100021.

8. Set "Active > On" to activate the instrument. Only active instruments are displayed
in the R&S SGMA-GUI main panel.

9. Click "OK" to confirm the settings and to close the dialog or press the "Apply" but-
ton to confirm the settings.

10. Click the "Cancel" button to discard settings and to close the dialog.

6.4.2.3 How to Scan for New Instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens.

2. Click the "Scan" button to trigger the instrument to scan all remote channel interfa-
ces for connected instruments.

Tip: To limit the amount of the searched instruments and to speed up the scan
process, select "Configure Instruments > Scan LAN instruments with hostname
prefix" and enter the prefix the searched hostnames begin with.
The scan function searches only for instruments whose hostnames begin with the
selected prefix.

All instruments which are connected to one of the available interfaces, are
switched on and are not locked are displayed in the"Available Instruments" list.
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The R&S SGMA-GUI obtains all information for connecting to the instrument, so
further configuration is not necessary.

6.4.2.4 How to Activate Instruments for Control from the R&S SGMA-GUI

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The "Available Instruments" in the Configure Instruments dialog lists all instruments
configured in the software.

2. Select the newly configured/connected or deactivated instrument and set "Active >
On" to activate it.

Tip: Only active instruments are displayed in the R&S SGMA-GUI main panel!

6.4.2.5 How to Edit Instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens and lists the "Available Instruments".

2. Select the instrument to be edited and click the "Edit" button.

The Edit Instrument dialog opens.

3. Change the settings and confirm with OK.

The edited settings are applied.

6.4.2.6 How to Delete an Instrument

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".
The Configure Instruments dialog opens.

2. Select the instrument to be deleted and click the "Delete" button.

The selected instrument is deleted from the list of "Available Instruments".

6.4.2.7 How to Delete All Instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".
The Configure Instruments dialog opens.

2. Click the "Clear" button.

All instruments are deleted from the list of "Available Instruments".
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6.4.2.8 How to Reserve the Instrument for Control

1. Open the "SGMA-GUI > Setup > Instruments > Configure Instruments" dialog,
select the instrument in the list of "Available Instruments" and select "Edit".

2. In the "Edit Instrument" dialog, enable "Exclusive Access".

3. Alternatively, send the SCPI command :INSTruments:EACCess[:STATe] from
the external PC the R&S SGMA-GUI is installed on.

The instrument is reserved for control from this external PC and cannot be
accessed from any other controller. A scan function started from another controller
finds the instrument but the instrument is indicated as locked.

The two functions "Exclusive Access" and monitoring are mutually exclusive!
The "Exclusive Access" must be disabled to remote control or monitor the instrument
form another external PC (see Chapter 10.5, "Using the R&S SGMA-GUI to Monitor
the Remote Control Operation", on page 127).

6.4.3 Finding Out the Default Hostname of the Instrument

The default hostname of the instrument is a non-case-sensitive string built as follows:

hostname = <instrument name><serial number>, where

<serial number> is the individual serial number of the instrument

<instrument name> is the complete name of the instrument, written without spaces.

How to query the hostname of the instrument

1. Find the individual serial number on rear of the instrument , e.g. 100021.

2. Build the default hostname.

For the R&S SGU with serial number 100021, the default hostname is
rssgu100a100021.

For instructions on how to change the default hostname, refer to Chapter 9.4, "How to
Use Computer Names", on page 106.

6.4.4 Bidirectional Instrument Identification

In practice, instruments are integrated into a large network or placed in racks together
with several other instruments of the same kind. It might be difficult then to find out
which of the instruments configured in the R&S SGMA-GUI corresponds to which
physical instrument or to localize all instruments operated by the current controller.
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The R&S SGMA-GUI and the instrument provide the "Device Identification" function for
this purpose.

How to find an instrument in the R&S SGMA-GUI

► If several instruments have been configured and activated in the R&S SGMA-GUI,
press the ID button on the instrument's front panel to trigger device identification.

The "Edit Instrument" dialog of this instrument opens.

Field "Edit Instrument > Symbolic Name" displays the name of the instrument as
shown in the R&S SGMA-GUI main panel.
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Dialog "Edit Instrument" does not appear
If this dialog does not open, perform the following:
● Check whether the instrument is correctly connected to the external PC on which

you work with the R&S SGMA-GUI.
● Check if the instrument is configured in the R&S SGMA-GUI and perform, if neces-

sary, the steps described in Chapter 6.4.2, "Handling Instruments in the R&S
SGMA-GUI", on page 58.

● Select "SGMA-GUI > Setup > Instruments", check the state of the instrument in the
"Configure Instruments > Available Instruments" table and activate it, if disabled.

How to identify an instrument in an instrument set

► To identify the instrument in an instrument set, use one of the device identification
functions:

a) Select "SGMA-GUI > Setup > Instruments > Available Instruments > Instrument
> Edit > Edit Instrument" and trigger "Device Identify"

b) Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Chan-
nels" and trigger "Device Identify"

The green LAN LED on the front panel of the instrument blinks.

6.4.5 Managing Messages in the Info Dialog

How to get additional information on the message

► In the "Info" dialog, click a message to select it.

In the lower section of the dialog, additional information on the highlighted mes-
sage is displayed.
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How to display all messages

► In the "Info" dialog, click the "History" button.

A history of all messages that have occurred since the R&S SGMA-GUI software
was started is listed in the upper dialog pane. The most recent message is dis-
played first.

How to delete an error message

► In the "Info" dialog, select the highlighted message and click the "Delete" button.

Tip: This button is available only when the history of the messages is displayed.

The highlighted message is cleared.

How to delete all error messages

► In the "Info" dialog, click the "Delete All" button.

Tip: This button is available only when the history of the messages is displayed.

All messages are cleared.

How to delete all brief messages

► In the "Info" dialog, click the "Del. volatile" button.

Tip: This button is available only when the history of the messages is displayed.

All brief messages are cleared.

How to call the history

1. In the "Info" dialog, click the "History" button.

A list of all messages that have occurred since the instrument switch-on is dis-
played. The most recent messages are displayed at the top of the list.

2. Click the "History" button once more.
A list of current messages is displayed.

6.5 Remote Control of the R&S SGMA-GUI

This section focuses on the remote control of the R&S SGMA-GUI software.

6.5.1 Configuring Instruments in the R&S SGMA-GUI

This section provides an example of the automation of the R&S SGMA-GUI.
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In the following example we assume that a remote PC with installed R&S SGMA-GUI
on it is connected to a LAN and that the remote PC and the instruments are switched
on.

For more information, refer to Chapter 2.3, "Connecting an External PC and Devices",
on page 20.

// ******************************************************************
// Trigger the scan function to search for instruments connected 
// to the remote computer via all of the available interfaces. 
// ******************************************************************

:INSTruments:SCAN:HNPRefix "rssg"
// scan returns only instruments with hostname beginning with "rssg"
:INSTruments:SCAN 1
*OPC?

// ******************************************************************
// Query the number of available instruments and the settings of each 
// configured instrument: instrument type, symbolic name, 
// remote channel used, serial number, hostname/IP address
// Adjust settings if required
// ******************************************************************

:INSTruments:COUNt?
// Response: 3

:INSTruments:TYPE?
// Response: SGU,SGS,SGT

:INSTruments:NAME?
// Response: SGU-100002,SGS-100006, SGT-100008

:INSTruments:SERial?
// Response: 100002,100006,100008

:INSTruments:REMote:CHANnel?
// Response: LAN,USB, PCIe

:INSTruments:REMote:NAME?
// Response: rssgu100a100002, rssgs100a100006, rssgt100a100008

// ******************************************************************
// Check the instrument state and activate instruments if required
// ******************************************************************

:INSTruments:ACTive:STATe?
// Response: 0,1,1
:INSTruments:ACTive:STATe ON,OFF,OFF
// Activates the first  instruments in the list, 
// i.e. the instruments with symbolic names SGS-100006
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// ******************************************************************
// Export the configuration into a mapping file
// ******************************************************************

:INSTruments:MAPPing:FILE 'd:\mapping_files\mapping.map'

// ******************************************************************
// Enable exclusive access for the selected instrument
// ******************************************************************

:INSTruments:EACCess:STATe?
// Response: 0,0,0
:INSTruments:EACCess:STATe ON,0FF, 0FF
// Locks the first instrument

6.5.2 R&S SGMA-GUI Settings

This section comprises the SCPI commands provided to remote control the R&S
SGMA-GUI.

:INSTruments:ACTive[:STATe]..........................................................................................66
:INSTruments:COUNt?..................................................................................................... 67
:INSTruments:EACCess[:STATe].......................................................................................67
:INSTruments:MAPPing:FILE............................................................................................ 67
:INSTruments:NAME........................................................................................................67
:INSTruments:REMote:CHANnel....................................................................................... 68
:INSTruments:REMote:NAME........................................................................................... 68
:INSTruments:SCAN........................................................................................................ 68
:INSTruments:SCAN:HNPRefix......................................................................................... 69
:INSTruments:SERial....................................................................................................... 69
:INSTruments:TYPE.........................................................................................................69

:INSTruments:ACTive[:STATe] <State>

Enables/disables the instrument for the R&S SGMA-GUI. The main panel of this soft-
ware displays only activated instruments.

Parameters:
<State> List of BOOL-values

<StateInstr#1>,<StateInstr#2>,...
0, 1, ON, OFF

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Manual operation: See "Available Instruments" on page 48
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:INSTruments:COUNt?

Queries the number of the currently available instruments.

Return values: 
<Count> float

Range: 0  to  12

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Usage: Query only

Manual operation: See "Available Instruments" on page 48

:INSTruments:EACCess[:STATe] <State>

"Locks" the instruments, meaning the instrument is reserved and can be operated
exclusively from the remote PC that sent this SCPI command.

Tip: It is recommended to lock the instrument prior to further configuration.

Parameters:
<State> List of BOOL-values

<LockInstr#1>,<LockInstr#2>,...
0,1,OFF,ON

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Manual operation: See "Exclusive Access" on page 51

:INSTruments:MAPPing:FILE <File>

Saves the list of the available instruments in a mapping file. Mapping files are stored
with the predefined file extension .map; the file extension may be omitted.

The file is saved in the default directory. Use the command MMEM:CDIRectory to
change the default directory or specify the complete path.

Parameters:
<File> string

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Manual operation: See "Export" on page 49

:INSTruments:NAME <Name>

Selects the alias name of the instruments, i.e. sets the "Symbolic Name".

Parameters:
<Name> <SymbolicNameInstr#1>,<SymbolicNameInstr#2>,...

Remote Control of the R&S SGMA-GUI

ManualsPlus.com

https://www.manualsplus.com/


Understanding the R&S SGMA-GUI SoftwareR&S®SGU100A

68User Manual 1176.7726.02 ─ 07

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Manual operation: See "Available Instruments" on page 48

:INSTruments:REMote:CHANnel <Channel>

Sets the hardware interface used by the remote channel.

Parameters:
<Channel> List of CHAR-Data

<Channellnstr#1>,<Channellnstr#2>,...
The available interfaces are: LAN, USB, SOCKET, PCIe, GPIB,
HiSLIP

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Manual operation: See "Hardware Channel" on page 51

:INSTruments:REMote:NAME <Name>

Enters the IP Address or the host name of the connected instrument.

Parameters:
<Name> <Hostname/IP-AddressInsr#1>,<Hostname/IP-Addres-

sInsr#2>,...

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Manual operation: See "Instrument Name / IP Address" on page 51

:INSTruments:SCAN <State>

Triggers a scan function and searches for instruments connected to the remote com-
puter via all of the available interfaces.

Parameters:
<State> number

1 = triggers the scan function, 0 = aborts the running scan proc-
ess
The query command returns 1 as long as scan is running; 0 indi-
cates completed scan process.

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Manual operation: See "Scan" on page 48
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:INSTruments:SCAN:HNPRefix <Prefix>

Sets the prefix the searched host names begin with.

Parameters:
<Prefix> string

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Manual operation: See "Scan LAN instruments with host name prefix" on page 50

:INSTruments:SERial <Serial>

Enters the serial number as instrument's identification while using the USB interface for
remote control.

Parameters:
<Serial> <SerialNumberInstr#1>, <SerialNumberInstr#2>,...

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Manual operation: See "Serial Number" on page 52

:INSTruments:TYPE <Type>

Selects the instrument's family.

Parameters:
<Type> List of CHAR-Data

<TypeInstr#1>,<TypeInstr#2>,...

Example: See Chapter 6.5.1, "Configuring Instruments in the R&S SGMA-
GUI", on page 64.

Manual operation: See "Available Instruments" on page 48

6.5.3 List of R&S SGMA-GUI Commands

:INSTruments:ACTive[:STATe]........................................................................................................................66
:INSTruments:COUNt?.................................................................................................................................... 67
:INSTruments:EACCess[:STATe]....................................................................................................................67
:INSTruments:MAPPing:FILE.......................................................................................................................... 67
:INSTruments:NAME....................................................................................................................................... 67
:INSTruments:REMote:CHANnel.....................................................................................................................68
:INSTruments:REMote:NAME......................................................................................................................... 68
:INSTruments:SCAN........................................................................................................................................68
:INSTruments:SCAN:HNPRefix.......................................................................................................................69
:INSTruments:SERial.......................................................................................................................................69
:INSTruments:TYPE........................................................................................................................................ 69
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7 Upconverter Settings
This section summarizes the settings necessary to configure the instrument for signal
generation. The description in this section follows the menu tree structure of the graph-
ical user interface. Each of the discussed topics follows a common structure, providing
basic background information and reference to the user interface.

Additionally, there is a section summarizing advanced configuration tasks.

For step-by-step instructions for fulfilling typical tasks, refer to Chapter 9, "Performing
Configuration Tasks", on page 101.

7.1 Frequency Settings

Depending on the installed options, the instrument provides an adjustable output fre-
quency in the frequency range of 10 MHz to 40 GHz.

► To access this dialog, select "SGMA-GUI > Instrument Name > Frequency".

Configuring the RF Frequency

► To change the RF frequency of the selected instrument, perform one of the follow-
ing:

a) Select "SGMA-GUI main panel > Freq" and enter the desired frequency.
b) Select "SGMA-GUI > Instrument Name > Frequency/Phase > Frequency" and

enter the desired frequency.

You have to confirm the changes of the RF frequency in the External Local Oscilla-
tor Settings dialog for them to be applied to the signal.

Frequency
Sets the RF frequency at the RF output connector of the selected instrument.

Remote command: 
[:SOURce]:FREQuency[:CW|FIXed] on page 160

7.2 Level and Power-On Settings

This section explains the level settings of the R&S SGU. The instrument can be equip-
ped optionally with an active electronic step attenuator (R&S SGU-B26).
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Configuring RF Level

► To change the RF level of the selected instrument, perform one of the following:

a) Select "SGMA-GUI main panel > Level" and enter the desired value.
b) Select "SGMA-GUI > Instrument Name > Level > RF Level > Level" and enter

the desired value.

You have to confirm the changes of the RF level in the External Local Oscillator
Settings menu for them to be applied to the signal.

7.2.1 RF Level

► To access the RF level settings, select "SGMA-GUI > Instrument Name > Level >
RF Level".

This dialog comprises settings like the RF level and level limit.

Level/Level Offset
Sets the RF level at the RF output connector of the selected instrument.

If you set a level offset, it will be indicated in the R&S SGMA-GUI main panel by a
change in the name of this parameter from "Level" to "Level Offset".

Note: The SCPI command [:SOURce]:POWer[:LEVel][:IMMediate][:
AMPLitude] sets the level of the "Level" display, that means the level containing off-
set while [:SOURce]:POWer:POWer sets the level at the RF output connector.
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Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] on page 166
[:SOURce]:POWer:POWer on page 168

Offset
Sets a level offset.

This value represents the level shift of a downstream instrument, as for example an
attenuator or an amplifier, and is indicated in the status bar of the display. It does not
change the level at the RF output.

Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet on page 167

Mode
Allows you to optimize the RF output signal for applications, where improved harmonic
distortion or improved wideband noise is required.

"Normal" In normal mode, the generator provides an RF output signal with high
signal to noise ratio as well as low distortion, according to the data
sheet.

"Low Noise" This setting forces the generator to optimize the signal to noise ratio.

"Low Distortion"
In this mode, the generator reduces distortions of the RF signal to a
minimum.

Remote command: 
[:SOURce]:POWer:LMODe on page 166

Setting Characteristic
Selects the characteristic for the level setting. For some general applications, the
instrument operation can be optimized by choosing one of the predefined level setting
characteristics.

"Auto" The instrument provides the highest dynamic range and the fastest
setting times according to the data sheet.
The RF signal is shortly blanked during the moment the step attenua-
tor is switched on.

"Uninterrupted Level setting"
Suppresses level blanking at frequency and level changes.
This mode reduces the dynamic range of the instrument. The step
attenuator is fixed.

"Strictly Monotone"
Provides level setting without discontinuities. All electronic switches in
the RF path are clamped. The operation mode is useful for applica-
tions using level searching algorithms.
This mode further reduces the dynamic range of the instrument.

"Constant-VSWR"
Suppresses output impedance variations at the RF OUT connector
due to switching of the step attenuator. The step attenuator is fixed.
This mode reduces the dynamic range of the instrument.
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Remote command: 
[:SOURce]:POWer:SCHaracteristic on page 166

Level Range
Displays the level range within which the level setting is expected to work properly. The
range limits depend on several parameters like "Mode", "Setting Characteristic", the I/Q
signal's crest factor etc.

Remote command: 
[:SOURce]:POWer:RANGe:LOWer? on page 168
[:SOURce]:POWer:RANGe:UPPer? on page 168

Limit
Sets the level limit.

The value specifies the upper limit of the level at the RF OUT connector. A message
appears if an attempt is made to set a level above this limit and the level at the RF out-
put is confined to the upper limit. However, the level indication is not influenced.

The value is not affected by an instrument preset function. This parameter is influenced
only by the Factory Preset and its factory value is equal to the upper limit.

Remote command: 
[:SOURce]:POWer:LIMit[:AMPLitude] on page 167

Readjust
Recalculates the instrument internal settings optimized for the current level. Not
required for automatic modes.

Remote command: 
[:SOURce]:POWer:ALC:SONCe on page 165

7.2.2 Attenuator

► To access the attenuator settings, select "SGMA-GUI > Instrument Name > Level
>Attenuator".

This dialog comprises the settings for the power-on behavior of the instrument.
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Mode
Sets the attenuator mode at the RF output.

"Auto" Standard mode.
The electronically switching attenuator switches with a ~ 6 dB step
width at optimized switching points. The entire level range is availa-
ble. The level setting is performed by continuous electronic level con-
trol combined with switching the step attenuator.

"Fixed" The level settings are made without switching the attenuator. When
this operating mode is switched on, the attenuator is fixed in the cur-
rent position to provide level settings without interruption. The result-
ing variation range is defined and displayed under Level Range.

Note: The function is effective when automatic level control is activa-
ted ("ALC State = On"). If the normal variation range is overranged or
underranged, level errors increase considerably and the warning
"Level under/overrange" appears in the info line. The spectral purity
of the output signal decreases with high attenuation.

Remote command: 
:OUTPut:AMODe on page 158

Level Range
Displays the level range in which the level is set without interruption for the "Attenuator
Mode Fixed" setting.

Remote command: 
:OUTPut:AFIXed:RANGe:LOWer? on page 159
:OUTPut:AFIXed:RANGe:UPPer? on page 159

SATT Switch-Over Offset
Sets the switch-over offset value of the attenuator.

Remote command: 
[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet] on page 166

RF-Off-Mode
Determines the attenuator's state after the instrument is switched off.

In default setting, the electronic step attenuator switches to highest attenuation when
RF is off. By setting the RF-Off mode, the electronic step attenuator can be fixed to
keep the output impedance constant during RF off.

Remote command: 
[:SOURce]:POWer:ATTenuation:RFOFf:MODE on page 165
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7.2.3 Power-On/EMF

► To access the power- on/EMF settings, select "SGMA-GUI > Instrument Name >
Level > Power-On/EMF".

This dialog comprises the settings for the power-on behavior of the instrument.

Power-On State
Selects the state which the RF output takes after the instrument is switched on.

"RF Off" The output is deactivated when the instrument is switched on.

"Previous Setting"
When the instrument is switched on, the output takes the same state
as it had when the instrument was switched off.

Remote command: 
:OUTPut[:STATe]:PON on page 159

7.2.4 ALC

► To access the automatic level control (ALC) settings, select "SGMA-GUI > Instru-
ment Name > Level > ALC".

Automatic level control can be used with almost all applications, especially I/Q
modulation. It only has to be deactivated for certain settings in the baseband and
when I/Q impairments ("Impairments State On") are activated. This is indicated
under the respective function.
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By default, the instrument operates in "Table & On" mode to provide the highest
level accuracy and fastest setting time. Level control can be switched to "Off
(Table)" or "On" for particular applications. The "Off (Table)" state (level control Off)
is recommended if in CW mode the signal/intermodulation ratio is to be improved
for multi-transmitter measurements.

State
Sets the internal level control.

"Table & On" Default mode.
First sets the level to the target value using the internal level table.
Then activates the level control circuit to achieve maximum level
accuracy.

"On" Internal level control is permanently activated.
If "On" and "Attenuator Mode Fixed" is selected, the level is recalibra-
ted for every level and frequency setting.

"Off (Table)" Internal level control is performed according to the ALC table.

Remote command: 
[:SOURce]:POWer:ALC[:STATe] on page 165

Detector Sensitivity
Allows you to fix the internal level detector. It is recommended to use the Auto mode
(default).

"Auto" Automatic detector selection. Recommended mode of operation.

"Low" Low sensitivity detector selected.
This setting is intended for signals with high internal electronic levels.

"Med" Medium sensitivity detector selected.
This setting corresponds to normal mode. It is intended for signals
with medium internal electronic levels.

"High" High sensitivity detector selected.
Selects the detector path with high sensitivity, intended for signals
with low internal electronic levels.

"Fix" Fixes the last set sensitivity setting.

7.3 I/Q Modulation and Signal Impairment

The R&S SGU offers I/Q modulation with external analog I/Q signals. I/Q modulation
with an external analog I/Q signal is possible for the instrument equipped with fre-
quency options R&S SGU-B120V/-B140V. The external signal is input via the I IN and
Q IN connectors and transferred to the I/Q modulator.

Before the signal is fed into the I/Q modulator, the signal can be impaired. Impairment
at this point along the signal flow is offered to allow error correction of the supplied sig-
nal or set dedicated impairments.
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7.3.1 I/Q Impairments

Signal impairments are well-defined arithmetic modifications of the data. Every data
sample is modified in the same way. The purpose of adding impairments to the data
stream is to simulate frequent sources of distortions in a real signal-processing chain in
order to generate a test signal with dirty transmitter conditions.

7.3.1.1 Gain and Gain Imbalance

An I/Q gain is a multiplication of all I/Q amplitudes by a common factor. The effect is
equivalent to two identical I and Q gain factors. The effect of an increased gain factor
in the I/Q constellation diagram is shown below.

Figure 7-1: Effect of an increased amplitude in the I/Q constellation diagram

An I gain multiplies the I amplitudes by a factor, leaving the Q amplitudes unchanged.
A Q gain has the opposite effect. Different I and Q gain factors result in an I/Q imbal-
ance, which is usually due to different gains of the amplifiers in the I and Q channels of
the I/Q modulator. The effect of a positive and negative gain imbalance is shown
below.

 

 

I/Q Modulation and Signal Impairment

ManualsPlus.com

https://www.manualsplus.com/


Upconverter SettingsR&S®SGU100A

78User Manual 1176.7726.02 ─ 07

Figure 7-2: Negative gain imbalance (left) and positive (right) gain imbalance in the I/Q constellation
diagram

7.3.1.2 I and Q Offset

An I offset adds a constant value to all I amplitudes, leaving the Q amplitudes
unchanged. A Q offset has the opposite effect. A combination of I and Q values results
in an I/Q offset, which is usually due to carrier feedthrough in the I/Q modulator. Possi-
ble reasons are interfering signals at the RF carrier frequency, e.g. an unsuppressed
RF carrier subchannel. The effect of a positive I and Q offset in the I/Q constellation
diagram is shown below.

Figure 7-3: I offset (left) and Q offset (right) in the I/Q constellation diagram

7.3.1.3 Quadrature Offset

Changes the phase angle between the I and Q vectors from the ideal 90 degrees,
while the amplitudes are maintained. A positive quadrature offset results in a phase
angle greater than 90 degrees. The effect of a positive quadrature offset in the I/Q con-
stellation diagram is shown below.
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Figure 7-4: Positive quadrature offset in the I/Q constellation diagram

7.3.2 General I/Q Settings

► To access the settings of the I/Q modulator, select "SGMA-GUI > Instrument Name
> I/Q Settings > General".

Comprises the settings for setting the state and the analog wideband I/Q input.

Mod State
Switches the I/Q modulation on and off.

Remote command: 
[:SOURce]:IQ:STATe on page 161

Crest Factor
Sets the crest factor of the I/Q modulation signal.

The crest factor gives the difference in level between the peak envelope power (PEP)
and average power value (RMS) in dB. This value is necessary for the generation of
the correct output power at the RF output, i.e. the instrument uses the PEP value to
compensate the average power.
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The maximum input voltage at the I/Q input is equated to the peak power and is used
as the "reference" for setting the level of the output signal. Since the signal does not
usually supply the peak power at a constant level and instead supplies lower average
power, the crest factor specifies how many dB have to be added internally so that the
correct output power is achieved.

Remote command: 
[:SOURce]:IQ:CREStfactor on page 163

7.3.3 Analog Impairment Settings

► To access the settings of the I/Q modulator, select "SGMA-GUI > Instrument Name
> I/Q Settings > Analog Impairments".

Comprises the settings like I/Q offset and quadrature offset.

State
Activates/deactivates I/Q impairments.

If activated, the settings for offset, gain imbalance and quadrature offset become effec-
tive.

Note: It is advisable to switch automatic level control to the "Off (Table)" mode, as oth-
erwise level errors may occur.

Remote command: 
[:SOURce]:IQ:IMPairment:STATe on page 162

Offset
Sets the carrier offset (in percent) of the amplitudes (scaled to the peak envelope
power (PEP) for the I and/or Q signal component. An ideal I/Q modulator suppresses
the carrier offset completely (offset = 0 percent).

For more information, see Chapter 7.3.1.2, "I and Q Offset", on page 78.
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Remote command: 
[:SOURce]:IQ:IMPairment:LEAKage:I on page 162
[:SOURce]:IQ:IMPairment:LEAKage:Q on page 162

Gain Imbalance
Sets the imbalance of the I and Q vector (see Chapter 7.3.1.1, "Gain and Gain Imbal-
ance", on page 77).

The entry is made in dB (default) or %, where 1 dB offset is roughly 12 % according to
the following:

Imbalance [dB] = 20log ( | GainQ | / | GainI |)

Positive values mean that the Q vector is amplified more than the I vector by the corre-
sponding percentage. Negative values have the opposite effect.

Remote command: 
[:SOURce]:IQ:IMPairment:IQRatio on page 161

Quadrature Offset
Sets the quadrature offset (see Chapter 7.3.1.3, "Quadrature Offset", on page 78).

Remote command: 
[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe] on page 162

7.4 Pulse Modulation Setting

The R&S SGU offers pulse modulation using external pulse signals. The external pulse
signal has to be connected to the multi purpose TRIG connector.

7.4.1 Pulse Modulation Settings

► To access the pulse modulation settings, select "SGMA-GUI > Instrument Name >
Pulse Modulation".

The "Pulse Modulation" dialog contains all parameters required to configure pulse
modulation and pulse signal generation.
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State
Sets the state of the pulse modulator.

Remote command: 
[:SOURce<hw>]:PULM:STATe on page 169

Polarity
Sets the polarity of the pulse modulator signal.

"Normal" The RF signal is suppressed during the pulse pause.

"Inverse" The RF signal is suppressed during the pulse.

Remote command: 
[:SOURce<hw>]:PULM:POLarity on page 169

7.4.2 Pulse Connector/Trigger Settings

► To access the pulse connector/trigger settings, select "SGMA-GUI > Instrument
Name > Pulse Modulation > Connector/Trigger".

Comprises the settings necessary to configure the signal at the multi purpose TRIG
connector in the external trigger mode.

Trigger Connector Mode
Determines the signal at the input/output of the multi purpose TRIG connector.

"Signal Valid" Output of high signal to mark valid frequency and level settings.

"Not Signal
Valid "

Output of high signal to mark the transition state when frequency and
level change.

"Pulse Mod Ext
Source"

Input for an externally provided pulse modulation signal
Used when an external pulse modulator source is provided at the
connector.

Remote command: 
:CONNector:TRIGger:OMODe on page 146

7.5 External Local Oscillator Settings

In a setup where an R&S SGU is connected to an incompatible signal generator (local
oscillator), the controller has to change the frequency and the level of this local oscilla-
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tor (LO) in order to output the desired signal from the R&S SGU.The required settings
of the local oscillator are shown in the "Local Oscillator" dialog.

► To access this dialog select "SGMA-GUI > Instrument Name >Ext. Local Oscilla-
tor".

When changing any parameters which affect the output signal of the combined system
of an incompatible LO and an R&S SGU, follow these steps:

Setting the signal of the R&S SGU

1. Set the parameters of the R&S SGU like frequency and level in the R&S SGMA-
GUI as needed.

2. Open the "SGMA-GUI > Instrument Name >Ext. Local Oscillator" dialog and read
the settings for "Frequency" and "Level".

3. Apply the required changes to the LO.

4. Press the "Confirm External LO Settings" button to confirm that you have made the
settings on the LO.

The desired signal is output by the R&S SGU.

Frequency
Shows the desired frequency for the LO input signal.

Remote command: 
[:SOURce]:LOSCillator:FREQuency? on page 164

Level
Shows the desired level for the LO input signal.

Remote command: 
[:SOURce]:LOSCillator:POWer? on page 164

Confirm External LO Settings
Outputs the signal.

Remote command: 
[:SOURce]:SETTings:APPLy[:IMMediate] on page 160

External Local Oscillator Settings
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7.6 Trigger Connector Settings

► To access this dialog select "SGMA-GUI > Instrument Name > Connector".

This dialog comprises the settings for configuring the connector.

Trigger Connector Mode
Determines the signal at the input/output of the multi purpose TRIG connector.

"Signal Valid" Output of high signal to mark valid frequency and level settings.

"Not Signal
Valid "

Output of high signal to mark the transition state when frequency and
level change.

"Pulse Mod Ext
Source"

Input for an externally provided pulse modulation signal
Used when an external pulse modulator source is provided at the
connector.

Remote command: 
:CONNector:TRIGger:OMODe on page 146

7.7 Preset

Calls up a defined instrument setup. All parameters and switching states are preset
(also those of inactive operating modes). The default instrument settings provide a
reproducible initial basis for all other settings. However, functions that concern the inte-
gration of the instrument into a measurement setup are not changed.

Overview of the most important preset states

The following list gives an overview of the presets for the most important generator set-
tings. The other presets can be found in the information accompanying the remote
commands.
● "RF frequency" = 1 GHz
● "RF output" switched off
● "Modulator State" = Off

Settings that are not affected by the "SGMA-GUI > Instrument Name > Preset" func-
tion:
● Power on settings ("Level" dialog)
● Network settings ("Setup" dialog)
● Password and settings protected by passwords ("Setup" dialog)
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To preset the R&S SGMA-GUI itself and all configured instruments to their predefined
state, use the "SGMA-GUI > File > New" function.

SCPI command:

:SYSTem:PRESet on page 141
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8 General Instrument Settings and Instrument
Setup
This section describes the settings which do not directly affect signal generation.

Access:

► Select "SGMA-GUI > Instrument Name > Setup" and select the required dialog.

8.1 Hardware Configuration

Querying information about the installed assemblies

► Select "SGMA-GUI > Instrument Name > Setup > Hardware Config".

In the "Hardware Config" dialog, the installed assemblies together with their var-
iants and revision states can be displayed for servicing purposes.
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The dialog is a table that lists the installed assemblies. It is divided into the sec-
tions:
● "Common Assembly"
● "RF Assembly"

Assembly
The tables list the installed assemblies.

"Assembly" Name of the assembly

"Part Number" Part Number of the assembly

"Serial Number"
Serial number of the assembly

"Revision" Revision state of assembly

Remote command: 
:SYSTem:HARDware:ASSembly<dir>:SNUMber? on page 181
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8.2 Software / Options

Querying information about the installed options and software version

► Select "SGMA-GUI > Instrument Name > Setup > Software/Options".

The "Software/Options" dialog shows the firmware version of the instrument soft-
ware and all installed hardware and software options.

The dialog is divided into the following sections:
● "Firmware"
● "Hardware"
● "Software"
● "Loaded Modules"
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Software options purchased at a later stage can be activated with a keycode. The acti-
vation code is supplied with the software option. An instruction on how to install options
is described in the service manual. Most hardware options need to be installed at an
authorized Rohde & Schwarz service center.

Software
Shows the software/firmware version and the version of the software platform.

Note: Your instrument is delivered with the latest firmware version available. Firmware
updates and the Release Notes describing the improvements and modifications are
provided on the Internet at the download site of the instrument's home page. This
home page always offers the latest information on your instrument, e.g. also on
changes of the firmware update procedure.

Hardware / Software/WinIQSIM
The tables in the sections "Hardware" and "Software" list the installed hardware and
software options.

"Option" Short name of the option

"Designation" Name of the option

"Licenses" Number of licenses

"Expiration Date"
For regular options, "Permanent" is indicated in this column. Some
options are available as trial versions. This column shows their expi-
ration date. After this date, the option is no longer available on the
instrument.

Loaded Modules
Section "Loaded Modules" is provided for service purposes. It lists all loaded software
modules with their versions and offers a short description of each module.

Show Open Source Acknowledgments
Accesses the list of the used open source software packages and the corresponding
verbatim license texts.

8.3 Install SW-Options

Newly purchased software options are enabled in the "Install SW-Option" dialog. They
are ready to operate after they are enabled by a key code supplied with the option.

Only if the instrument is equipped with an older firmware version, a firmware update
before enabling the software option may be required. The information on the valid firm-
ware versions for the purchased software option is provided together with the option.
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See:
● Chapter 9.5, "How to Install a New Firmware Version on the Instrument",

on page 107 for information on how to perform firmware update
● Chapter 9.6, "How to Activate Options", on page 108 for instruction on how to

install new options

The firmware update is also described in the service manual.

8.4 Protection

The "Protection" dialog provides access to the unlocking of protected service functions
(authorized personnel of R&S Service Departments only).

Unlocking of protected service functions

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Protection".

The "Protection" dialog provides access to the unlocking of protected service func-
tions (authorized personnel of R&S Service Departments only).

2. To deactivate the protection, the correct password has to be entered. After the
instrument has been switched on, the protection levels 1 to 4 are automatically
activated.
Enter "Protection Level 1 > Password > 123456".

Protection Level 1 is activated.

Protection Level / Password
"Protection Level 1" can be activated to expand the functionality of the internal adjust-
ment. The password is 123456.

The other protection levels 2 to 4 provide access to protected service functions. Only
the authorized personnel of R&S Service Departments can access these functions.
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8.5 Security Setting

The R&S SGU employs a security concept based on user and security password. The
security password is required for changing several critical settings, like performing firm-
ware updates. Access to the passwords and mass storage security settings is provided
in the "Security" dialog.

► To access the "Security" dialog, select "SGMA-GUI > Instrument Name > Setup >
Security"

The menu is divided into the password sections and the security settings section. In
the password section, the passwords for securing a controlled access to the instrument
are defined and changed.

A change of passwords for the operating system and security password requires the
entry of the old and new password and the conformation of the new password. All set-
tings are only accepted after the "Change Password" button is pressed.
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The settings of this dialog are not accessible over remote control (e.g. SCPI com-
mands).

Change User Password
The user name and password are required for remote access to the instrument via
VNC, FTP or SAMBA.

Note: It is highly recommended to change the default user password before connect-
ing the instrument to the network.

User Name ← Change User Password
Indicates the user name used for access to the Linux operating system and valid for
VNC, FTP and SAMBA access.

Old Password ← Change User Password
Enter the currently used user password. The default password is "instrument".

New Password ← Change User Password
Enter the new user password.

Confirm Password ← Change User Password
Enter the new password for conformation.

The new password is only valid after the "Change Password" button is pressed.

Change Password ← Change User Password
Changes the password accordingly.

Change Security Password
Note: It is highly recommended to change the default security password before con-
necting the instrument to the network.
The security password is for example required when changing the status of the USB
and LAN interface.

Old Password ← Change Security Password
Enter the currently used security password. The default password is '123456'.

New Password ← Change Security Password
Enter the new security password. The security password may contain decimal charac-
ters only.

Confirm Password ← Change Security Password
Enter the new password for conformation.

The new password is only valid after the "Change Password" button is pressed.

Change Password ← Change Security Password
Changes the password accordingly.

Security Setting
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Security Settings
Comprises the settings for enabling and disabling the USB and LAN interfaces. The
setting requires the entry of the security password and is only accepted after the
"Accept" button is pressed.

USB Device ← Security Settings
Enable/disable the USB interface.

Note: The instrument does not recognize any device connected to the USB interface
when the interface is disabled.

LAN Connection ← Security Settings
Enable/disable the LAN interface.

Note: It is not possible to access the instrument via LAN while the LAN connection is
disabled.
An enabled LAN connection is a prerequisite for the remote control of the instrument
via VNC, FTP or SAMBA.

Security Password ← Security Settings
Enters the password that is required to enable or to disable the settings protected by a
security password. The default is '123456'.

Note: It is highly recommended to change the default security password before con-
necting the instrument to the network. To change the security password, select
"SGMA-GUI > Instrument Name > Setup > Security > Change Security Password".
The settings are only accepted after the "Accept" button is pressed.

Accept ← Security Settings
Accept a new entry or selection and change the settings accordingly.

8.6 Maintenance

The R&S SGU provides a special dialog for performing some maintenance procedures,
like installing firmware packages.

► To access this dialog, select "SGMA-GUI > Instrument Name > Setup > Mainte-
nance".
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Operation
Selects the desired maintenance operation.

Select Package
Available only for "Operation > Install Firmware Package".

Selects the firmware package to be installed, see also Chapter 9.5, "How to Install a
New Firmware Version on the Instrument", on page 107.

Update All
Available only for "Operation > Install Firmware Package".

Enable this function to perform a simultaneous firmware update on all instruments, that
are in active state and are connected to this controller.

Note: A firmware update and the required subsequent restart and the automatically ini-
tiated internal adjustment process of the controller may be a time consuming operation.
This feature accelerates the update process and the required restart of the external PC
can be executed once after the update operation of all instruments is completed.

Security Password
Enters the password that is required to enable or to disable the settings protected by a
security password. The default is '123456'.

Note: It is highly recommended to change the default security password before con-
necting the instrument to the network. To change the security password, select
"SGMA-GUI > Instrument Name > Setup > Security > Change Security Password".
The settings are only accepted after the "Accept" button is pressed.

Accept
Accept the selected operation and perform the required procedure.

8.7 Network Settings

The instrument is equipped with a network interface and can be connected to an Ether-
net LAN (local area network). The "Network Settings" dialog provides access to the
network settings.
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Risk of network errors!
Connection errors can affect the entire network.
If your network does not support DHCP, or if you choose to disable dynamic TCP/IP
configuration, you must assign valid address information before connecting the instru-
ment to the LAN.
Contact your network administrator to obtain a valid IP address.

► To access this dialog, select "SGMA-GUI > Instrument Name > Setup > Network
Settings".

The dialog provides access to the network settings, like settings about the general net-
work environment and specific identification of the computer in the network. The dialog
also displays an indication whether the instrument is connected to the network or not.

Restart Network
Shuts down the network connection of the instrument and then re-establishes the con-
nection.

This function can be used to resolve network problems.

Note: Only the connection of the instrument to the network restarts, the network itself
is not affected.

Hostname
Displays the individual computer name of the instrument.

A predefined name is indicated and can be used for network connections, see Chap-
ter 6.4.3, "Finding Out the Default Hostname of the Instrument", on page 61.
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It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors may affect the entire network.

Remote command: 
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname on page 178

MAC Address
Indicates the MAC address of the network adapter.

Address Mode
Selects if the IP address is assigned automatically or manually.

It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors may affect the entire network.

Note: Lost LAN connection to an instrument.
If the connection to an instrument configured to use static IP addresses is lost, press
the LAN LED on the instrument front panel for 3 seconds.
This resets the "Address Mode" to its default value ("Auto (DHCP)").

"Auto (DHCP)" The IP address is assigned automatically.
The network used must support automatic assignment of IP address
via DHCP or APIPA (Zeroconf) to use this function.

"Static" The IP address is assigned manually.

Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress:MODE on page 177

IP Address
Displays the IP address. To enter the IP address manually, select "Address Mode >
Static".

In case of manual input of the IP address, it is recommended that a connection of the
instrument to the network is coordinated with the network administrator. Connection
errors may affect the entire network.

Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress on page 177

Subnet Mask
Displays the subnet mask. To enter the subnet mask manually, select "Address Mode
> Static".

This number is used together with the IP address to identify the network segment the
instrument is in.

It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors may affect the entire network.

Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK on page 178

Default Gateway
Displays the IP address of the default gateway. To enter the default gateway manually,
select "Address Mode > Static".
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This address identifies the router on the same network as the instrument that is used to
forward traffic to destinations beyond the local network.

It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors may affect the entire network.

Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway on page 178

Apply
Applies the network settings to the instrument.

8.8 Remote Channels

The "Remote" dialog provides access to the settings for remote control.

► To access this dialog, select "SGMA-GUI > Instrument Name > Setup > Remote".

Visa Resource Strings
Indicates the VISA resource strings used for remote control of the instrument. A sepa-
rate string is provided for remote control via the different interfaces.

Note: For background information and description of the syntax of the VISA resource
strings, refer to the description of the corresponding interface in Chapter 10.1, "Remote
Control Interfaces and Protocols", on page 110.

Remote command: 
:SYSTem:COMMunicate:HISLip:RESource? on page 179
:SYSTem:COMMunicate:NETWork:RESource? on page 178
:SYSTem:COMMunicate:SOCKet:RESource? on page 179
:SYSTem:COMMunicate:USB:RESource? on page 179
:SYSTem:COMMunicate:PCIexpress:RESource? on page 179
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Device Identity
Triggers the device identification function. The LAN LED on the front panel of the
selected instrument blinks.

See also Chapter 6.4.4, "Bidirectional Instrument Identification ", on page 61.

8.9 Factory Preset

The "Factory Preset" dialog provides a function to reset the instrument's settings to
their factory states

1. To access this dialog, select "SGMA-GUI > Instrument Name > Setup > Factory
Preset".

2. Select "Execute Factory Preset".

The instrument's settings are reset to their factory states. Security settings and
user data are not effected.

Execute Factory Preset
Reset the instrument's settings to their factory state.

Note: Because "Factory Preset" resets the "Remote Channel Settings" and "Network
Settings" to the default values, executing factory preset via remote control may termi-
nate the connection to the instrument, if these settings had been configured to values
different to the default ones!
The factory preset function resets nearly all instrument settings. In addition to the regu-
lar preset, a "Factory Preset" resets also the following values:
● Power on settings ("Level" dialog)
● Network settings including hostname ("Setup > Network Setting" dialog)
● Remote Channel settings ("Setup > Remote Channel" dialog)
● Eco Mode state ("Setup > Eco Mode" dialog)
To maintain security, password settings and all settings protected by these passwords
like disabled USB and LAN connections are not changed.

Not affected by the "Factory Preset" are also user data, lists or instrument settings
files, created for example with the "File Save As" function.

Remote command: 
:SYSTem:FPReset on page 141
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8.10 Eco Mode

This energy saving mode is available only for instruments equipped with
optionR&S SGU-B140/B140V.

► To access this dialog, select "SGMA-GUI > Instrument Name > Setup > Eco
Mode".

With enabled "Eco Mode 1" the doubler stage in a 40 GHz instrument is perma-
nently switched off to reduce power consumption and the maximum frequency is
limited to 20 GHZ. An enabled "Eco Mode" is indicated by a green coloring of the
frequency range in the R&S SGMA-GUI.

Risk of invalid adjustment after changing the Eco Mode
The switching off and on of the doubler stage changes the thermal conditions in the
instrument.
In order to achieve correct adjustment of the instrument, make sure that the instrument
is warm before performing adjustments. The warm-up time is 30 minutes.

The state of this parameter is not affected by an instrument "Preset". This parameter is
influenced only by the Factory Preset.

SCPI command:

8.11 Standby and Restart

See Chapter 9.3, "How to Switch Between the Operating States", on page 104.

8.12 Diagnostic and Tests

This section describes the settings provided for diagnostic and test purposes.
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8.12.1 Keyboard Tests

Access:

► Select "SGMA-GUI > Instrument Name > Diagnostic Tests > Keyboard Test".

Use this function to check the proper operation of all front panel elements.

If "Keyboard Test" is enabled, all front panel LEDs except the POWER ON are orange.

The exact test procedure is described in the service manual.

SCPI command:

:TEST:KEYBoard[:STATe] on page 183
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9 Performing Configuration Tasks
This section provides a general explanation on how to operate the instrument manually
via the R&S SGMA-GUI software.

We assume, that the R&S SGU is connected to a remote PC. The R&S SGMA-GUI
software has to be installed on this remote PC and the instrument has to be added to
the list of "Available Instruments".

For information on how to fulfill these requirements, refer to:
● Chapter 2.3.2.1, "Connecting the Instrument to the Network", on page 22
● Chapter 2.3.1, "Installing the R&S SGMA-GUI Software on an External PC",

on page 21
● Chapter 2.3.2.3, "Automatically Adding Instruments to the SGMA-GUI ",

on page 23

9.1 How to Generate I/Q Signals with an R&S SGS and an
R&S SGU Upconverter

Options R&S SGS-B112V and R&S SGU-B120V/-B140V are required for the I/Q mod-
ulation.

To generate an I/Q modulated signal with higher frequency

In this example, the R&S SGU acts as an extension to the R&S SGU extending its fre-
quency range to 40 GHz.

The Figure 9-1 shows an example of the test setup.
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Figure 9-1: Example of the test setup

For higher setting/ measuring speeds, use a PCIe switch and PCIe connections.

If a common reference frequency is required, use the internal reference signal of the
signal generator and provide it to the R&S SGU and the connected signal analyzer,
e.g. the R&S FSW.

1. Connect the test equipment as shown on Figure 9-1:

a) Connect the R&S SGS, the R&S SGU and the controller to a LAN switch.
b) Connect the I/Q OUT of the base band signal source to the I/Q IN of the R&S

SGU.
c) Connect the I/Q OUT of the R&S SGS to the I and Q connectors of the R&S

SGS.
d) Connect the RF OUT of the R&S SGS to the LO IN of the R&S SGU.
e) Connect the TRIG connectors of the R&S SGS and the R&S SGU.
f) Connect the RF OUT of the R&S SGU to the RF IN of the signal analyzer.

2. Select "SGMA-GUI main panel > R&S SGS > Extension".

Tip: Steps 3 to 5 can be omitted if the R&S SGS and a single R&S SGU are con-
nected using PCIe or USB or by a direct LAN connection because the SGS will
automatically activate the SGU.

3. Press the ID key on the front panel of the R&S SGU (only required if the compo-
nents are connected via a company network).

4. In the "Extension" dialog, trigger "Scan".
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The scan function finds out the connected R&S SGU.

5. Select the R&S SGU from the list and set "Available Instruments > Select > On" to
enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection to the extension.

6. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

The diagram displays the connection state of the tested connections.

7. Select "SGMA-GUI > R&S SGS > Freq = 20 GHz", "Lev = -30 dBm" and enable
"RF > State > On".

The extension adopts these values and states automatically. Generated is an I/Q
signal with RF = 20 GHz and Level = -30 dBm.

9.2 How to Restore the LAN Connection to an Instrument

► If the LAN connection to an instrument configured to use a static IP address is lost,
press the LAN LED on the instrument's front panel for more than 3 seconds to
reset the LAN settings and to set the "Address Mode" on page 96 to DHCP.
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Provided the network supports automatic assignment of IP address, new IP
address is automatically assigned to the instrument.

9.3 How to Switch Between the Operating States

The Figure 9-2 gives an overview of the operating states of the instruments and how to
trigger the switch-over between them.

Figure 9-2: Operating states

:RESTart, :STANdby = SCPI commands
"Setup > Standby", "Setup > Restart", "Shut Down Instru-
ments and Exit"

= R&S SGMA-GUI controls

POWER ON/STANDBY, POWER SWITCH ON/OFF = Hardkey controls on the front/rear panel of the
instrument

The Table 9-1 provides a short description of the operating states and their indication.
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Table 9-1: Indication of the operating states

Operating
state

Description Indication

Off The instrument is shut down. All LEDs on the front panel of the instrument
are off.

Booting The instrument boots the operating system
and starts the instrument firmware.

If the previous session was terminated reg-
ularly, the instrument uses the last setup
with the relevant instrument settings.

The green POWER ON /STAND BY key blinks.

Standby The standby power mode keeps the power
switch circuits and the remote control sys-
tem active.

In this state, it is safe to switch off the AC
power and disconnect the instrument from
the power supply.

In the R&S SGMA-GUI, the status indicator in
front of the instrument name is red.

The orange POWER ON /STAND BY key is
on.

Ready

(normal
operation)

The instrument is ready for operation. All
modules are power-supplied.

In the R&S SGMA-GUI, the status indicator in
front of the instrument name is green.

The green POWER ON /STAND BY key is on.

To switch the instrument to standby state

► Use one of the following:

a) On the remote PC, select "SGMA-GUI > Instrument Name > Setup > Standby".
b) Press the POWER ON/STANDBY key on the front panel of the instrument.
c) Send the SCPI command:

:STANdby.

The current instruments settings are automatically stored. The instrument switches
to a power saving mode.
In the R&S SGMA-GUI, the standby state is indicated by the red state symbol in
front of the corresponding instrument's name, on the front panel, by the orange
POWER ON/STANDBY button.
The instrument can still be remote controlled.

To return the instrument from standby to ready state

► Use one of the following:

a) On the remote PC, select "SGMA-GUI > Instrument Name > Setup > Restart".
b) Press the orange POWER ON/STANDBY key on the front panel of the instru-

ment.
c) Send the SCPI command:

:RESTart.

The instrument loads the last setup with all instrument settings, switches to ready
state and is ready for normal operation.
In the R&S SGMA-GUI, the ready state is indicated by the green state symbol in
front of the instrument's name.
On the front panel, the ready state is indicated by the green POWER ON /STAND
BY button.
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To switch all connected instruments to standby state and close the R&S SGMA-
GUI

► In the R&S SGMA-GUI main panel, select "File > Shut down instruments and exit".

The R&S SGMA-GUI quits and switches the connected instruments to standby
state.

For description on how to terminate work and shut down the instrument regularly, refer
to Chapter 2.1.5, "Switching the Instrument On and Off", on page 17.

9.4 How to Use Computer Names

Provided that there is a name server in the network, alternatively to the IP address
each PC or instrument connected in a LAN can be accessed via an unambiguous com-
puter name. Each instrument is delivered with an assigned computer name, but this
name can be changed.

For instruction on how to find out the default computer name, refer to Chapter 6.4.3,
"Finding Out the Default Hostname of the Instrument", on page 61.

To query and change a computer name

To avoid violations and to make use of the easy identification provided by the computer
name, it is recommended to keep the default hostname unchanged.

1. Open "SGMA-GUI > Instrument Name > Setup > Network Settings" dialog.

The computer name is displayed under "Hostname".

2. Select "SGMA-GUI > Instrument Name > Setup > Protection" and enable the "Pro-
tection Level 1".

The parameter "Hostname" in the "Network Settings" dialog is now enabled for
configuration.

3. Change the "Hostname".

4. Press the POWER ON /STAND BY key to restart the instrument.

Note: The "Factory Preset" function restores the factory value of the parameter
"Hostname".
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9.5 How to Install a New Firmware Version on the Instru-
ment

You can update the firmware of the R&S SGU .

Firmware Installation through the R&S SGMA-GUI

If an update to a new firmware version is required for both the R&S SGMA-GUI and the
instrument, it is mandatory that the new instrument's firmware is installed prior to the
update of the R&S SGMA-GUI to the new version.

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Maintenance > Oper-
ation > Install firmware package".

2. Press "Select Package" and navigate to the directory the new firmware is stored in.

3. If several instruments have to be updated to new firmware version, enable the fea-
ture "Update All " to accelerate the update process.

All instruments that are in active state and are connected to this controller are
updated simultaneously.

4. Enter the "Security Password".

5. Confirm the update with "Accept".

The software transfers the firmware file and automatically starts the update proce-
dure. During the update, the message "Updating Firmware" is displayed in the Info
line. The update process is indicated by an LED running light.

Note: The update procedure requires a restart of the instrument. The restart is per-
formed automatically. The instrument is not accessible during that time.

6. Wait until the message "Updating Firmware" disappears and the update is comple-
ted.

The green POWER ON /STAND BY LED is on.

7. If required, install the new R&S SGMA-GUI.
For detailed description, refer to Chapter 2.3.1, "Installing the R&S SGMA-GUI
Software on an External PC", on page 21

8. If the instrument and the controller/PC are connected over the PCIe interface and
the external PC does not support hot-plugging, it is required to restart the external
PC.
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Firmware Update through a Session Control Protocol (SCP)

If an update to a new firmware version is required for both the R&S SGMA-GUI and the
instrument, it is mandatory that the new instrument's firmware is installed prior to the
update of the R&S SGMA-GUI to the new version.

1. Connect the R&S SGU and a Windows PC to the same network.

2. On the PC, open a windows explorer window.

3. To connect to the R&S SGU enter the name of the instrument or its IP address in
the windows taskbar.

4. Enter the user name and password to connect to the R&S SGU. The default user
name is instrument and the password is instrument.

A folder opens, containing the share and the update folder.

5. Open the update folder and copy the new firmware update file in it.

The update starts automatically.

Unsuccessful or Erroneous Firmware Update
An erroneous or unsuccessful installation of firmware update package is indicated by a
combination of red and one orange LEDs on the front panel.
Refer to the service manual for a description of the displayed error code or contact the
customer support center.

9.6 How to Activate Options

A firmware update before the activation of the SW option may be required.
Refer to the description of the SW option for the required firmware version.
See also Chapter 9.5, "How to Install a New Firmware Version on the Instrument",
on page 107 for instruction on how to update the firmware version.

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Install SW-Options".

2. Select "Option Key" and enter the key code delivered with the new option.

The new option is now enabled and ready for operation.

 

How to Activate Options

ManualsPlus.com

https://www.manualsplus.com/


Performing Configuration TasksR&S®SGU100A

109User Manual 1176.7726.02 ─ 07

9.7 How to Manually Set a PCIe Direct Connection
Between an R&S SGS and an R&S SGU

To build a direct PCIe connection between an R&S SGU and an R&S SGS, which has
a "Controller > Revision" < 5, first you have to manually set the correct PCIe interface
mode. If your R&S SGS has a "Controller > Revision" 5 or higher, these settings are
done automatically.

You can check the "Controller > Revision" of your instrument in the "SGMA-GUI >
Instrument Name > Hardware Config" dialog.

To manually set a PCIe direct connection between an R&S SGS and an R&S SGU

1. Connect the R&S SGS and the R&S SGU directly using a PCIe cable. Refer to
Chapter 10.3.4, "Connecting the Controller and the Instrument", on page 124 for
cable requirements and setup information.

2. Switch on the R&S SGS and the R&S SGU.

3. Select "SGMA-GUI main panel > Instrument Name > Setup > Maintainance".

4. Select "Operation > PCIe Interface Mode".

5. Select "PCIe Interface Mode > Root Complex".

6. Restart your instrument for the changes to take place.

The PCIe connection between the R&S SGS and the R&S SGU is established and
the instruments can be used.
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10 Network and Remote Control Operation
As an alternative to operating the R&S SGU interactively via the R&S SGMA-GUI, one
can also control the R&S SGU using programmed commands from a remote PC.

The description in this section requires basic knowledge of the remote control opera-
tion. Definitions specified in the SCPI standard are not provided.
Nevertheless, you can find some basic information to the SCPI syntax, command lists,
and general programming recommendations in Chapter A, "Remote Control Basics",
on page 194. In addition, this chapter provides information on the status reporting sys-
tem of the instrument.

10.1 Remote Control Interfaces and Protocols

The instrument supports several interfaces for remote control. The following table gives
an overview.

Table 10-1: Remote control interfaces and protocols

Interface Protocols, VISA*) address string and Library Remarks

Local Area
Network
(LAN)

● HiSLIP High-Speed LAN Instrument Protocol
(IVI-6.1)
TCPIP::host address::hislip0[::
INSTR]

● VXI-11
TCPIP::host address::inst0[::INSTR]
Library: VISA

● socket communication (Raw Ethernet, simple
Telnet)
TCPIP::host address[::
LAN device name]::<port>::SOCKET
Library: VISA or socket controller

A LAN connector is located on the
rear panel of the instrument.

The interface is based on TCP/IP and
supports various protocols.

For details, see Chapter 10.1.2, "LAN
Interface", on page 113

USB USBTMC
USB::<vendor ID>::<product ID>::
<serial number>[::INSTR]
Library: VISA

A USB connector is located on the
rear panel of the instrument.

For details, see Chapter 10.1.3, "USB
Interface", on page 116

PCIe Proprietary
PCIe::<vendor ID>::<product ID>::
<serial number>[::INSTR]
Library: pcie controller

A PCIe connector is located on the
rear panel of the instrument.

For details, see Chapter 10.1.4, "PCI
Express Interface", on page 117

*) VISA is a standardized software interface library providing input and output functions
to communicate with instruments. A VISA installation on the controller is a prerequisite
for remote control over LAN (when using VXI-11 or HiSLIP protocol) or USB. However,
no VISA installation is necessary for remote control while using socket communication.
For more information about VISA, refer to the user documentation.
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Rohde & Schwarz provides the standardized I/O software library R&S VISA for com-
munication via TCP/IP (LAN: HiSLIP, VXI-11 and raw socket) or USB (USBTMC) inter-
faces.
R&S VISA is available for download at the Rohde & Schwarz website http://
www.rohde-schwarz.com/rsvisa.

SCPI (Standard Commands for Programmable Instruments)

SCPI commands are used for remote control. Commands that are not taken from the
SCPI standard follow the SCPI syntax rules. The instrument supports the SCPI version
1999. The SCPI standard is based on standard IEEE 488.2 and aims at the standardi-
zation of device-specific commands, error handling and the status registers. The tuto-
rial "Automatic Measurement Control - A tutorial on SCPI and IEEE 488.2" from John
M. Pieper (R&S order number 0002.3536.00) offers detailed information on concepts
and definitions of SCPI.

10.1.1 Remote Control Programs and Libraries

The Figure 10-1 provides a schematic illustration of the remote control capabilities of
the instrument.

Figure 10-1: Remote control interfaces, protocols and libraries

The following examples give an overview of the dependencies between the available
libraries, the possible interfaces and protocols, and whether an instrument driver is pro-
vided. The involved parts are highlighted.
● Remote control program using VISA
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Figure 10-2: Remote control program using VISA

Protocol Remote Control Program

Socket viOpen (..., "TCPIP:rssgu100a100010::5025::SOCKET", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

VXI-11 viOpen (..., "TCPIP:rssgu100a100010::inst0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

HiSLIP viOpen (..., "TCPIP:rssgu100a100010::hislip0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

USBTMC viOpen (..., "USB::0x0aad::0x00ce::1000010::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

● Remote control program using instrument driver (VISA available)

Figure 10-3: Remote control program using instrument driver (VISA available)
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Protocol Remote Control Program

Socket rssgu_init ("TCPIP:rssgu100a100010::5025::SOCKET", ...)
rssgu_SetFrequency (..., 2e9)

VXI-11 rssgu_init ("TCPIP:rssgu100a100010::inst0::INSTR", ...)
rssgu_SetFrequency (..., 2e9)

HiSLIP rssgu_init ("TCPIP:rssgu100a100010::hislip0::INSTR", ...)
rssgu_SetFrequency (..., 2e9)

USBTMC rssgu_init ("USB::0x0aad::0x00ce::1000010::INSTR", ...)
rssgu_SetFrequency (..., 2e9)

PCIe rssgu_init ("PCIe::0x162f::0x132e::1000010::INSTR", ...)
rssgu_SetFrequency (..., 2e9)

● Remote control program using instrument driver (VISA not available)

Figure 10-4: Remote control program using instrument driver (VISA not available)

Protocol Remote Control Program

Socket rssgu_init ("TCPIP:rssgu100a100010::5025::SOCKET", ...)
rssgu_SetFrequency (..., 2e9)

PCIe rssgu_init ("PCIe::0x162f::0x132e::1000010::INSTR", ...)
rssgu_SetFrequency (..., 2e9)

10.1.2 LAN Interface

To be integrated in a LAN, the instrument is equipped with a LAN interface, consisting
of a connector, a network interface card and protocols.

For remote control via a network, the PC and the instrument must be connected via the
LAN interface to a common network with TCP/IP network protocol. They are connected
using a RJ45 cable (shielded or unshielded twisted-pair category 5). The TCP/IP net-
work protocol and the associated network services are preconfigured on the instru-
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ment. Software for instrument control and (for specified protocols only) the VISA pro-
gram library must be installed on the controller.

Identifying instruments in a network
If several instruments are connected to the network, each instrument has its own IP
address and associated resource string. The controller identifies these instruments by
the resource string.

10.1.2.1 VISA Resource Strings

The VISA resource string is required to establish a communication session between
the controller and the instrument in a LAN. The resource string is a unique identifier,
composed of the specific IP address of the instrument and some network and VISA-
specific keywords.

TCPIP::host address[::LAN device name][::INSTR]
● TCPIP designates the network protocol used
● host address is the IP address or host name of the device

See also Chapter 6.4.3, "Finding Out the Default Hostname of the Instrument",
on page 61.

● [::LAN device name] defines the protocol and the instance number of a subinstru-
ment:

● [::INSTR] indicates the instrument resource class (optional)

The IP address (host address/computer name) is used by the programs to identify and
control the instrument. It is automatically assigned by the DHCP server the first time
the device is registered on the network. Alternatively, you can also assign its LAN
device name.

You can find the IP address in the "SGMA-GUI > Instrument Name > Setup > Remote"
dialog, and also adjust it manually, if necessary.

See below the characteristics of the VISA resource strings for the corresponding inter-
face protocols. The highlighted characters are crucial.

HiSLIP

TCPIP::host address::hislip0[::INSTR]
● hislip0 HiSLIP device name, designates that the interface protocol HiSLIP is used

(mandatory)

hislip0 is composed of [::HiSLIP device name[,HiSLIP port]] and must be assigned.

For details of the HiSLIP protocol, refer to Chapter 10.1.2.2, "HiSLIP Protocol",
on page 115.

VXI-11

TCPIP::host address[::inst0][::INSTR]
● [::inst0] LAN device name, indicates that the VXI-11 protocol is used (optional)

 

Remote Control Interfaces and Protocols

ManualsPlus.com

https://www.manualsplus.com/


Network and Remote Control OperationR&S®SGU100A

115User Manual 1176.7726.02 ─ 07

inst0 currently selects the VXI-11 protocol by default and can be omitted.

For details of the VXI-11 protocol, refer to .Chapter 10.1.2.3, "VXI-11 Protocol",
on page 116

Socket communication

TCPIP::host address::port::SOCKET
● port determines the used port number
● SOCKET indicates the raw network socket resource class

Socket communication requires the specification of the port (commonly referred to as
port number) and of "SOCKET" to complete the VISA resource string with the associ-
ated protocol used.

The registered port for socket communication is port 5025.

See also Chapter 10.1.2.4, "Socket Communication", on page 116.

Example: 
● Instrument has the IP address 10.113.11.91; the valid resource string using VXI-11

protocol is:
TCPIP::10.113.11.91::INSTR

● The DNS host name is rssgu100a100021; the valid resource string is:
TCPIP::rssgu100a100021::hislip0 (HiSLIP)
TCPIP::rssgu100a100021::inst0 (VXI-11)

● A raw socket connection can be established using:
TCPIP::10.113.11.91::5025::SOCKET

10.1.2.2 HiSLIP Protocol

The HiSLIP (High Speed LAN Instrument Protocol) is the successor protocol for
VXI-11 for TCP-based instruments specified by the IVI foundation. The protocol uses
two TCP sockets for a single connection - one for fast data transfer, the other for non-
sequential control commands (e.g. Device Clear or SRQ).

HiSLIP has the following characteristics:

● High performance as with raw socket network connections
● Compatible IEEE 488.2 support for Message Exchange Protocol, Device Clear,

Serial Poll, Remote/Local, Trigger, and Service Request
● Uses a single IANA registered port (4880), which simplifies the configuration of fire-

walls
● Supports simultaneous access of multiple users by providing versatile locking

mechanisms
● Usable for IPv6 or IPv4 networks
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Using VXI-11, each operation is blocked until a VXI-11 device handshake returns.
However, using HiSLIP, data is sent to the device using the "fire and forget" method
with immediate return. Thus, a successful return of a VISA operation such as
viWrite() does not guarantee that the instrument has finished or started the reques-
ted command, but is delivered to the TCP/IP buffers.

For more information see also the application note: 1MA208: Fast Remote Instrument
Control with HiSLIP.

10.1.2.3 VXI-11 Protocol

The VXI-11 standard is based on the ONC RPC (Open Network Computing Remote
Procedure Call) protocol which in turn relies on TCP/IP as the network/transport layer.
The TCP/IP network protocol and the associated network services are preconfigured.
TCP/IP ensures connection-oriented communication, where the order of the
exchanged messages is adhered to and interrupted links are identified. With this proto-
col, messages cannot be lost.

10.1.2.4 Socket Communication

An alternative way for remote control of the software is to establish a simple network
communication using sockets. The socket communication, also referred to as “Raw
Ethernet communication”, does not require a VISA installation on the remote controller
side.

The simplest way to establish socket communication is to use the built-in telnet pro-
gram. The telnet program is part of every operating system and supports communica-
tion with the software on a command-by-command basis.

Socket connections are established on a specially defined port. The socket address is
a combination of the IP address or the host name of the instrument and the number of
the port configured for remote-control. All instruments use port number 5025 for this
purpose. The port is configured for communication on a command-to-command basis
and for remote control from a program running on a connected PC.

10.1.3 USB Interface

For remote control via USB connection, the PC and the instrument must be connected
via the USB interface. A USB connection requires the VISA library to be installed. VISA
detects and configures the R&S instrument automatically when the USB connection is
established. You do not have to install a separate driver.

USB resource string

The syntax of the used USB resource string is:
USB::<vendor ID>::<product ID>::<serial number>[::INSTR], where:
● USB denotes the used interface
● <vendor ID> is the manufacturer ID for Rohde&Schwarz
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● <product ID> is the product identification of the R&S instrument
● <serial number> is the individual serial number on the rear of the instrument
● [::INSTR] indicates the instrument resource class (optional)

You can retrieve the USB resource string from the "SGMA-GUI > Instrument Name >
Setup > Remote" dialog.

Example: 
USB::0x0AAD::0x00ce::100021::INSTR
0x0AAD is the vendor ID for Rohde&Schwarz
0x00ce is the product ID for the R&S SGU
100021 is the serial number of the particular instrument

10.1.4 PCI Express Interface

A PCI Express (PCIe) connector is provided on the rear panel of the instrument.

Refer to Chapter 10.3, "Advanced Remote Control Using PCIe", on page 120 for a
description of how to set up a remote control connection via PCIe and the permitted
cables.

Via PCI Express some commands can be sent to the instrument with optimized speed
(memory-mapped remote control), e.g. frequency or level settings. This allows mini-
mum setup time.

PCIe resource string

The syntax of the used PCIe resource string is:
PCIe::<vendor ID>::<product ID>::<serial number>[::INSTR], where:
● PCIe denotes the used interface
● <vendor ID> is the manufacturer ID for Rohde&Schwarz
● <product ID> is the product identification of the R&S instrument
● <serial number> is the individual serial number on the rear of the instrument
● [::INSTR] indicates the instrument resource class (optional)

You can retrieve the PCIe resource string from the "SGMA-GUI > Instrument Name >
Setup > Remote" dialog.

Example: 
PCIe::0x162f::0x132e::100021::INSTR
0x162f is the vendor ID for Rohde&Schwarz
0x132e is the product ID for the R&S SGU
100021 is the serial number of the particular instrument
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10.2 Starting a Remote Control Session

The instrument and the controller have to be connected with a suitable cable and
switched on.

A remote control program must open a connection to the instrument, before it can send
commands to and receive device responses from the instrument.

Instrument address
To operate the instrument via remote control, it must be addressed using the defined
interface address.
See Chapter 10.1.2, "LAN Interface", on page 113, Chapter 10.1.3, "USB Interface",
on page 116 or Chapter 10.1.4, "PCI Express Interface", on page 117 for details.

The VISA resource strings are indicated in the "SGMA-GUI main panel > Instrument
name > Setup > Remote Channels" dialog.

10.2.1 How to Find the VISA Resource String

To find the VISA resource strings of your instrument:

► Select "SGMA-GUI main panel > Instrument name > Setup > Remote Channels".

The "Remote Channel Settings" dialog shows all specified resource strings of the
supported remote control interfaces.
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10.2.2 Example: Remote Control over LAN Using Socket Communication

This section provides an example on how to establish a remote control connection over
telnet protocol and a simple sockets-based program example that can be further devel-
oped (see also Chapter B, "Telnet program examples", on page 216).

Basic knowledge of programming and operation of the controller are assumed. A
description of the interface commands can be obtained from the relevant manuals.

Refer to the Getting Started manual for an example on how to set up remote control
connection over LAN using VXI-11 protocol.

To set up a Telnet connection

To control the software, only a telnet program is required. The telnet program is part of
every operating system.

1. To establish a Telnet connection with the R&S SGU, start the telnet program and
enter the socket address.
The socket address is a combination of the IP address or the host name of the
R&S SGU and the number of the port configured for remote-control via telnet.
Tip: The R&S SGU uses the port number 5025 for remote connection via Telnet.

The connection to the instrument is set up and remote-control commands can be
sent.

2. Even if the cursor is not visible on the screen, enter blind a remote-control com-
mand and confirm with Enter.
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10.3 Advanced Remote Control Using PCIe

The PCIe bus is a high-speed serial bus, composed of point-to-point serial links. A pair
of serial links, one transmitting and one receiving link, make up a lane.

Fast settings

The PCIe interface can be utilized not only to transfer text messages e.g. SCPI com-
mands but also to carry register based remote control messages. The latter mode is
called fast settings mode. The specially for this purpose provided instrument's driver is
mandatory for the instrument control with fast settings. This instrument driver contains
special functions for fast setup.

To use the advantage of the fast settings, the following prerequisites must be fulfilled:
● Using the PCIe interface is mandatory (see also Chapter 10.3.1, "Setting Up a

Remote Control Connection via PCIe", on page 120)
● The fast settings must be enabled with the function rssgu_useFastSettings

(see also Chapter 10.3.5, "Enabling Fast Settings", on page 124).

The instrument driver automatically uses the fast settings method whenever possible -
currently only for the parameters frequency, level, RF state, modulator state - and
sends SCPI messages in all other cases.

Remote control programs written for PCIe will, without modifications, also run if one of
the other control channels, LAN or USB is used.

10.3.1 Setting Up a Remote Control Connection via PCIe

To set up a remote control connection vie PCIe, perform the following steps:

1. Download the drivers, see 10.3.2.

2. Configure the controller, see 10.3.3
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3. Connect the controller and the instrument, see 10.3.4

4. Enable fast settings, see 10.3.5.

10.3.2 Download the Drivers

All required driver files are available for download on the product page at:

http://www.rohde-schwarz.com/product/SGU100A.html > "Downloads" > "Drivers"

Provided are the following files:
● LabWindows/CVI, Linux/OSX driver rssgu (InstrumentDriver)

C source code files which provide a functional application programming interface
(API) to R&S SGU instruments. Required if you want to control an instrument via
PCIe.

● Low-Level SGU drivers
Archive file that contains the following:
– KernelDriver

C source code files from which you can build a Linux kernel mode driver for the
R&S SGU PCIe remote control interface.

– SguDriverDemo
C source code module for a demo program using the instrument driver API.

– SharedLibraries-Dlls
Shared libraries (Dlls) for remote control channels Socket and PCIe. To be
used with the instrument driver.

● VXIplug&play x64/x86 driver rssgu
Download the required archive and extract the files on a remote PC.

10.3.3 Configuring the Controller

This section lists the steps necessary to configure a controller with Linux or Windows
operating system.

10.3.3.1 Building and Installing the Hardware Driver

The hardware driver defines the way to communicate with the instrument via PCIe
interface.

For Windows operating systems, the hardware driver is installed automatically together
with the installation of the R&S SGMA-GUI software.
See also section "Installation of R&S SGMA-GUI Software" in the getting started man-
ual.

For Linux operating system, the source code of the driver is included in the
Low-Level SGU drivers file.
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To build and install this driver, root authority is required.

1. Copy folder KernelDriver to your hdd

2. Go to directory host.

3. On the command line, enter make.

The driver sgshost.ko is automatically built.

4. Enter make install.

Device nodes sguX are created under the folder /dev (X from 0 to 31).
The module sguhost is loaded.

5. Enter lsmod to verify the module.

10.3.3.2 Making Shared Libraries Accessible

Two library files per operating system are included in SharedLibraries-Dlls file:
● For Linux operating system

libsocketcontroller.so and libpciecontroller.so
● For Windows operating system

SocketController.dll and PCIeController.dll
These libraries act as the dynamic link libraries for programs using the socket or PCIe
interface.

Linux operating system

► To make the libraries accessible, perform one of the following:

a) Append the environment variable LD_LIBRARY_PATH with the path of these
two files e.g. by changing the /etc/environment file.

b) Move these two files to /usr/lib or /lib directory.

Windows operating system

► To make the libraries accessible, perform one of the following:

a) Copy these two files to the folder of your executable.
b) Copy these two files to the WINDOWS\system32 folder.

10.3.3.3 Building a Program

The help file rssgu_vxi.chm shows all functions of the instrument which you can use
in your own remote control program.

An example file is provided ( SguDriverDemo.c), too.

Building the example program (Linux)

1. Copy folders InstrumentDriver and SguDriverDemo to your hard disk.
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2. Go to folder Build

3. On the command line, enter cmake ..

4. Enter make
Folder Build contains the executable SguDriverDemo.

Building the example program (Windows)

1. Copy folders InstrumentDriver and SguDriverDemo to your hard disk.

2. Open SguDriverDemo.vcproj with Visual Studio.

3. Build the program.

Running the example program

► On the command line, enter ./SguDriverDemo RESOURCESTRING [cmd].

Where
● RESOURCESTRING is the (VISA) resource string of your instrument, e.g.

TCPIP::ipaddress::5025::SOCKET or PCIE::0x162f::
0x132e::serialno::INSTR.
Where ipaddress is the IP address or hostname of your instrument and
serialno is its serial number.

● cmd is an optional command (see table).

The following table list the available commands.

Command Description

? Usage

q Quit

f value Set frequency

f? Query frequency

l value Set level

l? Query level

r value Set RF state (value = 0 | 1 | ON | OFF)

r? Query RF state

If you enter an additional optional command, SguDriverDemo executes it and
enters a loop waiting for further commands.

Example: 
TCPIP::10.111.11.44::5025::SOCKET ?
Lists the available commands.
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10.3.4 Connecting the Controller and the Instrument

A PCIe connector is provided on the rear panel of the instrument.

Risk of device failure
The R&S SGU is equipped with a single lane PCIe interface that supports hot plugging.
Do not connect an external PC to the PCIe connector of the instrument during opera-
tion if this external PC does not support hot-plugging!

Permitted PCIe cables
PCIe extension cables must fulfill the following requirements:
● Single lane connectors
● Max. cable length of 5 m.

For example: OSS-PCIe-CBL-x1 cable from One Stop Systems or 74576-000x cable
from Molex.

Connecting an external PC that does not support hot-plugging

1. Switch off the external PC and the instrument.
See also Chapter 2.1.5, "Switching the Instrument On and Off", on page 17.

2. Connect the instrument and the controller with the suitable cable.

3. Switch on the instrument.

4. Wait until the instrument has completed the booting (the "POWER" LED on the
instrument's front panel is constantly on).

5. Switch on the external PC.

Connecting an R&S SGS and an R&S SGU

If you use the R&S SGU as an upconverter to the R&S SGS, the R&S SGS acts as a
controller to the R&S SGU. For a description of how to connect the instruments refer to
Chapter 5.2, "Setups for Connecting an R&S SGS and an R&S SGU", on page 39.

10.3.5 Enabling Fast Settings

► To enable the special PCI express feature fast settings, enable the function
rssgu_UseFastSettings (ViSession instrumentHandle, ViBoolean
fastEnabled, ViBoolean asynchronousEnabled) included in the instru-
ment driver.

Settings for some parameters like level and frequency accelerate.
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To disable the fast settings, call the function rssgu_UseFastSettings with argu-
ment fastEnabled=false.

10.4 Advanced Remote Control Using Fast Socket

Fast settings

The socket interface can be utilized not only to transfer text messages e.g. SCPI com-
mands but also to carry register based remote control messages. The latter mode is
called fast settings mode. The fast socket communication is based on the Ethernet pro-
tocol which does not support routing. Therefore a controller PC can only control devi-
ces within its own network segment using the fast socket method.

To use the advantage of the fast settings, the following prerequisites must be fulfilled:
● On Windows operating systems, the fast socket driver must be installed.
● The application program must be run with root/administrator rights.
● The fast settings must be enabled with the function rssgu_useFastSettings

(see also Chapter 10.3.5, "Enabling Fast Settings", on page 124).

The instrument driver automatically uses the fast settings method whenever possible,
currently for the parameters frequency, level, RF state, I/Q modulator state, crest fac-
tor, host frequency, host level, apply settings. In all other cases, SCPI messages are
sent.

10.4.1 Setting Up a Remote Control Connection via Fast Socket

Download the required archive and extract the files on a remote PC, as described in
Chapter 10.3.2, "Download the Drivers", on page 121.

Windows operating systems

To set up a remote control connection via fast socket for Windows operating systems,
perform the following steps:

1. Connect the controller and the instrument, see Chapter 2.3.2, "Connecting a
Remote PC via LAN", on page 22.

2. Install the protocol driver to the controller, see Chapter 10.4.2, "Installing the Proto-
col Driver", on page 126.

3. On the controller start the driver by using one of the following:

a) Start the Windows console user interface as an administrator.
Excute the command net start SGMANDISPROT.

b) Use a program for opening the driver.
See for example the example file SguDriverDemo.c.
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4. Start the application with administrator rights.

5. Enable fast settings, see Chapter 10.4.3, "Enabling Fast Settings", on page 126.

Linux operating systems

To set up a remote control connection via fast socket for Linux operating systems, per-
form the following steps:

1. Connect the controller and the instrument, see Chapter 2.3.2, "Connecting a
Remote PC via LAN", on page 22.

2. Start the application as root.

3. Enable fast settings, see Chapter 10.4.3, "Enabling Fast Settings", on page 126.

10.4.2 Installing the Protocol Driver

The protocol driver defines the way to communicate with the instrument via the LAN
fast socket interface.

For Linux operating system, no special driver is needed.

For Windows operating systems, the SGMANDISPROT driver is required. The protocol
driver is installed automatically together with the installation of the R&S SGMA-GUI
software. It is also provided in the Low-Level SGU drivers file.

To install the driver manually on a Windows operating system:

1. Open "Control Panel > Network and Sharing Center".

2. Select the network adapter on which you want to install the driver and click it.

The "Local Area Connection Status" dialog opens.

3. Click "Properties" to open the "Local Area Connection Properties" dialog.

4. Click "Install" to open the "Select Network Feature Type" dialog.

5. Select "Protocol" and select "Add".

6. In the "Select Network Protocol" dialog, select "Have Disk".
Navigate to the directory where the driver is saved and click "OK" to install the
driver.

10.4.3 Enabling Fast Settings

► To enable the fast settings for the fast socket, call function
rssgu_UseFastSettings (ViSession instrumentHandle, ViBoolean
fastEnabled, ViBoolean asynchronousEnabled) included in the instru-
ment driver.

Settings for some parameters like level and frequency accelerate.
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To disable the fast settings, call the function rssgu_UseFastSettings with argu-
ment fastEnabled=false.

10.5 Using the R&S SGMA-GUI to Monitor the Remote
Control Operation

The R&S SGMA-GUI can be used to monitor the behavior of one or more instruments
while they are remote controlled.

A typical configuration consists of one monitor, controller(s) and instrument(s), where
the monitor is the remote PC on which the R&S SGMA-GUI is installed and the control-
ler is the remote PC on which the application program runs.

Simultaneous control of an instrument from a controller and a monitor may lead to colli-
sions whenever both the controller and the monitor utilize the same remote channel.
These collisions are indicated by an error message in the Info line, e.g. "Query inter-
rupted" or "Resource locked". Simultaneous monitoring and control over the same
remote channel is only possible, if the used protocols support
viLock()/viUnlock() and the remote program use these functions.

The Table 10-2 shows whether a collision-free communication over a particular combi-
nation of remote channels is possible or not and if there are any restrictions.

Table 10-2: Cross-reference between used remote channels and collision-free communication

Monitor/

Controller

LAN
(VXI-11)

LAN (HiSLIP) USB LAN (Socket) PCIe

LAN (VXI-11) OK* OK OK OK OK

LAN (HiSLIP) OK OK OK OK OK

USB OK OK viLock/viUnlock OK OK

LAN (Socket) OK OK OK X OK

PCIe OK OK OK OK X

Where:
● OK: communication possible, no collisions

*) the R&S SGMA-GUI always uses the LAN device name instr1, see also Chap-
ter 10.1.2.3, "VXI-11 Protocol", on page 116.

● X: communication is not possible without collisions
● viLock/viUnlock: communication is only possible, if the remote control com-

mands are enclosed in a viLock () - viUnlock() pair.

The R&S SGMA-GUI uses the viLock()/viUnlock() functions.
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The figure below shows an example of configuration where the monitor and the con-
troller are two different computers, connected to the same instrument over two different
hardware interfaces.

Figure 10-5: Example of setup for remote control monitoring

Connecting and configuring the monitoring PCs

In the "Setup > Security > Security Settings" dialog, check the state of the LAN and
USB interfaces and enable them if necessary.

1. Connect the monitoring PC to the instrument.

Note: Choose the hardware interface considering the limitations described in
Table 10-2.

2. Configure the instrument in the R&S SGMA-GUI, see Chapter 6.4.2, "Handling
Instruments in the R&S SGMA-GUI", on page 58.

3. In the "SGMA-GUI > Setup > Instruments > Edit Instruments" dialog, disable
"Exclusive Access".

Note: The two functions "Exclusive Access" and monitoring are mutually exclusive.

4. Send remote control commands from the controller to the instrument, open the cor-
responding dialogs in the R&S SGMA-GUI and observe the status of the parame-
ters.
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11 Remote Control Commands
In the following, all remote-control commands will be presented in detail with their
parameters and the ranges of the numerical values.

Conventions used in SCPI Command Descriptions

Note the following conventions used in the remote command descriptions:
● Command usage

If not specified otherwise, commands can be used both for setting and for querying
parameters.
If a command can be used for setting or querying only, or if it initiates an event, the
usage is stated explicitly.

● Parameter usage
If not specified otherwise, a parameter can be used to set a value and it is the
result of a query.
Parameters required only for setting are indicated as Setting parameters.
Parameters required only to refine a query are indicated as Query parameters.
Parameters that are only returned as the result of a query are indicated as Return
values.

● Conformity
Commands that are taken from the SCPI standard are indicated as SCPI con-
firmed. All commands used by the R&S SGU follow the SCPI syntax rules.

● Asynchronous commands
A command which does not automatically finish executing before the next com-
mand starts executing (overlapping command) is indicated as an Asynchronous
command.

● Reset values (*RST)
Default parameter values that are used directly after resetting the instrument (*RST
command) are indicated as *RST values, if available.

● Default unit
This is the unit used for numeric values if no other unit is provided with the parame-
ter.

● Manual operation
If the result of a remote command can also be achieved in manual operation, a link
to the description is inserted.

11.1 Programming Examples

This chapter provides simple programming examples for the R&S SGU. The purpose
of the examples is to present all commands for a given task. In real applications, one
would rather reduce the examples to an appropriate subset of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
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as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (e.g. comments) start with two // characters.

At the beginning of most remote control programs, an instrument (p)reset is recom-
mended to set the R&S SGU to a defined state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

It is also recommended to lock the instrument for remote control from the selected con-
troller prior to further configuration. Use the LOCK command for this purpose.

11.1.1 Performing General Tasks for Instrument Setup

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset the instrument first
// ******************************************************************

*RST; *CLS
// :SYSTem:PRESet
// :RESTart
// :SYSTem:FPReset

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

:LOCK? 12345
// Lock the instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Launch diagnostic 
// ******************************************************************

:DIAGnostic:POINt:CATalog?
// Response: : D_TEMP_UP20,D_TEMP_CPU
:DIAGNostic:MEASure:POINt? 'D_TEMP_UP20'

// ******************************************************************
// Query the entries in the error queue
// ******************************************************************

SYSTem:SERRor?
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// Query static errors
// SYSTem:ERRor:CODE:NEXT?
// SYSTem:ERRor:COUNT?
// SYSTem:ERRor:NEXT?
// STATus:QUEue:NEXT?
// SYSTem:ERRor:CODE:ALL?
SYSTem:ERRor:ALL?
// Query error queue

// ******************************************************************
// Query system information
// ******************************************************************

:SYSTem:VERSion?
:SYSTem:OSYStem?

// ******************************************************************
// Activate eco mode
// ******************************************************************

:SYSTem:EMODe EM1

// ******************************************************************
// Unlock the instrument
// ******************************************************************

:UNL 12345

11.1.2 Generating an I/Q Modulated Signal

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established. An external analog signal is provided at the I and Q connectors of the
instrument.

// ******************************************************************
// Reset the instrument first
// ******************************************************************

*RST; *CLS

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

:LOCK? 12345
// Lock the instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
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// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Set RF frequency and level 
// ******************************************************************

:SOURce:FREQuency:CW 2 GHz
:SOURce:POWer:-10dBm
:SOURce:POWer:PEP?

// ******************************************************************
// Define and enable impairments
// Enable modulation
// ******************************************************************

:SOURce:IQ:STATe ON 
:SOURce:IQ:IMPairment:STATe ON

:SOURce:IQ:IMPairment:LEAKage:I -1
:SOURce:IQ:IMPairment:LEAKage:Q 1
:SOURce:IQ:IMPairment:IQRatio: 1
:SOURce:IQ:IMPairment:QUADrature:ANGLe 2
:SOURce:IQ:CREStfactor 0.05

// ******************************************************************
// Enable output of the generated signal at the RF connector
// ******************************************************************

:OUTPut:STATe ON
:OUTPut:STATe:PON UNCH

// ******************************************************************
// Query LO frequency and power values and set LO
// ******************************************************************

:LOSCillator:FREQuency?
:LOSCillator:POWer?

// Set frequency and power on the local oscillator as required

// ******************************************************************
// Switch on the signal
// ******************************************************************

:SETTings:APPLy

// ******************************************************************
// Unlock the instrument
// ******************************************************************
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:UNL 12345

11.1.3 Advanced Task for Optimizing Performance

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset the instrument first
// ******************************************************************

*RST; *CLS
// :SYSTem:PRESet
// :RESTart
// :SYSTem:FPReset

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

:LOCK? 12345
// Lock the instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Query the level that can be set without adjustments of the attenuator 
// ******************************************************************

:OUTPut:AFIXed:RANGe:LOWer?
:OUTPut:AFIXed:RANGe:UPPer?

// ******************************************************************
// Optimizing the quality characteristics of the RF signal
// ******************************************************************

:SOURce:POWer:LMODe LNOise
// optimize the signal to low noise ratio
:SOURce:POWer:SCHaracteristic AUTO
// ensure highest dynamic range
:SOURce:POWer:LEVel:IMMediate:AMPLitude -30dBm
:SOURce:POWer:LIMit:AMPLitude 30dBm

:OUTPut:STATe:PON UNCHanged

 

Programming Examples

ManualsPlus.com

https://www.manualsplus.com/


Remote Control CommandsR&S®SGU100A

134User Manual 1176.7726.02 ─ 07

// ******************************************************************
// Query local oscillator frequency and power values and set LO
// ******************************************************************

:LOSCillator:FREQuency?
:LOSCillator:POWer?

// Set frequency and power on the local oscillator as required

// ******************************************************************
// Switch on the signal
// ******************************************************************

:SETTings:APPLy

// ******************************************************************
// Unlock the instrument
// ******************************************************************

:UNL 12345

11.1.4 Adjusting Network and Remote Channel Settings

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset the instrument first
// ******************************************************************

*RST; *CLS

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

:LOCK? 12345
// Lock the instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Query the VISA resource strings
// ******************************************************************
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:SYSTem:COMMunicate:NETWork:RESource?
// Response: TCPIP::10.113.10.187::INSTR
:SYSTem:COMMunicate:SOCKet:RESource?
// Response: TCPIP:10.113.10.187::5025::SOCKET
:SYSTem:COMMunicate:USB:RESource?
// Response: USB::0x0AAD::0x00ce::100021::INSTR
:SYSTem:COMMunicate:PCIexpress:RESource?
// Response: PCIe::0x162f::0x132f::100002::INSTR

// ******************************************************************
// Query network settings
// ******************************************************************

:SYSTem:COMMunicate:NETWork:COMMon:HOSTname?
// Response: rssgu100a100002
:SYSTem:COMMunicate:NETWork:IPADdress:MODE?
// Response: AUTO
:SYSTem:COMMunicate:NETWork:IPADdress?
// Response: 10.113.10.187
:SYSTem:COMMunicate:NETWork:IPADdress:SUBNet:MASK?
// Response: 255.255.0.0
:SYSTem:COMMunicate:NETWork:IPADdress:GATeway?
// Response: 10.113.0.1

// ******************************************************************
// Unlock the instrument
// ******************************************************************

:UNL 12345

11.2 Common Commands

Common commands are described in the IEEE 488.2 (IEC 625-2) standard. These
commands have the same effect and are employed in the same way on different devi-
ces. The headers of these commands consist of "*" followed by three letters. Many
common commands are related to the Status Reporting System.

Available common commands:

*CLS.............................................................................................................................136
*ESE.............................................................................................................................136
*ESR?...........................................................................................................................136
*IDN?............................................................................................................................136
*IST?............................................................................................................................ 137
*OPC............................................................................................................................137
*OPT?...........................................................................................................................137
*PRE............................................................................................................................ 137
*PSC............................................................................................................................ 137
*RCL.............................................................................................................................138
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*RST.............................................................................................................................138
*SAV.............................................................................................................................138
*SRE............................................................................................................................ 138
*STB?...........................................................................................................................139
*TRG............................................................................................................................ 139
*WAI.............................................................................................................................139

*CLS

Clear status

Sets the status byte (STB), the standard event register (ESR) and the EVENt part of
the QUEStionable and the OPERation registers to zero. The command does not
alter the mask and transition parts of the registers. It clears the output buffer.

Usage: Setting only

*ESE <Value>

Event status enable

Sets the event status enable register to the specified value. The query returns the con-
tents of the event status enable register in decimal form.

Parameters:
<Value> Range: 0 to 255

*ESR?

Event status read

Returns the contents of the event status register in decimal form and subsequently
sets the register to zero.

Return values: 
<Contents> Range: 0  to  255

Usage: Query only

*IDN?

Identification

Returns the instrument identification.

Return values: 
<ID> "Rohde&Schwarz,<device type>,<serial number>,<firmware ver-

sion>"

Example: Rohde&Schwarz,SGU,
1407.6004k02/000000,3.1.17.1-03.01.158

Usage: Query only
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*IST?

Individual status query

Returns the contents of the IST flag in decimal form. The IST flag is the status bit
which is sent during a parallel poll.

Return values: 
<ISTflag> 0 | 1

Usage: Query only

*OPC

Operation complete

Sets bit 0 in the event status register when all preceding commands have been execu-
ted. This bit can be used to initiate a service request. The query form writes a "1" into
the output buffer as soon as all preceding commands have been executed. This is
used for command synchronization.

*OPT?

Option identification query

Queries the options included in the instrument. For a list of all available options and
their description refer to the data sheet.

Return values: 
<Options> The query returns a list of options. The options are returned at

fixed positions in a comma-separated string. A zero is returned
for options that are not installed.

Usage: Query only

*PRE <Value>

Parallel poll register enable

Sets parallel poll enable register to the indicated value. The query returns the contents
of the parallel poll enable register in decimal form.

Parameters:
<Value> Range: 0  to  255

*PSC <Action>

Power on status clear

Determines whether the contents of the ENABle registers are preserved or reset when
the instrument is switched on. Thus a service request can be triggered when the instru-
ment is switched on, if the status registers ESE and SRE are suitably configured. The
query reads out the contents of the "power-on-status-clear" flag.
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Parameters:
<Action> 0 | 1

0
The contents of the status registers are preserved.
1
Resets the status registers.

*RCL <Number>

Recall

Loads the instrument settings from an intermediate memory identified by the specified
number. The instrument settings can be stored to this memory using the command
*SAV with the associated number.

It also activates the instrument settings which are stored in a file and loaded using the
MMEMory:LOAD <number>, <file_name.extension> command.

*RST

Reset

Sets the instrument to a defined default status. The default settings are indicated in the
description of commands.

The command is equivalent to SYSTem:PRESet.

Usage: Setting only

*SAV <Number>

Save

Stores the current instrument settings under the specified number in an intermediate
memory. The settings can be recalled using the command *RCL with the associated
number.

To transfer the stored instrument settings in a file, use the command :MMEMory:
STORe:STATe.

*SRE <Contents>

Service request enable

Sets the service request enable register to the indicated value. This command deter-
mines under which conditions a service request is triggered.

Parameters:
<Contents> Contents of the service request enable register in decimal form.

Bit 6 (MSS mask bit) is always 0.
Range: 0  to  255
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*STB?

Status byte query

Reads the contents of the status byte in decimal form.

Usage: Query only

*TRG

Trigger

Triggers all actions waiting for a trigger event. In particular, *TRG generates a manual
trigger signal. This common command complements the commands of the TRIGger
subsystem.

Usage: Event

*WAI

Wait to continue

Prevents servicing of the subsequent commands until all preceding commands have
been executed and all signals have settled (see also command synchronization and
*OPC).

Usage: Event

11.3 General Commands

:REMote:OPMode..........................................................................................................139
:RESTart.......................................................................................................................140
:STANdby..................................................................................................................... 140
:LOCK?.........................................................................................................................140
:UNLock........................................................................................................................140

:REMote:OPMode <OpMode>

Sets the remote operation mode of the instrument.

Parameters:
<OpMode> STDalone | EXTension

STDalone
The instrument acts standalone.
EXTension
The instrument is controlled by another Rohde&Schwarz instru-
ment. This parameter is used by the SGMA-GUI to disable set-
tings when the instrument is in extension mode.
*RST: STDalone
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:RESTart

Restarts the instrument.

Usage: Event

:STANdby

Switches the instrument to the standby state. To return the instrument into the ready
state, send the SCPI command :RESTart.

Usage: Event

:LOCK? <Lock Request Id>

Sends a lock request ID which uniquely identifies the controller of the instrument.

Parameters:
<Lock Request Id> Number

0
test query to check whether the instrument is locked
Controller ID
request lock from the controller with the specified Controller ID

Return values: 
<Value> Number

0
request refused; the instrument is already locked to another
<Lock Request Id>, i.e. to another controller
1
request granted

Example: :LOCK? 12345
Response: 1
:UNL 12345

Usage: Query only

Manual operation: See "Exclusive Access" on page 51

:UNLock <Unlock Id>

Unlocks an instrument locked to a controller with Controller ID = <Unlock Id>.

Setting parameters: 
<Unlock Id> Number

Unlock ID which uniquely identifies the controller of the instru-
ment. The value must match the Controller ID <Lock Request
Id> set with the command :LOCK?.

Usage: Setting only
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Manual operation: See "Exclusive Access" on page 51

11.4 Preset Commands

The following preset actions are available:
● Activation of the default state of all internal instrument functions (*RST

on page 138). Functions that concern the integration of the instrument into a mea-
surement setup are not changed, e.g. TCP/IP address or remote operating mode.

● Activation of the original state of delivery (factory reset, :SYSTem:FPReset
on page 141). Only functions that are protected by a password remain unchanged
as well as the passwords themselves.

:SOURce<hw>:PRESet
:SYSTem:PRESet
Triggers an instrument reset. It has the same effect as:
● The *RST command
● The "SGMA-GUI > Instrument Name > Preset" function

For an overview of the settings affected by the preset function, see Chapter 7.7, "Pre-
set", on page 84.

Example: SYST:PRES
All instrument settings (also the settings that are not currently
active) are reset to their default values.

Usage: Setting only

:SYSTem:FPReset

The command triggers an instrument reset to the original state of delivery.Only func-
tions that are protected by a password remain unchanged.

The factory preset function resets nearly all instrument settings. In addition to the regu-
lar preset a "Factory Preset" resets also the following values:
● Power on settings ("Level" dialog)
● Network settings including hostname ("Setup > Network Setting" dialog)
● Remote Channel settings ("Setup > Remote Channel" dialog)

For an overview of the settings affected by the factory preset function, see Chapter 8.9,
"Factory Preset", on page 98.

Example: SYST:FPR
all instrument settings (also those that are not currently active)
are reset to the factory values.

Usage: Event

Manual operation: See "Execute Factory Preset" on page 98
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11.5 CALibration Subsystem

The CALibration system contains the commands needed for calibrating the R&S SGU.

R&S SGU cannot be calibrated on its own. Therefore a connection with a signal gener-
ator (local oscillator (LO)) is needed. If you use a compatible R&S signal generator,
then the calibration process will be completed automatically after starting the calibra-
tion process. Otherwise you have to follow the steps described in "Calibration process
of the R&S SGU" on page 142. We assume that a remote PC is connected to the
instruments, the remote PC and the instruments are switched on and a connection
between them is established.

The selftest of an R&S SGU also requires a similiar instrumental setup. You can per-
form the selftest and read its results using the commands :TEST:ALL:STARt and :
TEST:ALL:RESult?.

Calibration process of the R&S SGU

Figure 11-1: Calibration process of the R&S SGU. No physical connections between the instruments
are shown in this graphic.

In order to complete the calibration process you have to complete the following steps:

1. Start an adjustment request with the SCPI command :CALibration:xxx:
STARt, where xxx stands for IQModulator, IQModulator:LOCal or LEVel.

2. :CALibration:HREQuest?
a) Query R&S SGU for the required LO settings with the SCPI command :

CALibration:HREQuest?.
b) Interpret the response of the query. The response is returned in the form of a

SCPI command. For example a response :SOUR:POW 6 asks for a power of 6
dBm.
For a list of all possible responses see :CALibration:HREQuest?
on page 144.
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3. Set the LO according to the required settings.

4. Repeat steps 2 and 3 until the value of step 2b is :CALibration:HREQ:STOP.

5. :CALibration:xxx:RESult?
xxx stands for IQModulator, IQModulator:LOCal or LEVel
a) Query the result of the adjustment request with the SCPI com-

mand :CALibration:xxx:RESult?.
b) The query returns either 0 or 1 signifying pass or fail.

The instrument is calibrated and can be further used.

How the described process may take place is shown in Table 11-1. If you use a com-
patible R&S signal generator the whole process will be completed automatically.

Table 11-1: Programming example of a calibration process

Local Oscillator/ Controller R&S SGU Response Interpretation

1):CALibration:LEVel:
STARt

- R&S SGU starts the Level Adjustment.

2):CALibration:HREQuest? :PROG:CREate Level
Adjustment

To do: create a progress bar with a caption
"Level Adjustment".

3):CALibration:HREQuest? :OUTP:STATe 1 To do: activate the RF output of the LO.

4):CALibration:HREQuest? :PROG:UPDate 5 The progress of the level adjustment is 5
%.

5):CALibration:HREQuest? :SOUR:FREQ 15e9;

:SOUR:POW -10.0
To do: set the frequency of the LO to
15GHZ and its level to -10dBm

6):CALibration:HREQuest? :SOUR:POW 5 To do: set the level of the LO to 5dBm.

7):CALibration:HREQuest? :PROG:UPDate 20 The progress of the level adjustment is 20
%.

8):CALibration:HREQuest? :SOUR:POW 20 To do: set the level of the LO to 5dBm.

9):CALibration:HREQuest? :PROG:UPDate 100 The progress of the level adjustment is 100
%.

10):CALibration:HREQuest? :PROG:REMove To do: delete the progress bar.

11):CALibration:HREQuest? :OUTP:STATe 0 To do: deactivate the RF output of the LO.

12):CALibration:HREQuest? :CAL:HREQ:STOP End of the calibration process.

:CALibration:HREQuest?................................................................................................ 144
:CALibration:IQModulator:STARt..................................................................................... 144
:CALibration:IQModulator:RESult?...................................................................................145
:CALibration:IQModulator:TEMPerature?..........................................................................145
:CALibration:IQModulator:LOCal:STARt........................................................................... 145
:CALibration:IQModulator:LOCal:RESult?.........................................................................145
:CALibration:LEVel:STARt.............................................................................................. 145
:CALibration:LEVel:RESult?............................................................................................ 146
:CALibration:LEVel:TEMPerature?...................................................................................146
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:CALibration:HREQuest?

Queries the settings required from the instrument during a calibration or a selftest.

See "Calibration process of the R&S SGU" on page 142 for a step by step description
of the calibration process.

Return values: 
<Command> string

All of the commands described below return the values in the
parameter's default unit.
:VERsion <Number>
Shows the command set version with which the instrument is
compliant
:OUTP:STATe <Number>
Shows the state required of the local oscillator
:SOUR:FREQ <Number>
Shows the frequency required of the local oscillator
:SOUR:POW<Number>
Shows the power required of the external local oscillator
:PROG:CREate <Text>
Asks the controller to create a progress bar
:PROG:REName <Text>
Asks the controller to rename the progress bar
:PROG:REMove
Asks the controller to delete the most recently created progress
bar
:PROG:UPDate <Number>
Shows the current progress value in percent
:NOP/:NO DATA
Intermediate message. No action is required
:CAL:HREQ:STOP
End of the calibration procedure

Example: See Table 11-1.

Usage: Query only

:CALibration:IQModulator:STARt

Starts an internal I/Q adjustment. Query the result of the adjustment with the SCPI
command :CALibration:IQModulator:RESult?.

See "Calibration process of the R&S SGU" on page 142 for a step by step description
of the calibration process.

Usage: Event
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:CALibration:IQModulator:RESult?

Queries the result of the internal I/Q adjustment. Start the adjustment with the SCPI
command :CALibration:IQModulator:STARt.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

Usage: Query only

:CALibration:IQModulator:TEMPerature?

Queries the delta temperature since the last adjustment of the IQ modulator.

Return values: 
<Temperature> string

Usage: Query only

:CALibration:IQModulator:LOCal:STARt

Starts an adjustment for the I/Q modulator of the current frequency. The I/Q modulator
is adjusted with respect to carrier leakage, I/Q imbalance and quadrature. Query the
result of the adjustment with the SCPI command :CALibration:IQModulator:
LOCal:RESult?.

See "Calibration process of the R&S SGU" on page 142 for a step by step description
of the calibration process.

Usage: Event

:CALibration:IQModulator:LOCal:RESult?

Queries the result of the I/Q modulation adjustment for the current frequency. Start the
adjustment with the SCPI command :CALibration:IQModulator:LOCal:STARt
on page 145.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

Usage: Query only

:CALibration:LEVel:STARt

Starts an internal level adjustment. Query the result of the adjustment with the SCPI
command :CALibration:LEVel:RESult?.

See "Calibration process of the R&S SGU" on page 142 for a step by step description
of the calibration process.

Usage: Event
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:CALibration:LEVel:RESult?

Queries the result of the internal level adjustment. Start the adjustment with the SCPI
command :CALibration:LEVel:STARt.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

Usage: Query only

:CALibration:LEVel:TEMPerature?

Queries the delta temperature since the last level adjustment.

Return values: 
<Temperature> string

Usage: Query only

11.6 CONNector Subsystem

:CONNector:TRIGger:OMODe.........................................................................................146

:CONNector:TRIGger:OMODe <Mode>

Sets the operating mode of the trigger connector.

Parameters:
<Mode> SVALid | SNValid | PEMSource

SVALid|SNValid
signal valid /not valid
PEMSource
external pulse modulator source

Manual operation: See "Trigger Connector Mode" on page 82

11.7 DIAGnostic Subsystem

:DIAGnostic:POINt:CATalog?..........................................................................................146
:DIAGnostic[:MEASure]:POINt?.......................................................................................147

:DIAGnostic:POINt:CATalog?

Queries the test points available in the instrument.

For description of the test points, see the service manual.

Example: See Chapter 11.1.1, "Performing General Tasks for Instrument
Setup", on page 130.
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Usage: Query only

:DIAGnostic[:MEASure]:POINt? <Name>

Triggers a voltage or a temperature measurement at the specified test point and
returns the measured value.

Use the command :DIAGnostic:POINt:CATalog? to retrieve a list of the available
test points.

For description of the test points, see the service manual.

Query parameters: 
<Name> string

Return values: 
<Value> number

Default unit: V or °C

Example: See Chapter 11.1.1, "Performing General Tasks for Instrument
Setup", on page 130.

Usage: Query only

11.8 Fast Speed Commands

This section describes special commands that allow a fast frequency and level setting.

:FFASt.......................................................................................................................... 147
:PFASt..........................................................................................................................147

:FFASt <Freq>

Special command to set the RF output frequency with minimum latency. No unit (e.g.
Hz) allowed.

Bypasses the status system so command *OPC? cannot be appended.

Parameters:
<Freq> float

Example: FFASt 12750000000

:PFASt <Pow>

Special command to set the RF output level with minimum latency at the RF output
connector. This value does not consider a specified offset. No unit (e.g. dBm) allowed.

Bypasses the status system so command *OPC? cannot be appended.

Parameters:
<Pow> float
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Example: :PFASt -20

11.9 FORMat Subsystem

The FORMat subsystem contains the commands which determine the format of the
data that the R&S SGU returns to the controller. This affects all query commands
which return a list of numerical data or block data. Reference is made to this in the
descriptions of the commands.

:FORMat:BORDer..........................................................................................................148
:FORMat[:DATA]............................................................................................................148
:FORMat:SREGister.......................................................................................................149

:FORMat:BORDer <Border>

Determines the sequence of bytes within a binary block. This only affects blocks which
use the IEEE754 format internally.

Parameters:
<Border> NORMal | SWAPped

NORMal
The instrument expects (with setting commands) and sends
(with queries) the least significant byte of each IEEE754 floating-
point number first and the most significant byte last.
SWAPped
The instrument expects (with setting commands) and sends
(with queries) the most significant byte of each IEEE754 floating-
point number first and the least significant byte last.
*RST: NORMal

Example: FORM:BORD SWAP
The data is transferred with the most significant bit first.

:FORMat[:DATA] <Data>

Determines the data format which the R&S SGU uses to return data. When data is
transferred from the control computer to the instrument, the instrument detects the data
format automatically. In this case, the value set here is irrelevant.
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Parameters:
<Data> ASCii | PACKed

ASCii
Numerical data is transferred as plain text separated by com-
mas.
PACKed
Numerical data is transferred as binary block data. The format
within the binary data depends on the command. The various
binary data formats are explained in the description of the
parameter types.
*RST: ASCii

Example: FORM ASC
The data is transferred as ASCII data.

:FORMat:SREGister <Format>

Determines the numerical format which is returned when the status registers are quer-
ied.

Parameters:
<Format> ASCii | BINary | HEXadecimal | OCTal

ASCii
The register content is returned as a decimal number.
BINary
The register content is returned as a binary number. #B is
placed in front of the number.
HEXadecimal
The register content is returned as a hexadecimal number. #H is
placed in front of the number.
OCTal
The register content is returned as an octal number. #Q is
placed in front of the number.
*RST: ASCii

Example: FORM:SREG HEX
The register content is returned as a hexadecimal number.

11.10 MMEMory Subsystem

The MMEMory subsystem (Mass Memory) contains the commands for managing files
and directories as well as for loading and storing complete instrument settings in files.

The files are stored on the internal flash memory of the instrument or on external USB
memory devices.

The default directory is determined using the command MMEMory:CDIR.
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Use the command :SYSTem:MMEMory:PATH:USER? to query the path of the direc-
tory for user-defined data.

The /opt directory is a protected and therefore a not accessible system directory. The
files on this directory contain data that must not be changed. Therefore, this directory
should not be accessed, since reconstruction of the system partition will lead to data
loss.

11.10.1 File Naming Conventions

To enable files in different file systems to be used, the following file naming conven-
tions should be observed.

The file name can be of any length and is case-sensitive, meaning it is distinguished
between uppercase and lowercase letters.

The file and the optional file extension are separated by a dot. All letters and numbers
are permitted (numbers are, however, not permitted at the beginning of the file name).
If possible, special characters should not be used. The use of the slashes "\" and "/"
should be avoided since they are used in file paths. A number of names are reserved
for the operating system, e.g. CLOCK$, CON, AUX, COM1...COM4, LPT1...LPT3, NUL
and PRN.

In the R&S SGU all files in which lists and settings are stored are given a characteristic
extension. The extension is separated from the actual file name by a dot (see Chap-
ter 11.10.2, "Extensions for User Files", on page 151 for an overview of the file types).

The two characters "*" and "?" function as "wildcards", meaning they are used for
selecting several files. The "?" character represents exactly one character, while the "*"
character represents all characters up to the end of the file name. "*.*" therefore stands
for all files in a directory.

When used in conjunction with the commands, the parameter <file_name> is speci-
fied as a string parameter with quotation marks. It can contain either the complete path
including the drive, only the path and the file name, or only the file name. The file name
must include the file extension. The same applies for the parameters
<directory_name> and <path>.

Depending on how much information is provided, either the values specified in the
parameter or the values specified with the command MMEM:CDIR (default directory)
are used for the path and the drive settings in the commands.

Before the instrument settings can be stored in a file, they have to be stored in an inter-
mediate memory using common command *SAV <number>. The specified number is
subsequently used in the :MMEMory:STORe:STATe on page 157 command. Also,
subsequently to loading a file with instrument settings with command :MMEMory:
LOAD:STATe on page 156, these settings have to be activated with the common com-
mand *RCL <number>.
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11.10.2 Extensions for User Files

The following table lists all available file extensions for user files.

Table 11-2: Automatically assigned file extensions in the instrument

Function Contents File suffix

R&S SGMA-GUI Save As/Open Software settings *.savrcl

11.10.3 Examples

In these examples, the current instrument setting is stored in the file
test.savrcltxt in the directory /var/user/..

Storing and Loading Current Settings

1. Store the current setting in an intermediate memory with the number 4. This setting
can be called using command *RCL and the associated number of the memory, for
example *RCL 4.
*SAV 4

2. To store the settings in a file in a specific directory, specify the complete path.
MMEM:STOR:STAT 4,"/var/user/test.savrcltxt"

3. To store the settings in a file in the default drive, set the default drive and specify
only the file name.
MMEM:CDIR '/var/user/'*SAV 4
MMEM:STOR:STAT 4,"test.savrcltxt"

4. Load the file test.savrcltxt in the user directory.
MMEM:LOAD:STAT 4,'/var/user/test.savrcltxt'

5. Activate the instrument setting of the file test.savrcltxt.
*RCL 4

Working with Files and Directories

1. Read out all files in the specified directory.
MMEM:CAT? '/usb/user'
Response: 127145265,175325184,"test,DIR,0","temp,DIR,0",
"readme.txt,ASC,1324","state.savrcltxt,STAT,5327",
"waveform.wv,BIN,2342"
the directory /usb/user contains the subdirectories test and temp as well as
the files readme.txt, state.savrcltxt and waveform.wv which have differ-
ent file types.

Tip: To query only the subdirectories of the current or specified directory, perform:
MMEM:DCAT? '/usb/user'
Response: 'test', 'temp'
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To query only the number of subdirectories in the current or specified directory,
perform:
MMEM:DCAT:LENG? '/usb/user'
Response: 2

2. To query the number of files in the current or specified directory, perform:
MMEM:CAT:LENG? '/usb/user'
Response: 3

3. Create a new subdirectory for mass memory storage in the specified directory.
MMEM:MDIR '/usb/new'

4. Copy the file state to a new file.
MMEM:COPY '/var/user/state.savrcltxt','/usb/new'

5. Rename the file state.
MMEM:MOVE 'state.savrcltxt','state_new.savrcltxt'

6. Remove the test directory.
MMEM:RDIR 'usbtest'

11.10.4 Remote Control Commands

:MMEMory:CATalog?..................................................................................................... 152
:MMEMory:CATalog:LENGth?.........................................................................................153
:MMEMory:CDIRectory...................................................................................................153
:MMEMory:COPY...........................................................................................................154
:MMEMory:DATA........................................................................................................... 154
:MMEMory:DCATalog?...................................................................................................155
:MMEMory:DCATalog:LENGth?.......................................................................................155
:MMEMory:DELete.........................................................................................................155
:MEMory:HFRee?.......................................................................................................... 156
:MMEMory:LOAD:STATe................................................................................................156
:MMEMory:MDIRectory...................................................................................................156
:MMEMory:MOVE.......................................................................................................... 157
:MMEMory:MSIS............................................................................................................157
:MMEMory:RDIRectory...................................................................................................157
:MMEMory:STORe:STATe..............................................................................................157

:MMEMory:CATalog? <path>

Returns the content of a particular directory.

Query parameters: 
<path> string

String parameter to specify the directory.
If you leave out the path, the command returns the contents of
the directory selected with :MMEMory:CDIRectory.
The path may be relative or absolute.
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Return values: 
<UsedDiskSpace> Byte size of all files in the directory.

<FreeDiskSpace> Remaining disk space in bytes.

<FileInfo> <NameFileN>,<SuffixFileN>,<SizeFileN>
List of files, separated by commas
<NameFileN>
Name of the file.
<SuffixFileN>
Type of the file. Possible suffixes are: ASCii, BINary, DIRectory
<SizeFileN>
Size of the file in bytes.

Example: See "Working with Files and Directories" on page 151.

Usage: Query only

:MMEMory:CATalog:LENGth? <Path>

Returns the number of files in the current or in the specified directory.

Query parameters: 
<Path> string

String parameter to specify the directory. If the directory is omit-
ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<FileCount> integer

Number of files.

Example: See "Working with Files and Directories" on page 151.

Usage: Query only

:MMEMory:CDIRectory <Directory>

Changes the default directory for mass memory storage. The directory is used for all
subsequent MMEM commands if no path is specified with them.

Parameters:
<Directory> <directory_name>

String containing the path to another directory. The path can be
relative or absolute.
To change to a higher directory, use two dots '..' .

Example: See "Working with Files and Directories" on page 151.

Usage: SCPI confirmed
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:MMEMory:COPY <SourceFile>[,<DestinationFile>]

Copies an existing file to a new file. Instead of just a file, this command can also be
used to copy a complete directory together with all its files.

Setting parameters: 
<SourceFile> string

String containing the path and file name of the source file

<DestinationFile> string
String containing the path and name of the target file. The path
can be relative or absolute.
If <DestinationFile> is not specified, the <SourceFile> is
copied to the current directory, queried with the :MMEMory:
CDIRectory command.
Note: Existing files with the same name in the destination direc-
tory are overwritten without an error message.

Example: See "Working with Files and Directories" on page 151.

Usage: Setting only
SCPI confirmed

:MMEMory:DATA <Filename>, <BinaryBlock>
:MMEMory:DATA? <Filename>

The setting command writes the block data <BinaryBlock> to the file identified by
<Filename>.

Tip: Use this command to read/transfer stored instrument settings or waveforms
directly from/to the instrument.

Parameters:
<BinaryBlock> #<number><length_entry><data>

#: Hash sign; always comes first in the binary block
<number>: the first digit indicates how many digits the subse-
quent length entry has
<length_entry>: indicates the number of subsequent bytes
<data>: binary block data for the specified length.
For files with a size with more than nine digits (gigabytes), the
instrument allows the syntax #(<Length>), where <Length>
is the file size in decimal format.

Parameters for setting and query: 
<Filename> string

String parameter to specify the name of the file.
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Example: MMEMory:DATA '/var/user/test.txt',#15hallo
Writes the block data to the file test.txt.
The digit 1 indicates a length entry of one digit; the digit 5 indi-
cate a length of the binary data (hallo) in bytes.
MMEMory:DATA? '/var/user/test.txt'
Sends the data of the file test.txt from the instrument to the
controller in the form of a binary block.
Response: #15hallo

Usage: SCPI confirmed

:MMEMory:DCATalog? <path>

Returns the subdirectories of a particular directory.

Query parameters: 
<path> String parameter to specify the directory. If the directory is omit-

ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<Catalog> <file_entry>

Names of the subdirectories separated by colons. The first two
strings are related to the parent directory.

Example: See "Working with Files and Directories" on page 151.

Usage: Query only

:MMEMory:DCATalog:LENGth? [<Path>]

Returns the number of subdirectories in the current or specified directory.

Query parameters: 
<Path> String parameter to specify the directory. If the directory is omit-

ted, the command queries the contents of the current directory,
to be queried with :MMEMory:CDIRectory command.

Return values: 
<DirectoryCount> integer

Number of parent and subdirectories.

Example: See "Working with Files and Directories" on page 151.

Usage: Query only

:MMEMory:DELete <Filename>

Removes a file from the specified directory.
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Setting parameters: 
<Filename> string

String parameter to specify the name and directory of the file to
be removed.

Example: See "Working with Files and Directories" on page 151.

Usage: Event
SCPI confirmed

:MEMory:HFRee?

Returns the used and available memory in Kb.

Return values: 
<TotalPhysMemKb> integer

Total physical memory.

<ApplicMemKb> integer
Application memory.

<HeapUsedKb> integer
Used heap memory.

<HeapAvailableKb> integer
Available heap memory.

Usage: Query only

:MMEMory:LOAD:STATe <SavRclStateNumb>, <file_name>

Loads the specified file stored under the specified name in an internal memory.

After the file has been loaded, the instrument setting must be activated using an *RCL
command.

Setting parameters: 
<SavRclStateNumb> Determines to the specific <number> to be used with the *RCL

command, e.g. *RCL 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Example: See "Storing and Loading Current Settings" on page 151.

Usage: Setting only

:MMEMory:MDIRectory <Directory>

Creates a subdirectory for mass memory storage in the specified directory. If no direc-
tory is specified, a subdirectory is created in the default directory. This command can
also be used to create a directory tree.
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Setting parameters: 
<Directory> string

String parameter to specify the new directory.

Example: See "Working with Files and Directories" on page 151.

Usage: Event

:MMEMory:MOVE <SourceFile>, <DestinationFile>

Moves an existing file to a new location or, if no path is specified, renames an existing
file.

Setting parameters: 
<SourceFile> string

String parameter to specify the name of the file to be moved.

<DestinationFile> string
String parameters to specify the name of the new file.

Example: See "Working with Files and Directories" on page 151.

Usage: Event
SCPI confirmed

:MMEMory:MSIS <Msis>

Defines the drive or network resource (in the case of networks) for instruments with
windows operating system, using msis (MSIS = Mass Storage Identification String).

Note: Instruments with Linux operating system ignore this command, since Linux does
not use drive letter assignment.

Usage: SCPI confirmed

:MMEMory:RDIRectory <Directory>

Removes an existing directory from the mass memory storage system. If no directory
is specified, the subdirectory with the specified name is deleted in the default directory.

Setting parameters: 
<Directory> string

String parameter to specify the directory to be deleted.

Example: See "Working with Files and Directories" on page 151.

Usage: Event

:MMEMory:STORe:STATe <savrcl_state_nr>, <file_name>

Stores the current instrument setting in the specified file.
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The instrument setting must first be stored in an internal memory with the same num-
ber using the common command *SAV.

Setting parameters: 
<savrcl_state_nr> Corresponds to the specific <number> defined with the *SAV

command, e.g. *SAV 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Example: See "Storing and Loading Current Settings" on page 151.

Usage: Event

11.11 OUTPut Subsystem

:OUTPut:AMODe........................................................................................................... 158
:OUTPut[:STATe]...........................................................................................................158
:OUTPut[:STATe]:PON...................................................................................................159
:OUTPut:AFIXed:RANGe:LOWer?...................................................................................159
:OUTPut:AFIXed:RANGe:UPPer?....................................................................................159
:OUTPut<hw>:PROTection:CLEar................................................................................... 159

:OUTPut:AMODe <AMode>

Sets the mode of the attenuator (Attenuator MODe) at the RF output.

Parameters:
<AMode> AUTO | FIXed

AUTO
The attenuator is switched automatically. The level settings are
made in the full range.
FIXed
The level settings are made without switching the attenuator.
When this operating mode is switched on, the attenuator is fixed
to its current position and the resulting variation range is defined.
*RST: AUTO

Manual operation: See "Mode" on page 74

:OUTPut[:STATe] <State>

Activates/deactivates the RF output.

Parameters:
<State> 0 | 1 | OFF | ON

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 131.

Manual operation: See "RF On/Off" on page 57
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:OUTPut[:STATe]:PON <Mode>

Selects the state which the RF output takes when the instrument is switched on.

Parameters:
<Mode> OFF | UNCHanged

OFF
When the instrument is switched on, the output is deactivated .
UNCHanged
When the instrument is switched on, the output remains in the
same state as it was before the instrument was switched off.
*RST: UNCHanged

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 131 .

Manual operation: See "Power-On State" on page 75

:OUTPut:AFIXed:RANGe:LOWer?

Queries the minimum level which can be set without the attenuator being adjusted.

Return values: 
<Lower> float

Default unit: dBm

Example: See Chapter 11.1.3, "Advanced Task for Optimizing Perform-
ance", on page 133.

Usage: Query only

Manual operation: See "Level Range" on page 74

:OUTPut:AFIXed:RANGe:UPPer?

Queries the maximum level which can be set without the attenuator being adjusted.

Return values: 
<Upper> float

Default unit: dBm

Example: See Chapter 11.1.3, "Advanced Task for Optimizing Perform-
ance", on page 133 .

Usage: Query only

Manual operation: See "Level Range" on page 74

:OUTPut<hw>:PROTection:CLEar

Resets the protective circuit after it has been tripped. The state of the output is again
determined by OUTPut:STATe.

OUTPut Subsystem

ManualsPlus.com

https://www.manualsplus.com/


Remote Control CommandsR&S®SGU100A

160User Manual 1176.7726.02 ─ 07

Example: OUTP:PROT:CLE
resets the protective circuit for RF output.

Usage: Event

11.12 SOURce Subsystem

[:SOURce]:SETTings:APPLy[:IMMediate]......................................................................... 160
[:SOURce]:FREQuency[:CW|FIXed].................................................................................160
[:SOURce]:TRAits<ch>...................................................................................................160
[:SOURce]:TRAits:COUNt?............................................................................................. 161

[:SOURce]:SETTings:APPLy[:IMMediate]

Applies the signal settings and outputs the signal.

See Chapter 11.14, "SOURce:Local Oscillator Subsystem", on page 163 for a descrip-
tion of the setting process.

Usage: Event

Manual operation: See "Confirm External LO Settings" on page 83

[:SOURce]:FREQuency[:CW|FIXed] <Cw>

Sets the RF frequency at the RF output connector of the instrument.

Parameters:
<Cw> float

Range: 1E+6  to  40E+9
Increment: 1E-3
*RST: 1E+9

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 131.

Manual operation: See "Frequency" on page 57

[:SOURce]:TRAits<ch>

Queries for a list of values for the corresponding trait. The following values values are
available for the channel number:

● 1: queries the upper edge frequencies for the frequency bands
● 2: queries the upconverter frequency multiplication factors for each band
● 3: queries if the bypass mode is active for each band
● 4: queries the pulsmodulation performed in LO for each band
● 5: queries the AM signal allowed for each band
● 6: queries the PM / PhiM signal allowed for each band
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[:SOURce]:TRAits:COUNt?

Queries the number of trait lists.

Return values: 
<Count> float

Usage: Query only

11.13 SOURce:IQ Subsystem

The IQ Impairment remote commands are available only for R&S SGU-B120V/-B140V.

[:SOURce]:IQ:STATe..................................................................................................... 161
[:SOURce]:IQ:IMPairment:IQRatio................................................................................... 161
[:SOURce]:IQ:IMPairment:LEAKage:I...............................................................................162
[:SOURce]:IQ:IMPairment:LEAKage:Q.............................................................................162
[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe]...............................................................162
[:SOURce]:IQ:IMPairment:STATe.................................................................................... 162
[:SOURce]:IQ:CREStfactor..............................................................................................163

[:SOURce]:IQ:STATe <State>

Switches the I/Q modulation on and off.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 131.

Options: R&S SGU-B120V/-B140V

Manual operation: See "Mod State" on page 57

[:SOURce]:IQ:IMPairment:IQRatio <IqRatio>

Sets the ratio of I modulation to Q modulation (gain “imbalance”). The input may be
either in dB or %. An input in percent is rounded to the closest valid value in dB. A
query returns the value in dB.

Parameters:
<IqRatio> float

Range: -1  to  1
Increment: 1E-3
*RST: 0

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 131.

Options: R&S SGU-B120V/-140V
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Manual operation: See "Gain Imbalance" on page 81

[:SOURce]:IQ:IMPairment:LEAKage:I <I>
[:SOURce]:IQ:IMPairment:LEAKage:Q <Q>

Sets the carrier leakage amplitude for the I-/Q-signal component.

Parameters:
<Q> float

Range: -5  to  5
Increment: 0.01
*RST: 0
Default unit: PCT

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 131.

Options: R&S SGU-B120V/-B140V

Manual operation: See "Offset" on page 80

[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe] <Angle>

Sets the quadrature offset for the digital I/Q signal.

Parameters:
<Angle> float

Range: -8  to  8
Increment: 0.01
*RST: 0
Default unit: DEG

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 131.

Options: R&S SGU-B120V/-B140V

Manual operation: See "Quadrature Offset" on page 81

[:SOURce]:IQ:IMPairment:STATe <State>

Activates/deactivates the impairment or correction values LEAKage, QUADrature and
IQRatio for the baseband signal prior to input to the I/Q modulator.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 131.

Options: R&S SGU-B120V/-B140V

Manual operation: See "State" on page 80
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[:SOURce]:IQ:CREStfactor <Crest>

Sets the crest factor of the I/Q modulation signal.

Parameters:
<Crest> float

Range: 0  to  35
Increment: 0.01
*RST: 0
Default unit: dB

Example: See Chapter 11.1.2, "Generating an I/Q Modulated Signal",
on page 131

Manual operation: See "Crest Factor" on page 79

11.14 SOURce:Local Oscillator Subsystem

R&S SGU as an extension to a compatible R&S signal generator

If a R&S SGU is connected to a compatible R&S signal generator the R&S SGU acts
as an extension to the signal generator extending its frequency range. In this setup a
controller does not need to access the R&S SGU directly. Instead, the signal generator
acts as a controller to the R&S SGU and depending on the required output signal
parameters performs all required settings automatically.

For example, if the signal generator is set to an output frequency of 15 GHz it passes
this value on to the R&S SGU. On reception of the new frequency R&S SGU blanks its
output and computes the necessary settings for the local oscillator (signal generator).
Next, the signal generator queries R&S SGU for the required frequency and level val-
ues of the local oscillator, which answers with for example 7.5 GHz and -10 dBm. The
signal generator applies these settings to its own oscillator hardware and confirms that
the required signal is now present at its output connector by sending the apply com-
mand to the R&S SGU. The R&S SGU unblanks its own output thus finishing the cycle.

R&S SGU as an upconverter for any signal generator

If, on the other hand, the R&S SGU is connected to an incompatible signal generator
the controller has to perform the above steps instead of the signal generator. We
assume that a remote PC (controller) is connected to both the R&S SGU and the sig-
nal generator (local oscillator). When changing any parameters which affect the output
signal of the combined system of local oscillator and R&S SGU the controller has to
follow these steps:

Setting the signal of the R&S SGU

1. Set the parameters of the R&S SGU like frequency and level as needed.
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2. Query the local oscillator frequency and the local oscillator level from R&S SGU
with the SCPI commands [:SOURce]:LOSCillator:FREQuency? and [:
SOURce]:LOSCillator:POWer?.

3. Interpret the result and apply the required changes to the LO.

4. Send the SCPI command [:SOURce]:SETTings:APPLy[:IMMediate] to
R&S SGU to output the signal.

See Chapter 11.1.3, "Advanced Task for Optimizing Performance", on page 133 for an
example.

[:SOURce]:LOSCillator:FREQuency?...............................................................................164
[:SOURce]:LOSCillator:POWer?......................................................................................164

[:SOURce]:LOSCillator:FREQuency?

Queries the frequency of the local oscillator input signal.

See Chapter 11.14, "SOURce:Local Oscillator Subsystem", on page 163 for a descrip-
tion of the setting process.

Return values: 
<Frequency> float

Range: 1E+6  to  20E+9
Increment: 1E-3
*RST: 1E+9

Usage: Query only

Manual operation: See "Frequency" on page 83

[:SOURce]:LOSCillator:POWer?

Queries the level of the local oscillator input signal.

See Chapter 11.14, "SOURce:Local Oscillator Subsystem", on page 163 for a descrip-
tion of the setting process.

Return values: 
<Amplitude> float

Range: -120  to  25
Increment: 0.01
*RST: -10

Usage: Query only

Manual operation: See "Level" on page 83
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11.15 SOURce:POWer Subsystem

[:SOURce]:POWer:ALC[:STATe]..................................................................................... 165
[:SOURce]:POWer:ALC:DSENsitivity............................................................................... 165
[:SOURce]:POWer:ALC:SONCe......................................................................................165
[:SOURce]:POWer:ATTenuation:RFOFf:MODE.................................................................165
[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet]............................................................. 166
[:SOURce]:POWer:LMODe............................................................................................. 166
[:SOURce]:POWer:SCHaracteristic..................................................................................166
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude]..........................................................166
[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet................................................................167
[:SOURce]:POWer:LIMit[:AMPLitude]...............................................................................167
[:SOURce]:POWer:PEP?................................................................................................ 167
[:SOURce]:POWer:POWer..............................................................................................168
[:SOURce]:POWer:RANGe:LOWer?................................................................................ 168
[:SOURce]:POWer:RANGe:UPPer?.................................................................................168

[:SOURce]:POWer:ALC[:STATe] <State>

Activates/deactivates the automatic level control.

Parameters:
<State> 1 | OFFTable | ONTable | ON

*RST: ONTable

Manual operation: See "State" on page 76

[:SOURce]:POWer:ALC:DSENsitivity <Sensitivity>

Sets the sensitivity of the power detector.

Parameters:
<Sensitivity> OFF | LOW | MED | HIGH

*RST: OFF

[:SOURce]:POWer:ALC:SONCe

Briefly activates automatic level control for correction purposes.

Usage: Event

Manual operation: See "Readjust" on page 73

[:SOURce]:POWer:ATTenuation:RFOFf:MODE <Mode>

Selects the state which the attenuator assumes when the instrument is switched on.

Parameters:
<Mode> MAX | FIXed

*RST: MAX
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Manual operation: See "RF-Off-Mode" on page 74

[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet] <Offset>

Sets the switch-over offset value of the attenuator.

Parameters:
<Offset> float

*RST: 0

Manual operation: See "SATT Switch-Over Offset" on page 74

[:SOURce]:POWer:LMODe <LevMode>

Selects the level mode.

Parameters:
<LevMode> NORMal | LNOise | LDIStortion

NORMal
automatic selection of the best settings
LNOISe
settings for lowest noise
LDIStortion
settings for lowest distortions
*RST: NORMal

Example: see Chapter 11.1.3, "Advanced Task for Optimizing Perform-
ance", on page 133

Manual operation: See "Mode" on page 72

[:SOURce]:POWer:SCHaracteristic <Characteristic>

Selects the characteristic for the level setting.

Parameters:
<Characteristic> AUTO | UNINterrupted | CVSWr | USER | MONotone

UNINterrupted: Uninterrupted Level setting, CVSWr: Con-
stant-VSWR, MONotone: Strictly Monotone

*RST: AUTO

Example: see Chapter 11.1.3, "Advanced Task for Optimizing Perform-
ance", on page 133

Manual operation: See "Setting Characteristic" on page 72

[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] <Amplitude>

Sets the RF level at the RF output connector of the instrument.
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Parameters:
<Amplitude> float

Range: -120  to  25
Increment: 0.01
*RST: -10

Example: See Chapter 11.1.3, "Advanced Task for Optimizing Perform-
ance", on page 133.

Manual operation: See "Level/Level Offset" on page 57

[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet <Offset>

Specifies the constant level offset of a downstream attenuator/amplifier. If a level offset
is entered, the level entered with [:SOURce]:POWer:POWer no longer corresponds
to the RF output level.

The following correlation applies:

:POWer = RF output level + POWer:OFFSet.

Entering a level offset does not change the RF output level, but rather the query value
of :POWer.

Only dB is permitted as the unit here. The linear units (V, W, etc.) are not permitted.

Parameters:
<Offset> float

Range: -100  to  100
Increment: 0.1
*RST: 0

Manual operation: See "Offset" on page 72

[:SOURce]:POWer:LIMit[:AMPLitude] <Amplitude>

Sets the upper limit of the RF signal power.

The value is not affected by an instrument preset and *RST function. This parameter is
influenced only by the factory preset (SYST:FPR) and its factory value is equal to the
upper limit.

Parameters:
<Amplitude> float

Range: -300  to  30
Increment: 0.01
Default unit: dBm

Manual operation: See "Limit" on page 73

[:SOURce]:POWer:PEP?

Queries the RF signal's peak envelope power at the DUT.
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Return values: 
<PEP> float

Range: -120  to  25
Increment: 0.01
*RST: -10

Example: see Chapter 11.1.3, "Advanced Task for Optimizing Perform-
ance", on page 133

Usage: Query only

Manual operation: See "PEP" on page 57

[:SOURce]:POWer:POWer <Power>

Sets the level at the RF output connector.

This value does not consider a specified offset. The command [:SOURce]:POWer[:
LEVel][:IMMediate]:OFFSet sets the level of the "Level" display, that means the
level containing offset.

Parameters:
<Power> float

Range: -120  to  25
Increment: 0.01
*RST: -10

Example: POW:POW 15
sets the RF level at output to 15 dBm.

Manual operation: See "Level/Level Offset" on page 57

[:SOURce]:POWer:RANGe:LOWer?
[:SOURce]:POWer:RANGe:UPPer?
Queries the minimum/maximum level range in the current level mode

Return values: 
<Upper> float

Range: -300  to  30
Increment: 0.01
*RST: 30

Usage: Query only

Manual operation: See "Level Range" on page 73

11.16 SOURce:PULM Subsystem

[:SOURce<hw>]:PULM:STATe........................................................................................169
[:SOURce<hw>]:PULM:POLarity..................................................................................... 169
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[:SOURce<hw>]:PULM:STATe <State>

Activates the pulse modulation.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: PULM:STAT ON
activates pulse modulation.

Manual operation: See "State" on page 82

[:SOURce<hw>]:PULM:POLarity <Polarity>

Sets the polarity of the pulse modulator signal. This command is effective only for an
external modulation signal.

Parameters:
<Polarity> NORMal | INVerted

NORMal
The RF signal is suppressed during the pulse pause.
INVerted
The RF signal is suppressed during the pulse.
*RST: NORMal

Example: PULM:POL INV
selects inverted polarity.

Manual operation: See "Polarity" on page 82

11.17 STATus Subsystem

This system contains the commands for the status reporting system. See also Chap-
ter A.5, "Status Reporting System", on page 206 for detailed information.

*RST on page 138 has no effect on the status registers.

Value ranges

● Queries return the current value of the respective register, which permits a check of
the device status.
Return values: A decimal value in the range 0 to 32767 (=215-1)

● The configuration commands set the respective register thus determining which
status changes of the R&S SGU cause the status registers to be changed.
Setting values: A decimal value in the range 0 to 32767 (=215-1)

:STATus:OPERation:CONDition...................................................................................... 170
:STATus:OPERation:ENABle.......................................................................................... 170
:STATus:OPERation[:EVENt].......................................................................................... 170
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:STATus:OPERation:NTRansition....................................................................................171
:STATus:OPERation:PTRansition.................................................................................... 171
:STATus:PRESet........................................................................................................... 171
:STATus:QUEStionable:CONDition..................................................................................171
:STATus:QUEStionable:ENABle......................................................................................172
:STATus:QUEStionable[:EVENt]......................................................................................172
:STATus:QUEStionable:NTRansition................................................................................172
:STATus:QUEStionable:PTRansition................................................................................172
:STATus:QUEue[:NEXT]?...............................................................................................173

:STATus:OPERation:CONDition <Condition>

Sets the content of the CONDition part of the STATus:OPERation register. This part
contains information on the action currently being performed in the instrument. The
content is not deleted after being read out because it indicates the current hardware
status.

Parameters:
<Condition> string

Example: :STATus:OPERation:CONDition?
queries the Status:Operation:Condition register.

:STATus:OPERation:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:OPERation register. This setting deter-
mines which events of the Status-Event part are forwarded to the sum bit in the status
byte. These events can be used for a service request.

Parameters:
<Enable> string

Example: :STAT:OPER:ENAB 32767
all events are forwarded to the sum bit of the status byte.

:STATus:OPERation[:EVENt] <Event>

Queries the content of the EVENt part of the STATus:OPERation register. This part
contains information on the actions performed in the instrument since the last readout.
The content of the EVENt part is deleted after being read out.

Parameters:
<Event> string

Example: :STAT:OPER:EVEN?
queries the STATus:OPERation:EVENt register.
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:STATus:OPERation:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:OPERation register. If a bit is set,
a transition from 1 to 0 in the condition part causes an entry to be made in the EVENt
part of the register. The disappearance of an event in the hardware is thus registered,
for example the end of an adjustment.

Parameters:
<Ntransition> string

Example: :STAT:OPER:NTR 0
a transition from 1 to 0 in the condition part of the Status:Opera-
tion register does not cause an entry to be made in the EVENt
part.

:STATus:OPERation:PTRansition <Ptransition>

Sets the bits of the PTRansition part of the STATus:OPERation register. If a bit is set,
a transition from 0 to 1 in the condition part causes an entry to be made in the EVENt
part of the register. A new event in the hardware is thus registered, for example the
start of an adjustment.

Parameters:
<Ptransition> string

Example: :STAT:OPER:PTR 32767
all transitions from 0 to 1 in the condition part of the Status:Oper-
ation register cause an entry to be made in the EVENt part.

:STATus:PRESet <Preset>

Resets the status registers. All PTRansition parts are set to FFFFh (32767), i.e. all
transitions from 0 to 1 are detected. All NTRansition parts are set to 0, i.e. a transition
from 1 to 0 in a CONDition bit is not detected. The ENABle parts of STATus:OPERa-
tion and STATus:QUEStionable are set to 0, i.e. all events in these registers are not
passed on.

Parameters:
<Preset> string

Example: STAT:PRES
resets the status registers.

:STATus:QUEStionable:CONDition <Condition>

Queries the content of the CONDition part of the STATus:QUEStionable register. This
part contains information on the action currently being performed in the instrument.
The content is not deleted after being read out since it indicates the current hardware
status.

Parameters:
<Condition> string
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Example: :STATus:QUEStionable:CONDition?
queries the Status:Questionable:Condition register.

:STATus:QUEStionable:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:QUEStionable register. This setting
determines which events of the Status-Event part are enabled for the sum bit in the
status byte. These events can be used for a service request.

Parameters:
<Enable> string

Example: STAT:OPER:ENAB 1
problems when performing an adjustment cause an entry to be
made in the sum bit.

:STATus:QUEStionable[:EVENt] <Event>

Queries the content of the EVENt part of the STATus:QUEStionable register. This
part contains information on the actions performed in the instrument since the last
readout. The content of the EVENt part is deleted after being read out.

Parameters:
<Event> string

Example: STAT:QUES:EVEN?
queries the Status:Questionable:Event register.

:STATus:QUEStionable:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<Ntransition> string

Example: STAT:OPER:NTR 0
a transition from 1 to 0 in the condition part of the Status:Ques-
tionable register does not cause an entry to be made in the
EVENt part

:STATus:QUEStionable:PTRansition <PTransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<PTransition> string
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Example: :STAT:OPER:PTR 32767
all transitions from 0 to 1 in the condition part of the Sta-
tus:Questionable register cause an entry to be made in the
EVENt part

:STATus:QUEue[:NEXT]?

Queries the oldest entry in the error queue and then deletes it. Positive error numbers
denote device-specific errors, and negative error numbers denote error messages
defined by SCPI. If the error queue is empty, 0 ("No error") is returned.

The command is identical to :SYSTem:ERRor[:NEXT]? on page 176.

Return values: 
<Next> string

Example: :STATus:QUEue?
queries the oldest entry in the error queue.
Response: 0, 'no error'
no errors have occurred since the error queue was last read out

Usage: Query only

11.18 SYSTem Subsystem

The SYSTem subsystem contains a series of commands for general functions which do
not directly affect signal generation.

:SYSTem:EMODe..........................................................................................................174
:SYSTem:ERRor:ALL?................................................................................................... 174
:SYSTem:ERRor:CODE:ALL?......................................................................................... 174
:SYSTem:ERRor:CODE[:NEXT]?.................................................................................... 175
:SYSTem:ERRor:COUNt?...............................................................................................175
:SYSTem:ERRor[:NEXT]?...............................................................................................176
:SYSTem:SERRor?........................................................................................................176
:SYSTem:VERSion?.......................................................................................................176
:SYSTem:COMMunicate:NETWork:IPADdress................................................................. 177
:SYSTem:COMMunicate:NETWork:IPADdress:MODE.......................................................177
:SYSTem:COMMunicate:NETWork:MACaddress.............................................................. 177
:SYSTem:COMMunicate:NETWork:RESTart.....................................................................177
:SYSTem:COMMunicate:NETWork:STATus?................................................................... 177
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname............................................... 178
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway.................................................178
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK......................................... 178
:SYSTem:COMMunicate:NETWork:RESource?................................................................ 178
:SYSTem:COMMunicate:HISLip:RESource?.....................................................................179
:SYSTem:COMMunicate:PCIexpress:RESource?..............................................................179
:SYSTem:COMMunicate:SOCKet:RESource?...................................................................179
:SYSTem:COMMunicate:USB:RESource?........................................................................179
:SYSTem:COMMunicate:SERial:RESource?.....................................................................180
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:SYSTem:COMMunicate:SERial:BAUD............................................................................ 180
:SYSTem:COMMunicate:SERial:PARity........................................................................... 180
:SYSTem:COMMunicate:SERial:SBITs............................................................................ 180
:SYSTem:HARDware:ASSembly<dir>:SNUMber?.............................................................181
:SYSTem:MMEMory:PATH:USER?................................................................................. 181
:SYSTem:OSYStem?..................................................................................................... 181
:SYSTem:PROTect<ch>[:STATe].................................................................................... 181
:SYSTem:STARtup:COMPlete?.......................................................................................182

:SYSTem:EMODe <Mode>

Enables and selects the eco mode.

Parameters:
<Mode> OFF | EM1

*RST: OFF

Example: See Chapter 11.1.1, "Performing General Tasks for Instrument
Setup", on page 130.

:SYSTem:ERRor:ALL?

Queries the error/event queue for all unread items and removes them from the queue.
The response is a comma separated list of error number and a short description of the
error in FIFO order.

Positive error numbers are instrument-dependent. Negative error numbers are
reserved by the SCPI standard.

Return values: 
<All> string

List of: Error/event_number,"Error/event_description>[;Device-
dependent info]"
If the queue is empty, the response is 0,"No error"

Example: SYST:ERR:ALL?
queries all entries in the error queue.
Response: 0, 'no error'
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:CODE:ALL?

Queries all entries in the error queue and then deletes them. Only the error numbers
are returned and not the entire error text.
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Return values: 
<All> string

0
"No error", i.e. the error queue is empty
positive value
Positive error numbers denote device-specific errors
negative value
Negative error numbers denote error messages defined by
SCPI.

Example: SYST:ERR:CODE:ALL
queries all entries in the error queue.
Response: 0
no errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:CODE[:NEXT]?

Queries the oldest entry in the error queue and then deletes it. Only the error number
is returned and not the entire error text.

Return values: 
<Next> string

0
"No error", i.e. the error queue is empty
positive value
Positive error numbers denote device-specific errors
negative value
Negative error numbers denote error messages defined by
SCPI.

Example: SYST:ERR:CODE
queries the oldest entry in the error queue.
Response: 0
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:COUNt?

Queries the number of entries in the error queue. If the error queue is empty, '0' is
returned.

Return values: 
<Count> string

Example: SYST:ERR:COUN
queries the number of entries in the error queue.
Response: 1
One error has occurred since the error queue was last read out.
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Usage: Query only

:SYSTem:ERRor[:NEXT]?

Queries the error/event queue for the oldest item and removes it from the queue. The
response consists of an error number and a short description of the error.

Positive error numbers are instrument-dependent. Negative error numbers are
reserved by the SCPI standard.

Return values: 
<Next> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
If the queue is empty, the response is 0,"No error"

Example: SYST:ERR?
queries the oldest entry in the error queue.
Response: 0, 'no error'
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:SERRor?

Returns a list of all errors existing at the time when the query is started. This list corre-
sponds to the display on the info page under manual control.

Return values: 
<Serror> string

Example: SYST:SERR
queries all errors existing in the error queue.

Example: Response: -221, 'Settings conflict', 153,
'Input voltage out of range'
The two returned errors have occurred since the error queue
was last queried.

Usage: Query only

:SYSTem:VERSion?

Queries the SCPI version the instrument's command set complies with.

Return values: 
<Version> string

Example: SYST:VERS
queries the SCPI version.
Response: "1996"
The instrument complies with the SCPI version from 1996.

Usage: Query only
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:SYSTem:COMMunicate:NETWork:IPADdress <IpAddress>

Sets the IP address.

Parameters:
<IpAddress> string

Range: 0.0.0.0.  to  ff.ff.ff.ff

Example: SYSTem:COMMunicate:NETWork:IPADdress '7.8.9.10'
sets the IP address of the instrument.

Manual operation: See "IP Address" on page 96

:SYSTem:COMMunicate:NETWork:IPADdress:MODE <Mode>

Selects manual or automatic setting of the IP address.

Parameters:
<Mode> AUTO | STATic

*RST: AUTO

Example: SYSTem:COMMunicate:NETWork:IPADdress:MODE AUTO
the IP address is assigned automatically (DHCP)

Manual operation: See "Address Mode" on page 96

:SYSTem:COMMunicate:NETWork:MACaddress <MacAddress>

Queries the MAC address of the network adapter.

Parameters:
<MacAddress> string

Example: SYST:COMM:NETW:MAC
queries the MAC address.

:SYSTem:COMMunicate:NETWork:RESTart

Restarts the network connection to the instrument, terminates the connection and sets
it up again.

Example: SYSTem:COMMunicate:NETWork:RESTart
Usage: Event

:SYSTem:COMMunicate:NETWork:STATus?

Queries the network configuration state.

Return values: 
<State> 0 | 1 | OFF | ON

Usage: Query only
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:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname <Hostname>

Sets the individual host name of the R&S SGU.

Note: it is recommended that you do not change the host name in order to avoid prob-
lems with the networdk connection. However, if you change the host name be sure to
use an unique name.

The host name is a protected parameter, To change it, first disable protection level 1
with command :SYSTem:PROTect<ch>[:STATe] on page 181.

Parameters:
<Hostname> string

Example: SYSTem:PROTect1:STATe OFF,123456
SYSTem:COMMunicate:NETWork:HOSTname 'SIGGEN'
sets the individual computer name of the R&S SGU.

Manual operation: See "Hostname" on page 95

:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway <Gateway>

Sets the IP address of the default gateway.

Parameters:
<Gateway> string

Range: 0.0.0.0  to  ff.ff.ff.ff

Example: SYSTem:COMMunicate:NETWork:IPADdress:GATeway
'1.2.3.4'
sets the IP address of the default gateway.

Manual operation: See "Default Gateway" on page 96

:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK <Mask>

Sets the subnet mask.

Parameters:
<Mask> string

Example: SYSTem:COMMunicate:NETWork:IPADdress:SUBNet:
MASK '255.255.0.0'
determines the subnet mask.

Manual operation: See "Subnet Mask" on page 96

:SYSTem:COMMunicate:NETWork:RESource?

Queries the VISA resource string, used for remote control of the instrument with
VXI-11 protocol.

Return values: 
<Resource> string
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Example: SYSTem:COMMunicate:NETWork:RESource?
Response: "TCPIP::192.1.2.3::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 97

:SYSTem:COMMunicate:HISLip:RESource?

Queries the VISA resource string, used for remote control of the instrument with
HiSLIP protocol.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:HISLip:RESource?
Response: "TCPIP::192.1.2.3::hislip0::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 97

:SYSTem:COMMunicate:PCIexpress:RESource?

Queries the visa resource string for remote control via the PCIe interface.

Return values: 
<Resource> string

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 97

:SYSTem:COMMunicate:SOCKet:RESource?

Queries the visa resource string for remote control via LAN interface, using TCP/IP
socket protocol.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:SOCKet:RESource?
Response: "TCPIP::10.113.1.150::5025::SOCKET"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 97

:SYSTem:COMMunicate:USB:RESource?

Queries the visa resource string for remote control via the USB interface.

Return values: 
<Resource> string
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Example: SYSTem:COMMunicate:USB:RESource?
queries the VISA resource string for remote control via the USB
interface.
Response: "USB::72::000000::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 97

:SYSTem:COMMunicate:SERial:RESource?

Queries the visa resource string for the serial remote control interface. This string is
used for remote control of the instrument.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:SERial:RESource?
queries the VISA resource string.
Response: "ASRL1::INSTR"

Usage: Query only

:SYSTem:COMMunicate:SERial:BAUD <Baud>

Sets the baudrate for the serial remote control interface.

Parameters:
<Baud> 2400 | 4800 | 9600 | 19200 | 38400 | 57600 | 115200

*RST: 115200

Example: SYSTem:COMMunicate:SERial:BAUD 115200
determines 115200 baudrate.

:SYSTem:COMMunicate:SERial:PARity <Parity>

Sets the parity for the serial remote control interface.

Parameters:
<Parity> NONE | ODD | EVEN

*RST: NONE

Example: SYST:COMM:SER:PAR NONE
selects parity NONE.

:SYSTem:COMMunicate:SERial:SBITs <SBits>

Sets the number of stop bits for the serial remote control interface.

Parameters:
<SBits> 1 | 2

*RST: 1

SYSTem Subsystem

ManualsPlus.com

https://www.manualsplus.com/


Remote Control CommandsR&S®SGU100A

181User Manual 1176.7726.02 ─ 07

Example: SYST:COMM:SER:SBIT 2
selects 2 stop bits.

:SYSTem:HARDware:ASSembly<dir>:SNUMber?

Queries the list of hardware module serial numbers.

Suffix: 
<dir>

.
1 | 2
Defines the section: 1 = common assembly, 2 = RF assembly.

Return values: 
<SNumber> string

Example: SYSTem:HARDware:ASSembly1:SNUMber?

Usage: Query only

Manual operation: See "Assembly" on page 87

:SYSTem:MMEMory:PATH:USER?

Queries the user directory, that means the directory the instrument stores user files on.

Return values: 
<PathUser> string

Example: SYSTem:MMEMory:PATH:USER?
Response: "/var/user/"'

Usage: Query only

:SYSTem:OSYStem?

Queries the operating system of the instrument.

Return values: 
<OperSystem> string

Example: SYSTem:OSYStem?
Response: "Linux"

Usage: Query only

:SYSTem:PROTect<ch>[:STATe] <State>[, <Key>]

Activates/deactivates the specified protection level.

Parameters:
<State> select

*RST: 1
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Setting parameters: 
<Key> integer

The respective functions are disabled when the protection level
is activated. No password is required for activation. A password
must be entered to deactivate the protection level. The pass-
word for the first level is 123456.

Example: SYSTem:PROTect1:STATe ON
activates protection level 1.
SYSTem:PROTect1:STATe OFF,123456
deactivates protection level 1.

:SYSTem:STARtup:COMPlete?

Queries if the startup of the instrument is completed.

Return values: 
<Complete> 0 | 1 | OFF | ON

*RST: 0

Example: SYST:STAR:COMP?
// 1
// the startup of the instrument is completed

Usage: Query only

11.19 TEST Subsystem

The TEST system contains the commands for performing the routines. R&S SGU can-
not perform the selftest on its own. Therefore a connection with a signal generator is
needed. If you use a compatible R&S signal generator, then the calibration process will
be completed automatically after starting the calibration process. Otherwise you have
to follow the steps described in "Calibration process of the R&S SGU" on page 142. In
the given example, replace the :CALibration:xxx:STARt SCPI command
with :TEST:ALL:STARt and :CALibration:xxx:RESult with :TEST:ALL:
RESult. We assume that a remote PC is connected to the instruments, the remote PC
and the instruments are switched on and a connection between them is established.

The self tests returns a "0" if the test is performed successfully, otherwise a value other
than "0" is returned. None of the commands of this system has a *RST value.

Improper use can destroy the assembly
The respective hardware assembly responds directly to the :TEST:DIRect command;
any safety mechanisms are bypassed. The command is intended for servicing purpo-
ses and should be used only by the Rohde & Schwarz service personnel.
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:TEST:ALL:STARt..........................................................................................................183
:TEST:ALL:RESult?........................................................................................................183
:TEST:KEYBoard[:STATe].............................................................................................. 183

:TEST:ALL:STARt

Starts a selftest. Use the command :TEST:ALL:RESult? to query the result.

Use :CALibration:HREQuest? to query for settings required by the instrument.

Usage: Event

:TEST:ALL:RESult?

Queries the result of the performed selftest. Start the selftest with :TEST:ALL:STARt.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

*RST: STOPped

Example: See Chapter 11.1.1, "Performing General Tasks for Instrument
Setup", on page 130.

Usage: Query only

:TEST:KEYBoard[:STATe] <State>

Enables/disables the keyboard and the LED test state.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: OFF

11.20 UNIT Subsystem

The UNIT subsystem contains the commands specifying which units are valid if no unit
is indicated in a command. These settings are valid for the entire instrument.

:UNIT:ANGLe <Angle>

Sets the default angle unit for remote control. Does not influence the manual control
parameter units and the display.

Parameters:
<Angle> DEGRee | RADian

*RST: RADian

Example: UNIT:ANGL DEG
sets DEG as a default unit for all commands which determine
angle values.
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:UNIT:POWer <Power>

Defines the default unit for power parameters. This setting affects the GUI, as well as
all remote control commands that determine power values.

Parameters:
<Power> V | DBUV | DBM

*RST: DBM

Example: UNIT:POW V
sets V as a default unit for all commands which determine power
values.

11.21 List of R&S SGU Commands

:CALibration:HREQuest?...............................................................................................................................144
:CALibration:IQModulator:LOCal:RESult?.....................................................................................................145
:CALibration:IQModulator:LOCal:STARt........................................................................................................145
:CALibration:IQModulator:RESult?................................................................................................................ 145
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:CALibration:IQModulator:TEMPerature?......................................................................................................145
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:CALibration:LEVel:TEMPerature?................................................................................................................ 146
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:DIAGnostic:POINt:CATalog?........................................................................................................................146
:DIAGnostic[:MEASure]:POINt?.....................................................................................................................147
:FFASt............................................................................................................................................................147
:FORMat:BORDer..........................................................................................................................................148
:FORMat:SREGister...................................................................................................................................... 149
:FORMat[:DATA]............................................................................................................................................148
:LOCK?.......................................................................................................................................................... 140
:MEMory:HFRee?.......................................................................................................................................... 156
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:MMEMory:COPY.......................................................................................................................................... 154
:MMEMory:DATA...........................................................................................................................................154
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:MMEMory:DELete.........................................................................................................................................155
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:MMEMory:MOVE..........................................................................................................................................157
:MMEMory:MSIS............................................................................................................................................157
:MMEMory:RDIRectory..................................................................................................................................157
:MMEMory:STORe:STATe............................................................................................................................ 157
:OUTPut:AFIXed:RANGe:LOWer?................................................................................................................ 159
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:OUTPut:AMODe........................................................................................................................................... 158
:OUTPut[:STATe]...........................................................................................................................................158
:OUTPut[:STATe]:PON..................................................................................................................................159
:OUTPut<hw>:PROTection:CLEar................................................................................................................ 159
:PFASt............................................................................................................................................................147
:REMote:OPMode..........................................................................................................................................139
:RESTart........................................................................................................................................................ 140
:SOURce<hw>:PRESet................................................................................................................................. 141
:STANdby.......................................................................................................................................................140
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12 Maintenance
The instrument does not need periodic maintenance. Only cleaning the instrument is
essential.

Follow the instructions in the service manual and the safety instructions when
exchanging modules or ordering spare parts. The order number for spare parts is inclu-
ded in the service manual. The service manual includes further information particularly
on troubleshooting, repair, exchange of modules (including battery exchange, adjust-
ment of the OCXO oscillator) and alignment.

The address of our support center and a list of all Rohde & Schwarz service centers
can be found at the beginning of this manual.

12.1 Cleaning

The outside of the instrument can be cleaned sufficiently using a soft, lint-free dust
cloth. Make sure that the fan openings are not obstructed.

Shock hazard
Before cleaning the instrument, make sure that the instrument is switched off and dis-
connected from all power supplies.

Instrument damage caused by cleaning agents
Cleaning agents contain substances that may damage the instrument. For example,
cleaning agents that contain a solvent may damage the front panel labeling, plastic
parts, or the display.
Never use cleaning agents such as solvents (thinners, acetone, etc), acids, bases, or
other substances.
The outside of the instrument can be cleaned sufficiently using a soft, lint-free dust
cloth.
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Risk of instrument damage due to obstructed fans
If the instrument is operated in dusty areas, the fans may become obstructed by dust
or other particles in the process of time. Make sure to check and, if necessary, clean
the fans regularly to ensure they operate properly at all times. If the instrument is run
with obstructed fans for a longer period, it may become overheated which may cause
damage.

12.2 Storing and Packing

The storage temperature range of the instrument is given in the data sheet. If the
instrument is to be stored for a longer period of time, it must be protected against dust.

Repack the instrument as it was originally packed when transporting or shipping. The
two protective foam plastic parts prevent the control elements and connectors from
being damaged. The antistatic packing foil avoids any undesired electrostatic charging
to occur.

If you do not use the original packaging, use a sturdy cardboard box of suitable size
and provide for sufficient padding to prevent the instrument from slipping inside the
package. Wrap antistatic packing foil around the instrument to protect it from electro-
static charging.
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13 Error Messages and Troubleshooting
This chapter describes the error messages of the R&S SGU. The error messages are
output in the "Info" line on the screen and entered in the error/event queue of the sta-
tus reporting system.

A great variety of different messages such as status messages, error messages, warn-
ings or information are displayed in the header field of the screen. Some error mes-
sages require that the error must be eliminated before correct instrument operation can
be ensured. The "Info" window with a list of current messages and a detailed descrip-
tion of each message can be opened with the "Info" button (see also Chapter 6.2.1,
"Info Dialog", on page 53).

13.1 Status Information

The status messages are displayed in the Info line of the R&S SGMA-GUI main panel.
The status information gives the user an overview of the main operating states and set-
tings of the instrument. The states are indicated for information only and do not neces-
sitate any action by the user.

Status Information displayed in the Info line

AttFixed
Attenuator fixed mode is active.

The uninterrupted level settings are made in a fixed range without attenuator switching.
The variation range is set automatically when this mode is activated. The range is dis-
played with the parameter "SGMA-GUI > Instrument Name > Level > Attenuator Fixed
Range".

13.2 Error Messages

Messages indicate errors in the instrument. They are displayed in the info line in differ-
ent colors depending on their importance and display duration. Errors (e.g. no calibra-
tion data) are displayed in red, information (e.g. file not found) and warnings in black.
Warnings indicate less significant errors (e.g. the instrument operates outside specified
data).

See also Chapter 6.2.1, "Info Dialog", on page 53 and Chapter 6.2.2, "Understanding
the Messages in the Info Bar", on page 55.

13.2.1 Volatile messages

Volatile messages report automatic settings in the instrument (e.g. switching off of
incompatible types of modulation) or on illegal entries that are not accepted by the

 

 

 

 

Error Messages

ManualsPlus.com

https://www.manualsplus.com/


Error Messages and TroubleshootingR&S®SGU100A

191User Manual 1176.7726.02 ─ 07

instrument (e.g. range violations). They are displayed in the info line on a yellow back-
ground. They are displayed on top of status information or permanent messages.

Volatile messages do not normally demand user actions and disappear automatically
after a brief period of time. They are stored in the history, however.

SCPI command: :SYSTem:ERRor:ALL? and :SYSTem:ERRor[:NEXT]?.

13.2.2 Permanent messages

Permanent messages are displayed if an error occurs that impairs further instrument
operation, e.g. a hardware fault. The error signaled by a permanent message must be
eliminated before correct instrument operation can be ensured.

The message is displayed until the error is eliminated. It covers the status display in
the info line. After error elimination, the message automatically disappears and is also
recorded in the history.

SCPI command: :SYSTem:SERRor?

13.3 SCPI-Error Messages

The SCPI error messages are the same in all SCPI instruments. Detailed information
and an overview of all error messages as defined in SCPI standard can be found in the
corresponding documentation.

The errors are assigned negative numbers. The error text being entered into the error/
event queue or being displayed is printed in bold face on the left together with the error
code. Below the error text, there is an explanation as to the respective error.

13.4 Device-Specific Error Messages

The following table contains all error messages specific for the instrument in alphabeti-
cal order, as well as an explanation of the error situation. The positive error codes
mark the errors specific of the instrument.

The device-specific error messages set bit 3 in the ESR register.

The index provides a list of the error messages sorted according to their error codes.
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Error
Code

Error Description Remedy

180 Adjustment failed Adjustment could not be executed The adjustment data have to be
generated first by an internal or
external adjustment or to be loa-
ded into the device.

182 Adjustment data miss-
ing

Adjustment data are missing. The adjustment data have to be
generated first by an internal or
external adjustment or to be loa-
ded into the instrument.

183 Adjustment data inva-
lid

Adjustment data are invalid and must
be restored.

The adjustment data have to be
generated again by an internal or
external adjustment or to be loa-
ded into the instrument.

200 Cannot access hard-
ware

The data transmission to a module
was unsuccessful.

The module is not installed, not
properly installed or missing.

201 Hardware revision out
of date

A later version of certain parts of the
instrument is necessary to execute
the function selected.

The driver does not support the
installed version of a module.

202 Cannot access the
EEPROM

A error occurs when writing or reading
a EEPROM.

The EEPROM might be defect
and has to be replaced.

203 Invalid EEPROM data   

204 Driver initialization
failed

Initialization of a driver fails when
booting the instrument firmware.

The driver is not compatible with
the hardware or software config-
uration of the instrument.

241 No current list There is no list selected. To execute the required opera-
tion, a list has to be selected in
the related dialog. If no list is
available, a new list must be cre-
ated.

242 Unknown list type
specified

The list type selected is not valid for
the required operation.

For instance, the file extension for
mapping files is *.map. It is not possi-
ble to enter another file extension
when selecting a list.

Check the selected list type.

460 Cannot open file The selected file can not be opened. Check the path and file name.

461 Cannot write file The file can not be written. Check if the file is read-only.

462 Cannot read file The file can not be read. Check if the file contents are
compatible with the file type.

463 Filename missing The required operation cannot be
executed because the file name is not
specified.

A file name has to be entered
when creating a new list.

464 Invalid filename exten-
sion

The file extension is not valid for the
required operation.

Check the file extension.

For instance, the file extension
for the mapping files is *.map. It
is not possible to enter another
file extension when storing a list.
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Error
Code

Error Description Remedy

465 File contains invalid
data

The selected file contains data that is
not valid for the file type.

Check the file extension.

The file extension determines the
data that is valid for this file type.
If the file extension is changed
the lists are no longer recognized
and the data are therefore inva-
lid.

468 Cannot find directory Required folder cannot be found. Check drive and path.

469 No files found Folder is empty  
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Annex
A Remote Control Basics

This chapter provides basic information on operating an instrument via remote control.

A.1 Messages

The messages transferred on the data lines are divided into the following categories:

● Interface messages
Interface messages are transmitted to the instrument on the data lines, with the
attention line being active (LOW). They are used to communicate between the con-
troller and the instrument. Interface messages can only be sent by instruments that
have GPIB bus functionality. For details see the sections for the required interface.

● Instrument messages
Instrument messages are employed in the same way for all interfaces, if not indica-
ted otherwise in the description. Structure and syntax of the instrument messages
are described in Chapter A.3, "SCPI Command Structure", on page 195. A
detailed description of all messages available for the instrument is provided in the
chapter "Remote Control Commands".
There are different types of instrument messages, depending on the direction they
are sent:
– Commands
– Instrument responses

Commands

Commands (program messages) are messages the controller sends to the instrument.
They operate the instrument functions and request information. The commands are
subdivided according to two criteria:
● According to the effect they have on the instrument:

– Setting commands cause instrument settings such as a reset of the instru-
ment or setting the frequency.

– Queries cause data to be provided for remote control, e.g. for identification of
the instrument or polling a parameter value. Queries are formed by directly
appending a question mark to the command header.

● According to their definition in standards:
– Common commands: their function and syntax are precisely defined in stan-

dard IEEE 488.2. They are employed identically on all instruments (if imple-
mented). They refer to functions such as management of the standardized sta-
tus registers, reset and self-test.

– Instrument control commands refer to functions depending on the features of
the instrument such as frequency settings. Many of these commands have also
been standardized by the SCPI committee. These commands are marked as
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"SCPI confirmed" in the command reference chapters. Commands without this
SCPI label are device-specific; however, their syntax follows SCPI rules as per-
mitted by the standard.

Instrument responses

Instrument responses (response messages and service requests) are messages the
instrument sends to the controller after a query. They can contain measurement
results, instrument settings and information on the instrument status.

A.2 LAN Interface Messages

In the LAN connection, the interface messages are called low–level control messages.
These messages can be used to emulate interface messages of the GPIB bus.

Command Long term Effect on the instrument

&ABO Abort Aborts processing of the commands just received.

&DCL Device Clear Aborts processing of the commands just received and
sets the command processing software to a defined initial
state. Does not change the instrument setting.

&GTL Go to Local Transition to the "local" state (manual control). (The
instrument automatically returns to remote state when a
remote command is sent UNLESS &NREN was sent
before.)

&GTR Go to Remote Enables automatic transition from local state to remote
state by a subsequent remote command (after &NREN
was sent).

&GET Group Execute Trigger Triggers a previously active instrument function (e.g. a
sweep). The effect of the command is the same as with
that of a pulse at the external trigger signal input.

&LLO Local Lockout Disables transition from remote control to manual control
by means of the front panel keys.

&NREN Not Remote Enable Disables automatic transition from local state to remote
state by a subsequent remote command. (To re-activate
automatic transition use &GTR.)

&POL Serial Poll Starts a serial poll.

A.3 SCPI Command Structure

SCPI commands consist of a so-called header and, in most cases, one or more param-
eters. The header and the parameters are separated by a "white space" (ASCII code 0
to 9, 11 to 32 decimal, e.g. blank). The headers may consist of several mnemonics
(keywords). Queries are formed by appending a question mark directly to the header.
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The commands can be either device-specific or device-independent (common com-
mands). Common and device-specific commands differ in their syntax.

A.3.1 Syntax for Common Commands

Common (=device-independent) commands consist of a header preceded by an aster-
isk (*) and possibly one or more parameters.

Examples:

*RST RESET Resets the instrument.

*ESE EVENT STATUS ENABLE Sets the bits of the event status enable
registers.

*ESR? EVENT STATUS QUERY Queries the contents of the event status
register.

*IDN? IDENTIFICATION QUERY Queries the instrument identification
string.

A.3.2 Syntax for Device-Specific Commands

Not all commands used in the following examples are necessarily implemented in the
instrument.
For demonstration purposes only, assume the existence of the following commands for
this section:
● DISPlay[:WINDow<1...4>]:MAXimize <Boolean>
● FORMat:READings:DATA <type>[,<length>]
● HCOPy:DEVice:COLor <Boolean>
● HCOPy:DEVice:CMAP:COLor:RGB <red>,<green>,<blue>
● HCOPy[:IMMediate]
● HCOPy:ITEM:ALL
● HCOPy:ITEM:LABel <string>
● HCOPy:PAGE:DIMensions:QUADrant[<N>]
● HCOPy:PAGE:ORIentation LANDscape | PORTrait
● HCOPy:PAGE:SCALe <numeric value>
● MMEMory:COPY <file_source>,<file_destination>
● SENSE:BANDwidth|BWIDth[:RESolution] <numeric_value>
● SENSe:FREQuency:STOP <numeric value>
● SENSe:LIST:FREQuency <numeric_value>{,<numeric_value>}
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Long and short form

The mnemonics feature a long form and a short form. The short form is marked by
upper case letters, the long form corresponds to the complete word. Either the short
form or the long form can be entered; other abbreviations are not permitted.

Example: 
HCOPy:DEVice:COLor ON is equivalent to HCOP:DEV:COL ON.

Case-insensitivity
Upper case and lower case notation only serves to distinguish the two forms in the
manual, the instrument itself is case-insensitive.

Numeric suffixes

If a command can be applied to multiple instances of an object, e.g. specific channels
or sources, the required instances can be specified by a suffix added to the command.
Numeric suffixes are indicated by angular brackets (<1...4>, <n>, <i>) and are replaced
by a single value in the command. Entries without a suffix are interpreted as having the
suffix 1.

Example: 
Definition: HCOPy:PAGE:DIMensions:QUADrant[<N>]
Command: HCOP:PAGE:DIM:QUAD2
This command refers to the quadrant 2.

Different numbering in remote control
For remote control, the suffix may differ from the number of the corresponding selec-
tion used in manual operation. SCPI prescribes that suffix counting starts with 1. Suffix
1 is the default state and used when no specific suffix is specified.
Some standards define a fixed numbering, starting with 0. If the numbering differs in
manual operation and remote control, it is indicated for the corresponding command.

Optional mnemonics

Some command systems permit certain mnemonics to be inserted into the header or
omitted. These mnemonics are marked by square brackets in the description. The
instrument must recognize the long command to comply with the SCPI standard. Some
commands are considerably shortened by these optional mnemonics.

Example: 
Definition: HCOPy[:IMMediate]
Command: HCOP:IMM is equivalent to HCOP
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Optional mnemonics with numeric suffixes
Do not omit an optional mnemonic if it includes a numeric suffix that is relevant for the
effect of the command.
Example:
Definition:DISPlay[:WINDow<1...4>]:MAXimize <Boolean>
Command: DISP:MAX ON refers to window 1.

In order to refer to a window other than 1, you must include the optional WINDow
parameter with the suffix for the required window.
DISP:WIND2:MAX ON refers to window 2.

Parameters

Parameters must be separated from the header by a "white space". If several parame-
ters are specified in a command, they are separated by a comma (,). For a description
of the parameter types, refer to Chapter A.3.3, "SCPI Parameters", on page 199.

Example: 
Definition:HCOPy:DEVice:CMAP:COLor:RGB <red>,<green>,<blue>
Command:HCOP:DEV:CMAP:COL:RGB 3,32,44
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Special characters

| Parameters

A vertical stroke in parameter definitions indicates alternative possibilities in the sense of "or". The
effect of the command differs, depending on which parameter is used.

Example:

Definition:HCOPy:PAGE:ORIentation LANDscape | PORTrait
Command HCOP:PAGE:ORI LAND specifies landscape orientation

Command HCOP:PAGE:ORI PORT specifies portrait orientation

Mnemonics

A selection of mnemonics with an identical effect exists for several commands. These mnemonics are
indicated in the same line; they are separated by a vertical stroke. Only one of these mnemonics
needs to be included in the header of the command. The effect of the command is independent of
which of the mnemonics is used.

Example:

DefinitionSENSE:BANDwidth|BWIDth[:RESolution] <numeric_value>
The two following commands with identical meaning can be created:

SENS:BAND:RES 1
SENS:BWID:RES 1

[ ] Mnemonics in square brackets are optional and may be inserted into the header or omitted.

Example: HCOPy[:IMMediate]
HCOP:IMM is equivalent to HCOP

{ } Parameters in curly brackets are optional and can be inserted once or several times, or omitted.

Example: SENSe:LIST:FREQuency <numeric_value>{,<numeric_value>}
The following are valid commands:

SENS:LIST:FREQ 10
SENS:LIST:FREQ 10,20
SENS:LIST:FREQ 10,20,30,40

A.3.3 SCPI Parameters

Many commands are supplemented by a parameter or a list of parameters. The
parameters must be separated from the header by a "white space" (ASCII code 0 to 9,
11 to 32 decimal, e.g. blank). Allowed parameters are:

● Numeric values
● Special numeric values
● Boolean parameters
● Text
● Character strings
● Block data

The parameters required for each command and the allowed range of values are
specified in the command description.
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Numeric values

Numeric values can be entered in any form, i.e. with sign, decimal point and exponent.
Values exceeding the resolution of the instrument are rounded up or down. The man-
tissa may comprise up to 255 characters, the exponent must lie inside the value range
-32000 to 32000. The exponent is introduced by an "E" or "e". Entry of the exponent
alone is not allowed. In the case of physical quantities, the unit can be entered.
Allowed unit prefixes are G (giga), MA (mega), MOHM and MHZ are also allowed), K
(kilo), M (milli), U (micro) and N (nano). If the unit is missing, the basic unit is used.

Example: SENS:FREQ:STOP 1.5GHz = SENS:FREQ:STOP 1.5E9

Units

For physical quantities, the unit can be entered. Allowed unit prefixes are:

● G (giga)
● MA (mega), MOHM, MHZ
● K (kilo)
● M (milli)
● U (micro)
● N (nano)

If the unit is missing, the basic unit is used.

Example: 
SENSe:FREQ:STOP 1.5GHz = SENSe:FREQ:STOP 1.5E9

Some settings allow relative values to be stated in percent. According to SCPI, this unit
is represented by the PCT string.

Example: 
HCOP:PAGE:SCAL 90PCT

Special numeric values

The texts listed below are interpreted as special numeric values. In the case of a
query, the numeric value is provided.

● MIN/MAX
MINimum and MAXimum denote the minimum and maximum value.

● DEF
DEFault denotes a preset value which has been stored in the EPROM. This value
conforms to the default setting, as it is called by the *RST command.

● UP/DOWN
UP, DOWN increases or reduces the numeric value by one step. The step width
can be specified via an allocated step command for each parameter which can be
set via UP, DOWN.

● INF/NINF
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INFinity, Negative INFinity (NINF) represent the numeric values 9.9E37 or -9.9E37,
respectively. INF and NINF are only sent as instrument responses.

● NAN
Not A Number (NAN) represents the value 9.91E37. NAN is only sent as a instru-
ment response. This value is not defined. Possible causes are the division of zero
by zero, the subtraction of infinite from infinite and the representation of missing
values.

Example: 
Setting command: SENSe:LIST:FREQ MAXimum
Query: SENS:LIST:FREQ?, Response: 3.5E9

Queries for special numeric values
The numeric values associated to MAXimum/MINimum/DEFault can be queried by
adding the corresponding mnemonics to the command. They must be entered follow-
ing the quotation mark.
Example: SENSe:LIST:FREQ? MAXimum
Returns the maximum numeric value as a result.

Boolean Parameters

Boolean parameters represent two states. The "ON" state (logically true) is represen-
ted by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by
"OFF" or the numeric value 0. The numeric values are provided as the response for a
query.

Example: 
Setting command: HCOPy:DEV:COL ON
Query: HCOPy:DEV:COL?
Response: 1

Text parameters

Text parameters observe the syntactic rules for mnemonics, i.e. they can be entered
using a short or long form. Like any parameter, they have to be separated from the
header by a white space. In the case of a query, the short form of the text is provided.

Example: 
Setting command: HCOPy:PAGE:ORIentation LANDscape
Query: HCOP:PAGE:ORI?
Response: LAND

Character strings

Strings must always be entered in quotation marks (' or ").
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Example: 
HCOP:ITEM:LABel "Test1" or HCOP:ITEM:LABel 'Test1'

Block data

Block data is a format which is suitable for the transmission of large amounts of data. A
command using a block data parameter has the following structure:

Example: 
FORMat:READings:DATA #45168xxxxxxxx
The ASCII character # introduces the data block. The next number indicates how many
of the following digits describe the length of the data block. In the example the 4 follow-
ing digits indicate the length to be 5168 bytes. The data bytes follow. During the trans-
mission of these data bytes all end or other control signs are ignored until all bytes are
transmitted.
#0 specifies a data block of indefinite length. The use of the indefinite format requires a
NL^END message to terminate the data block. This format is useful when the length of
the transmission is not known or if speed or other considerations prevent segmentation
of the data into blocks of definite length.

A.3.4 Overview of Syntax Elements

The following table provides an overview of the syntax elements:

: The colon separates the mnemonics of a command. In a command line the separating semico-
lon marks the uppermost command level.

; The semicolon separates two commands of a command line. It does not alter the path.

, The comma separates several parameters of a command.

? The question mark forms a query.

* The asterisk marks a common command.

' '

"

Quotation marks introduce a string and terminate it (both single and double quotation marks are
possible).

# The hash symbol introduces binary, octal, hexadecimal and block data.
● Binary: #B10110
● Octal: #O7612
● Hexa: #HF3A7
● Block: #21312

A "white space" (ASCII-Code 0 to 9, 11 to 32 decimal, e.g. blank) separates the header from the
parameters.

A.3.5 Structure of a command line

A command line may consist of one or several commands. It is terminated by one of
the following:
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● a <New Line>
● a <New Line> with EOI
● an EOI together with the last data byte

Several commands in a command line must be separated by a semicolon ";". If the
next command belongs to a different command system, the semicolon is followed by a
colon.

Example: 
MMEM:COPY "Test1","MeasurementXY";:HCOP:ITEM ALL
This command line contains two commands. The first command belongs to the MMEM
system, the second command belongs to the HCOP system.

If the successive commands belong to the same system, having one or several levels
in common, the command line can be abbreviated. To this end, the second command
after the semicolon starts with the level that lies below the common levels. The colon
following the semicolon must be omitted in this case.

Example: 
HCOP:ITEM ALL;:HCOP:IMM
This command line contains two commands. Both commands are part of the HCOP
command system, i.e. they have one level in common.
When abbreviating the command line, the second command begins with the level
below HCOP. The colon after the semicolon is omitted. The abbreviated form of the
command line reads as follows:
HCOP:ITEM ALL;IMM

A new command line always begins with the complete path.

Example: 
HCOP:ITEM ALL
HCOP:IMM

A.3.6 Responses to Queries

A query is defined for each setting command unless explicitly specified otherwise. It is
formed by adding a question mark to the associated setting command. According to
SCPI, the responses to queries are partly subject to stricter rules than in standard
IEEE 488.2.

● The requested parameter is transmitted without a header.
Example: HCOP:PAGE:ORI?, Response: LAND

● Maximum values, minimum values and all other quantities that are requested via a
special text parameter are returned as numeric values.
Example: SENSe:FREQuency:STOP? MAX, Response: 3.5E9
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● Numeric values are output without a unit. Physical quantities are referred to the
basic units or to the units set using the Unit command. The response 3.5E9 in
the previous example stands for 3.5 GHz.

● Truth values (Boolean values) are returned as 0 (for OFF) and 1 (for ON).
Example:
Setting command: HCOPy:DEV:COL ON
Query: HCOPy:DEV:COL?
Response: 1

● Text (character data) is returned in a short form.
Example:
Setting command: HCOPy:PAGE:ORIentation LANDscape
Query: HCOP:PAGE:ORI?
Response: LAND

A.4 Command Sequence and Synchronization

IEEE 488.2 defines a distinction between overlapped and sequential commands:

● A sequential command is one which finishes executing before the next command
starts executing. Commands that are processed quickly are usually implemented
as sequential commands. Sequential commands are not implemented in the instru-
ment, however the execution time of most commands is so short that they act as
sequential commands when sent in different command lines.

● An overlapping command is one which does not automatically finish executing
before the next command starts executing. Usually, overlapping commands take
longer to process and allow the program to do other tasks while being executed. If
overlapping commands do have to be executed in a defined order, e.g. in order to
avoid wrong measurement results, they must be serviced sequentially. This is
called synchronization between the controller and the instrument.

Setting commands within one command line, even though they may be implemented
as sequential commands, are not necessarily serviced in the order in which they have
been received. In order to make sure that commands are actually carried out in a cer-
tain order, each command must be sent in a separate command line.

As a general rule, send commands and queries in different program messages.

A.4.1 Preventing Overlapping Execution

To prevent an overlapping execution of commands, one of the commands *OPC,
*OPC? or *WAI can be used. All three commands cause a certain action only to be
carried out after the hardware has been set. By suitable programming, the controller
can be forced to wait for the corresponding action to occur.
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Table A-1: Synchronization using *OPC, *OPC? and *WAI

Com-
mand

Action Programming the controller

*OPC Sets the Operation Complete bit in the ESR
after all previous commands have been exe-
cuted.

● Setting bit 0 in the ESE
● Setting bit 5 in the SRE
● Waiting for service request (SRQ)

*OPC? Stops command processing until 1 is
returned. This is only the case after the Oper-
ation Complete bit has been set in the ESR.
This bit indicates that the previous setting has
been completed.

Sending *OPC? directly after the command
whose processing should be terminated
before other commands can be executed.

*WAI Stops further command processing until all
commands sent before *WAI have been exe-
cuted.

Sending *WAI directly after the command
whose processing should be terminated
before other commands are executed.

Command synchronization using *WAI or *OPC? is a good choice if the overlapped
command takes only little time to process. The two synchronization commands simply
block overlapped execution of the command. Append the synchronization command to
the overlapping command, for example:

SINGle; *OPC?
For time consuming overlapped commands you can allow the controller or the instru-
ment to do other useful work while waiting for command execution. Use one of the fol-
lowing methods:

*OPC with a service request

1. Set the OPC mask bit (bit no. 0) in the ESE: *ESE 1

2. Set bit no. 5 in the SRE: *SRE 32 to enable ESB service request.

3. Send the overlapped command with *OPC

4. Wait for a service request

The service request indicates that the overlapped command has finished.

*OPC? with a service request

1. Set bit no. 4 in the SRE: *SRE 16 to enable MAV service request.

2. Send the overlapped command with *OPC?

3. Wait for a service request

The service request indicates that the overlapped command has finished.

Event Status Register (ESE)

1. Set the OPC mask bit (bit no. 0) in the ESE: *ESE 1

2. Send the overlapped command without *OPC, *OPC? or *WAI
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3. Poll the operation complete state periodically (by means of a timer) using the
sequence: *OPC; *ESR?

A return value (LSB) of 1 indicates that the overlapped command has finished.

A.5 Status Reporting System

The status reporting system stores all information on the current operating state of the
instrument, and on errors which have occurred. This information is stored in the status
registers and in the error queue.

You can query both with the commands of the STATus Subsystem.

A.5.1 Hierarchy of the Status Registers

The Figure A-1 shows the hierarchical structure of information in the status registers
(ascending from left to right).
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Figure A-1: Graphical overview of the status registers hierarchy

OPER = Operation Status Summary Bit
RQS/MSS = Service Request Generation
ESB = Standard Event Status Summary Bit
MAV = Message Available in Output Queue
QUES = Questionable Status Summary Bit
2 = Error- /Event-Queue
1, 0 = not used

Note: This legend explains the abbreviations to the Status Byte Register.

The R&S SGU uses the following status registers:
● Status Byte (STB) and Service Request Enable (SRE), see Chapter A.5.3, "Sta-

tus Byte (STB) and Service Request Enable Register (SRE)", on page 210.
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● Standard Event Status, i.e. the Event status Register (ESR) and the Event Status
Enable (ESE), see Chapter A.5.4, "Event Status Register (ESR) and Event Status
Enable Register (ESE)", on page 211.

● Questionable Status and Operation Status, the (SCPI status registers, see
Chapter A.5.2, "Structure of a SCPI Status Register", on page 208, Chapter A.5.5,
"Questionable Status Register (STATus:QUEStionable)", on page 211 and Chap-
ter A.5.6, "Operation Status Register (STATus:OPERation)", on page 212.

● Output-Queue
The output queue contains the messages the instrument returns to the controller. It
is not part of the status reporting system but determines the value of the MAV bit in
the STB and thus is represented in the overview.

● Error- /Event-Queue
The error-/event-queue contains all errors and events that have occurred in the
past. When reading the queue, the instrument starts with the first occurred error/
event.

All status registers have the same internal structure.

SRE, ESE
The service request enable register SRE can be used as ENABle part of the STB if the
STB is structured according to SCPI. By analogy, the ESE can be used as the ENABle
part of the ESR.

A.5.2 Structure of a SCPI Status Register

Each standard SCPI register consists of 5 parts. Each part has a width of 16 bits and
has different functions. The individual bits are independent of each other, i.e. each
hardware status is assigned a bit number which is valid for all five parts. Bit 15 (the
most significant bit) is set to zero for all parts. Thus the contents of the register parts
can be processed by the controller as positive integers.

Figure A-2: The status-register model
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Description of the five status register parts

The five parts of a SCPI register have different properties and functions:

● CONDition
The CONDition part is written into directly by the hardware or the sum bit of the
next lower register. Its contents reflect the current instrument status. This register
part can only be read, but not written into or cleared. Its contents are not affected
by reading.

● PTRansition / NTRansition
The two transition register parts define which state transition of the CONDition
part (none, 0 to 1, 1 to 0 or both) is stored in the EVENt part.
The Positive-TRansition part acts as a transition filter. When a bit of the
CONDition part is changed from 0 to 1, the associated PTR bit decides whether
the EVENt bit is set to 1.

– PTR bit =1: the EVENt bit is set.

– PTR bit =0: the EVENt bit is not set.

This part can be written into and read as required. Its contents are not affected by
reading.
The Negative-TRansition part also acts as a transition filter. When a bit of the
CONDition part is changed from 1 to 0, the associated NTR bit decides whether
the EVENt bit is set to 1.

– NTR bit =1: the EVENt bit is set.

– NTR bit =0: the EVENt bit is not set.

This part can be written into and read as required. Its contents are not affected by
reading.

● EVENt
The EVENt part indicates whether an event has occurred since the last reading, it
is the "memory" of the condition part. It only indicates events passed on by the
transition filters. It is permanently updated by the instrument. This part can only be
read by the user. Reading the register clears it. This part is often equated with the
entire register.

● ENABle
The ENABle part determines whether the associated EVENt bit contributes to the
sum bit (see below). Each bit of the EVENt part is "ANDed" with the associated
ENABle bit (symbol '&'). The results of all logical operations of this part are passed
on to the sum bit via an "OR" function (symbol '+').
ENABle bit = 0: the associated EVENt bit does not contribute to the sum bit
ENABle bit = 1: if the associated EVENt bit is "1", the sum bit is set to "1" as well.
This part can be written into and read by the user as required. Its contents are not
affected by reading.

Sum bit

The sum bit is obtained from the EVENt and ENABle part for each register. The result
is then entered into a bit of the CONDition part of the higher-order register.
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ManualsPlus.com

https://www.manualsplus.com/


Remote Control BasicsR&S®SGU100A

210User Manual 1176.7726.02 ─ 07

The instrument automatically generates the sum bit for each register. Thus an event
can lead to a service request throughout all levels of the hierarchy.

A.5.3 Status Byte (STB) and Service Request Enable Register (SRE)

The STatus Byte (STB) is already defined in IEEE 488.2. It provides a rough over-
view of the instrument status by collecting the pieces of information of the lower regis-
ters. A special feature is that bit 6 acts as the sum bit of the remaining bits of the status
byte.

The STB is read using the command *STB? or a serial poll.

The STatus Byte (STB) is linked to the Service Request Enable (SRE) register.
Each bit of the STB is assigned a bit in the SRE. Bit 6 of the SRE is ignored. If a bit is
set in the SRE and the associated bit in the STB changes from 0 to 1, a service
request (SRQ) is generated. The SRE can be set using the command *SRE and read
using the command *SRE?.

Table A-2: Meaning of the bits used in the status byte

Bit No. Meaning

0...1 Not used

2 Error Queue not empty

The bit is set when an entry is made in the error queue. If this bit is enabled by the SRE, each
entry of the error queue generates a service request. Thus an error can be recognized and
specified in greater detail by polling the error queue. The poll provides an informative error mes-
sage. This procedure is to be recommended since it considerably reduces the problems
involved with remote control.

3 QUEStionable status register summary bit

The bit is set if an EVENt bit is set in the QUEStionable status register and the associated
ENABle bit is set to 1. A set bit indicates a questionable instrument status, which can be speci-
fied in greater detail by querying the STATus:QUEStionable status register.

4 MAV bit (message available)

The bit is set if a message is available in the output queue which can be read. This bit can be
used to enable data to be automatically read from the instrument to the controller.

5 ESB bit

Sum bit of the event status register. It is set if one of the bits in the event status register is set
and enabled in the event status enable register. Setting of this bit indicates a serious error which
can be specified in greater detail by polling the event status register.

6 MSS bit (master status summary bit)

The bit is set if the instrument triggers a service request. This is the case if one of the other bits
of this registers is set together with its mask bit in the service request enable register SRE.

7 STATus:OPERation status register summary bit

The bit is set if an EVENt bit is set in the OPERation status register and the associated
ENABle bit is set to 1. A set bit indicates that the instrument is just performing an action. The
type of action can be determined by querying the STATus:OPERation status register.
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A.5.4 Event Status Register (ESR) and Event Status Enable Register
(ESE)

The ESR is defined in IEEE 488.2. It can be compared with the EVENt part of a SCPI
register. The event status register can be read out using command *ESR?.

The ESE corresponds to the ENABle part of a SCPI register. If a bit is set in the ESE
and the associated bit in the ESR changes from 0 to 1, the ESB bit in the STB is set.
The ESE register can be set using the command *ESE and read using the command
*ESE?.

Table A-3: Meaning of the bits used in the event status register

Bit No. Meaning

0 Operation Complete

This bit is set on receipt of the command *OPC exactly when all previous commands have been
executed.

1 Not used

2 Query Error

This bit is set if either the controller wants to read data from the instrument without having sent a
query, or if it does not fetch requested data and sends new instructions to the instrument
instead. The cause is often a query which is faulty and hence cannot be executed.

3 Device-dependent Error

This bit is set if a device-dependent error occurs. An error message with a number between
-300 and -399 or a positive error number, which denotes the error in greater detail, is entered
into the error queue.

4 Execution Error

This bit is set if a received command is syntactically correct but cannot be performed for other
reasons. An error message with a number between -200 and -300, which denotes the error in
greater detail, is entered into the error queue.

5 Command Error

This bit is set if a command is received, which is undefined or syntactically incorrect. An error
message with a number between -100 and -200, which denotes the error in greater detail, is
entered into the error queue.

6 User Request

This bit is set when the instrument is switched over to manual control.

7 Power On (supply voltage on)

This bit is set on switching on the instrument.

A.5.5 Questionable Status Register (STATus:QUEStionable)

This register contains information on questionable instrument states. Such states may
occur when the instrument is not operated in compliance with its specifications.

To read the register, use the query commands STAT:QUEST:COND? or
STAT:QUEST[:EVEN]?.
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Table A-4: Meaning of the bits used in the questionable status register

Bit No. Meaning

0–15 Not used

A.5.6 Operation Status Register (STATus:OPERation)

This condition part contains information on the actions currently being performed by
the instrument, while the event part contains information on the actions performed by
the instrument since the last readout of the register.

To read the register, use the query commands STAT:OPER:COND? or
STAT:OPER[:EVEN]?.

Table A-5: Meaning of the bits used in the operation status register

Bit No. Meaning

0 Calibrating

The bit is set during the calibration phase.

1–2 Not used

3 Sweeping

This bit is set during a sweep in automatic or single mode.

4–15 Not used

A.5.7 Application of the Status Reporting System

The purpose of the status reporting system is to monitor the status of one or several
devices in a measuring system. To do this and react appropriately, the controller must
receive and evaluate the information of all devices. The following standard methods
are used:

● Service request (SRQ) initiated by the instrument
● Serial poll of all devices in the bus system, initiated by the controller to find out

who sent an SRQ and why
● Query of a specific instrument status by commands
● Query of the error queue

A.5.7.1 Service Request

Under certain circumstances, the instrument can send a service request (SRQ) to the
controller. Usually this service request initiates an interrupt at the controller, to which
the control program can react appropriately. An SRQ is always initiated if one or sev-
eral of bits 2, 4 or 5 of the status byte are set and enabled in the SRE. Each of these
bits combines the information of the error queue or the output buffer. To use the possi-
bilities of the service request effectively, all bits should be set to "1" in the enable regis-
ters SRE and ESE.
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Example: 
Use command *OPC to generate an SRQ .

*ESE 1 - set bit 0 of ESE (Operation Complete)

*SRE 32 - set bit 5 of SRE (ESB).

After its settings have been completed, the instrument generates an SRQ.

The SRQ is the only possibility for the instrument to become active on its own. Each
controller program should set the instrument such that a service request is initiated in
the case of malfunction. The program should react appropriately to the service request.

A.5.7.2 Serial Poll

In a serial poll, just as with command *STB, the status byte of an instrument is queried.
However, the query is realized via interface messages and is thus clearly faster.

The serial poll method is defined in IEEE 488.1 and used to be the only standard pos-
sibility for different instruments to poll the status byte. The method also works for
instruments which do not adhere to SCPI or IEEE 488.2.

The serial poll is mainly used to obtain a fast overview of the state of several instru-
ments connected to the controller.

A.5.7.3 Query of an instrument status

Each part of any status register can be read using queries. There are two types of
commands:

● The common commands *ESR?, *IDN?, *IST?, *STB? query the higher-level
registers.

● The commands of the STATus system query the SCPI registers
(STATus:QUEStionable...)

The returned value is always a decimal number that represents the bit pattern of the
queried register. This number is evaluated by the controller program.

Queries are usually used after an SRQ in order to obtain more detailed information on
the cause of the SRQ.

A.5.7.4 Error Queue

Each error state in the instrument leads to an entry in the error queue. The entries of
the error queue are detailed plain text error messages that can be looked up in the
Error Log or queried via remote control using SYSTem:ERRor[:NEXT]?. Each call of
SYSTem:ERRor[:NEXT]? provides one entry from the error queue. If no error mes-
sages are stored there any more, the instrument responds with 0, "No error".

The error queue should be queried after every SRQ in the controller program as the
entries describe the cause of an error more precisely than the status registers. Espe-
cially in the test phase of a controller program the error queue should be queried regu-
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larly since faulty commands from the controller to the instrument are recorded there as
well.

A.5.8 Reset Values of the Status Reporting System

The following table contains the different commands and events causing the status
reporting system to be reset. None of the commands, except of *RST and
SYSTem:PRESet affect the functional instrument settings. In particular, DCL does not
change the instrument settings.

Table A-6: Resetting the status reporting system

Event Switching on supply
voltage

Power-On-Status-
Clear

DCL,
SDC
(Device
Clear,
Selected
Device
Clear)

*RST or
SYSTem:
PRESet

STATus:
PRESet

*CLS

Effect 0 1

Clear STB, ESR - Yes - - - Yes

Clear SRE, ESE - Yes - - - -

Clear PPE - Yes - - - -

Clear error queue Yes Yes - - - Yes

Clear output buffer Yes Yes Yes 1) 1) 1)

Clear command processing
and input buffer

Yes Yes Yes - - -

1) The first command in a command line that immediately follows a <PROGRAM MESSAGE TERMINA-
TOR> clears the output buffer.

A.6 General Programming Recommendations

Initial instrument status before changing settings

Manual operation is designed for maximum possible operating convenience. In con-
trast, the priority of remote control is the "predictability" of the instrument status. Thus,
when a command attempts to define incompatible settings, the command is ignored
and the instrument status remains unchanged, i.e. other settings are not automatically
adapted. Therefore, control programs should always define an initial instrument status
(e.g. using the *RST command) and then implement the required settings.

Command sequence

As a general rule, send commands and queries in different program messages. Other-
wise, the result of the query may vary depending on which operation is performed first
(see also Preventing Overlapping Execution).

 

 

General Programming Recommendations

ManualsPlus.com

https://www.manualsplus.com/


Remote Control BasicsR&S®SGU100A

215User Manual 1176.7726.02 ─ 07

Reacting to malfunctions

The service request is the only possibility for the instrument to become active on its
own. Each controller program should instruct the instrument to initiate a service
request in case of malfunction. The program should react appropriately to the service
request.

Error queues

The error queue should be queried after every service request in the controller pro-
gram as the entries describe the cause of an error more precisely than the status regis-
ters. Especially in the test phase of a controller program the error queue should be
queried regularly since faulty commands from the controller to the instrument are
recorded there as well.
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B Telnet program examples
The following program example shows a simple TcpClient class that is intended to
explain on how to get started with programming of sockets.

The example sets up a socket communication to R&S SGU and opens a simple user
interface, very similar to the telnet, which allows input of commands. To enable real
automation, further development of the program is required.

TcpClient.h

#include <string>
//defines structs for socket handling
#include <netinet/in.h>
using namespace std;
typedef struct sockaddr_in SockAddrStruct;
typedef struct hostent     HostInfoStruct;
class TcpClient
{
  public:
    TcpClient();
    ~TcpClient();
    void connectToServer( string &hostname, int port );
    void disconnect( );
    void transmit( string &txString );
    void receive( string &rxString );
    string getCurrentHostName( ) const;
    int    getCurrentPort( ) const;
  private:
    string           currentHostName;
    int              currentPort;
    int              currentSocketDescr;
    SockAddrStruct   serverAddress;
    HostInfoStruct * currentHostInfo;
    bool             clientIsConnected;
    int              receiveBufferSize;
};

TcpClient.cpp

#include <string>
//defines structs for socket handling
#include <netinet/in.h>
using namespace std;
typedef struct sockaddr_in SockAddrStruct;
typedef struct hostent     HostInfoStruct;
class TcpClient
{
  public:
    TcpClient();
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    ~TcpClient();
    void connectToServer( string &hostname, int port );
    void disconnect( );
    void transmit( string &txString );
    void receive( string &rxString );
    string getCurrentHostName( ) const;
    int    getCurrentPort( ) const;
  private:
    string           currentHostName;
    int              currentPort;
    int              currentSocketDescr;
    SockAddrStruct   serverAddress;
    HostInfoStruct * currentHostInfo;
    bool             clientIsConnected;
    int              receiveBufferSize;
};

#include <netdb.h>
#include <netinet/in.h>
#include <unistd.h>
#include "TcpClient.h"
TcpClient::TcpClient()
: currentHostName( "" )
, currentPort( 0 )
, currentSocketDescr( 0 )
, serverAddress ( )
, currentHostInfo( NULL )
, clientIsConnected( false )
, receiveBufferSize( 1024 )
{
}
TcpClient::~TcpClient()
{
  currentHostInfo = NULL;
}

void TcpClient::connectToServer( string &hostname, int port )
{
  currentHostInfo = gethostbyname( hostname.c_str( ) );
  if( currentHostInfo == NULL )
  {
    currentHostName   = "";
    currentPort       = 0;
    currentHostInfo   = NULL;
    clientIsConnected = false;
    printf("error connecting host\n" );
  }
  currentHostName = hostname;
  currentPort     = port;
  currentSocketDescr = socket(AF_INET, SOCK_STREAM, 0);
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  if( currentSocketDescr == 0 )
  {
    currentHostName   = "";
    currentPort       = 0;
    currentHostInfo   = NULL;
    clientIsConnected = false;
    printf("can't create socket\n" );
  }
  serverAddress.sin_family = currentHostInfo->h_addrtype;
  serverAddress.sin_port   = htons( currentPort );
  memcpy( (char *) &serverAddress.sin_addr.s_addr, 
  currentHostInfo->h_addr_list[0], currentHostInfo->h_length );
  if( connect( currentSocketDescr, ( struct sockaddr *) &serverAddress, 
  sizeof( serverAddress ) ) < 0 )
  {
   throw string("can't connect server\n" );
  }
  clientIsConnected = true;
}
void TcpClient::disconnect( )
{
  if( clientIsConnected )
  {
    close( currentSocketDescr );
  }
  currentSocketDescr = 0;
  currentHostName    = "";
  currentPort        = 0;
  currentHostInfo    = NULL;
  clientIsConnected  = false;
}
void TcpClient::transmit( string &txString )
{
  if( !clientIsConnected )
  {
  throw string("connection must be established before any data can be sent\n");
  }
  char * transmitBuffer = new char[txString.length() +1];
  memcpy( transmitBuffer, txString.c_str(), txString.length() );
  transmitBuffer[txString.length()] = '\n'; //newline is needed!
  if( send( currentSocketDescr, transmitBuffer, txString.length() + 1, 0 ) < 0 )
  {
    throw string("can't transmit data\n");
  }
  delete [] transmitBuffer;
}
void TcpClient::receive( string &rxString )
{
  if( !clientIsConnected )
  {
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  throw string("connection must be established before any data can be received\n");
  }
  char * receiveBuffer = new char[receiveBufferSize];
  memset( receiveBuffer, 0, receiveBufferSize );
  bool receiving = true;
  while( receiving )
  {
    int receivedByteCount = recv( currentSocketDescr, 
    receiveBuffer, receiveBufferSize, 0 );
    if( receivedByteCount < 0 )
    {
      throw string("error while receiving data\n");
    }
    rxString += string( receiveBuffer );
    receiving = ( receivedByteCount == receiveBufferSize );
  }
  delete [] receiveBuffer;
}
string TcpClient::getCurrentHostName( ) const
{
  return currentHostName;
}
int TcpClient::getCurrentPort( ) const
{
  return currentPort;
}

TelnetClient.cpp

#include <iostream>
#include "TcpClient.h"
void printUsage()
{
  cout<<"usage: EthernetRawCommand <server-ip> [scpi-command]"<<endl;
}
int main( int argc, char *argv[] )
{
  int errorCode         = 0; //no error
  bool useSingleCommand = false;
  string singleCommand  = "";
  string hostname       = "";
  int    port           = 5025;
  string input          = "";
  TcpClient client;
  switch( argc )
  {
    case 3:
      useSingleCommand = true;
      singleCommand    = argv[2];
    case 2:
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      hostname         = argv[1];
      break;
    default:
        printUsage();
        return(-1);
  }
  try
  {
    client.connectToServer( hostname, port );
    bool terminate = false;
    while( !terminate )
    {
      char buffer[1024];
      if( useSingleCommand )
      {
        input =  singleCommand; //send string
      }
      else
      {
        cin.getline( buffer, 1024 );
        input = buffer;
        if( input == "end" )
        {
          terminate = true;
        }
      }
      if( !terminate)
      {
        client.transmit( input ); //send string
        int qPos = input.find( "?", 0 );
        //receive string only when needed
        if( qPos > 0 )
        {
          string rcStr = "";
          client.receive( rcStr );
          cout << rcStr << endl;
        }
      }
      if( useSingleCommand )
      {
        terminate = true;
      }
    }
  }catch( const string errorString )
  {
    cout<<errorString<<endl;
  }
  client.disconnect( );
  return errorCode;
}
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